r9291: Add a stub for smb_raw_lpq() which is in smb_interfaces.h but doesn't
authorTim Potter <tpot@samba.org>
Sat, 13 Aug 2005 01:15:32 +0000 (01:15 +0000)
committerGerald (Jerry) Carter <jerry@samba.org>
Wed, 10 Oct 2007 18:33:21 +0000 (13:33 -0500)
seem to be used anywhere yet.

source/libcli/config.mk
source/libcli/raw/rawlpq.c [new file with mode: 0644]

index 5787b1241f034795dd711397a904c27285b0765a..aec06f8023228ecdee6b69ef13d921a57c55c03f 100644 (file)
@@ -103,4 +103,5 @@ OBJ_FILES = libcli/raw/rawfile.o \
                libcli/raw/rawnotify.o \
                libcli/raw/rawioctl.o \
                libcli/raw/rawacl.o \
-               libcli/raw/rawdate.o
+               libcli/raw/rawdate.o \
+               libcli/raw/rawlpq.o
diff --git a/source/libcli/raw/rawlpq.c b/source/libcli/raw/rawlpq.c
new file mode 100644 (file)
index 0000000..e83ee48
--- /dev/null
@@ -0,0 +1,48 @@
+/* 
+   Unix SMB/CIFS implementation.
+   client lpq operations
+   Copyright (C) Tim Potter 2005
+   
+   This program is free software; you can redistribute it and/or modify
+   it under the terms of the GNU General Public License as published by
+   the Free Software Foundation; either version 2 of the License, or
+   (at your option) any later version.
+   
+   This program is distributed in the hope that it will be useful,
+   but WITHOUT ANY WARRANTY; without even the implied warranty of
+   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+   GNU General Public License for more details.
+   
+   You should have received a copy of the GNU General Public License
+   along with this program; if not, write to the Free Software
+   Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+*/
+
+#include "includes.h"
+#include "libcli/raw/libcliraw.h"
+
+/****************************************************************************
+ lpq - async send
+****************************************************************************/
+struct smbcli_request *smb_raw_lpq_send(struct smbcli_tree *tree,
+                                       union smb_lpq *parms)
+{
+       return NULL;
+}
+
+/****************************************************************************
+ lpq - async receive
+****************************************************************************/
+NTSTATUS smb_raw_lpq_recv(struct smbcli_request *req, union smb_lpq *parms)
+{
+       return NT_STATUS_NOT_IMPLEMENTED;
+}
+
+/*
+  lpq - sync interface
+*/
+NTSTATUS smb_raw_lpq(struct smbcli_tree *tree, union smb_lpq *parms)
+{
+       struct smbcli_request *req = smb_raw_lpq_send(tree, parms);
+       return smb_raw_lpq_recv(req, parms);
+}