r13658: More moving around of files:
[jelmer/samba4-debian.git] / source / lib / basic.mk
index 754458fec14719643656cd99187fbffa7c0a1aca..51ca3378a24a58c8f07075de2b3beb51d6ae1d45 100644 (file)
@@ -1,57 +1,70 @@
 # LIB BASIC subsystem
+include com/config.mk
+include samba3/config.mk
+include socket/config.mk
+include charset/config.mk
+include ldb/config.mk
+include talloc/config.mk
+include tdb/config.mk
+include tls/config.mk
+include registry/config.mk
+include messaging/config.mk
+include events/config.mk
+include popt/config.mk
+include cmdline/config.mk
+include socket_wrapper/config.mk
+include appweb/config.mk
+include replace/config.mk
+include stream/config.mk
+include util/config.mk
 
 ##############################
-# Start SUBSYSTEM LIBBASIC
-[SUBSYSTEM::LIBBASIC]
-INIT_OBJ_FILES = lib/version.o
-ADD_OBJ_FILES = \
-               lib/debug.o \
-               lib/fault.o \
-               lib/getsmbpass.o \
-               lib/interface.o \
-               lib/interfaces.o \
-               lib/pidfile.o \
-               lib/replace.o \
-               lib/signal.o \
-               lib/system.o \
-               lib/time.o \
-               lib/genrand.o \
-               lib/username.o \
-               lib/smbrun.o \
-               lib/bitmap.o \
-               lib/snprintf.o \
-               lib/dprintf.o \
-               lib/xfile.o \
-               lib/wins_srv.o \
-               lib/util_str.o \
-               lib/util_sid.o \
-               lib/util_secdesc.o \
-               lib/util_uuid.o \
-               lib/util_unistr.o \
-               lib/util_file.o \
-               lib/data_blob.o \
-               lib/util.o \
-               lib/util_sock.o \
-               lib/talloc.o \
-               lib/substitute.o \
-               lib/fsusage.o \
-               lib/ms_fnmatch.o \
-               lib/select.o \
-               lib/messages.o \
-               lib/tallocmsg.o \
-               lib/dmallocmsg.o \
-               lib/pam_errors.o \
-               intl/lang_tdb.o \
-               lib/gencache.o \
-               lib/module.o \
-               lib/mutex.o \
-               lib/events.o \
-               lib/crypto/crc32.o \
-               lib/crypto/md5.o \
-               lib/crypto/hmacmd5.o \
-               lib/crypto/md4.o \
-               lib/tdb_helper.o
-REQUIRED_SUBSYSTEMS = \
-               LIBTDB CHARSET
-# End SUBSYSTEM LIBBASIC
+# Start SUBSYSTEM LIBNETIF
+[SUBSYSTEM::LIBNETIF]
+OBJ_FILES = \
+               netif/interface.o \
+               netif/netif.o
+# End SUBSYSTEM LIBNETIF
 ##############################
+
+[LIBRARY::TDR]
+PUBLIC_HEADERS = tdr/tdr.h
+MAJOR_VERSION = 0
+MINOR_VERSION = 0
+RELEASE_VERSION = 1
+DESCRIPTION = Simple marshall/unmarshall library
+PRIVATE_PROTO_HEADER = tdr/tdr_proto.h
+OBJ_FILES = tdr/tdr.o
+
+##############################
+# Start SUBSYSTEM LIBCRYPTO
+[SUBSYSTEM::LIBCRYPTO]
+NOPROTO = YES
+OBJ_FILES = \
+               crypto/crc32.o \
+               crypto/md5.o \
+               crypto/hmacmd5.o \
+               crypto/md4.o \
+               crypto/arcfour.o
+# End SUBSYSTEM LIBCRYPTO
+##############################
+
+################################################
+# Start SUBSYSTEM LIBCOMPRESSION
+[SUBSYSTEM::LIBCOMPRESSION]
+OBJ_FILES = \
+               compression/mszip.o
+# End SUBSYSTEM LIBCOMPRESION
+################################################
+
+[SUBSYSTEM::GENCACHE]
+PRIVATE_PROTO_HEADER = gencache/gencache.h
+OBJ_FILES = \
+               gencache/gencache.o \
+
+[SUBSYSTEM::DB_WRAP]
+OBJ_FILES = db_wrap.o \
+               gendb.o
+REQUIRED_SUBSYSTEMS = LIBLDB LIBTDB
+
+