r15387: Fix installation of dcerpc headers, remove more instances of uint_t
authorJelmer Vernooij <jelmer@samba.org>
Mon, 1 May 2006 23:03:32 +0000 (23:03 +0000)
committerGerald (Jerry) Carter <jerry@samba.org>
Wed, 10 Oct 2007 19:05:31 +0000 (14:05 -0500)
source/build/smb_build/config_mk.pm
source/libcli/nbt/libnbt.h
source/ntvfs/cifs_posix_cli/cvfs.h
source/ntvfs/ntvfs.h
source/ntvfs/simple/svfs.h
source/param/loadparm.h
source/rpc_server/config.mk

index 7880745538085890c1125c1f6753f7ef8528a868..80da0ab2fac9fdc57a2e46e545330d0f3b24b785 100644 (file)
@@ -55,6 +55,10 @@ my $section_types = {
 
                "MANPAGE"               => "string",
                "PRIVATE_PROTO_HEADER"  => "string",
+               "PUBLIC_PROTO_HEADER"   => "string",
+
+
+               "PUBLIC_HEADERS"        => "list",
 
                "CFLAGS"                => "string"
                },
index e828beb29f96198cf0c0815baa4e367fea740f86..521c4f52bd5ed1e51458451063023e8ab8b7ab8a 100644 (file)
@@ -74,7 +74,7 @@ struct nbt_name_request {
        /* shall we allow multiple replies? */
        BOOL allow_multiple_replies;
 
-       uint_t num_replies;
+       unsigned int num_replies;
        struct nbt_name_reply {
                struct nbt_name_packet *packet;
                struct socket_address *dest;
index 8e462d99f44acad68972a547d83f9f6e988cbfeb..74e7b6c4529676aa4ef0be5c2093899e37f240c0 100644 (file)
@@ -13,7 +13,7 @@ struct svfs_private {
 };
 
 struct svfs_dir {
-       uint_t count;
+       unsigned int count;
        char *unix_dir;
        struct svfs_dirfile {
                char *name;
@@ -30,6 +30,6 @@ struct svfs_file {
 struct search_state {
        struct search_state *next, *prev;
        uint16_t handle;
-       uint_t current_index;
+       unsigned int current_index;
        struct svfs_dir *dir;
 };
index 3d12c5efc9f52bae53c9f78e8adbc52ce211da35..9069e6c2ac7f33bab2b56c6d653a69aee1da0f72 100644 (file)
@@ -223,7 +223,7 @@ struct ntvfs_context {
 struct ntvfs_async_state {
        struct ntvfs_async_state *prev, *next;
        /* the async handling infos */
-       uint_t state;
+       unsigned int state;
        void *private_data;
        void (*send_fn)(struct ntvfs_request *);
        NTSTATUS status;
index 8e462d99f44acad68972a547d83f9f6e988cbfeb..74e7b6c4529676aa4ef0be5c2093899e37f240c0 100644 (file)
@@ -13,7 +13,7 @@ struct svfs_private {
 };
 
 struct svfs_dir {
-       uint_t count;
+       unsigned int count;
        char *unix_dir;
        struct svfs_dirfile {
                char *name;
@@ -30,6 +30,6 @@ struct svfs_file {
 struct search_state {
        struct search_state *next, *prev;
        uint16_t handle;
-       uint_t current_index;
+       unsigned int current_index;
        struct svfs_dir *dir;
 };
index cbd017db7ccb649d9428f44c09505933ff4dd795..5e3bcea523341b3a058c6c64427cea1ba8bda4d4 100644 (file)
@@ -49,7 +49,7 @@ struct parm_struct {
        void *ptr;
        BOOL (*special)(const char *, char **);
        const struct enum_list *enum_list;
-       uint_t flags;
+       unsigned int flags;
        union {
                BOOL bvalue;
                int ivalue;
index 63fb1cefccdc7b74176ca68ff893b0637c9de1fe..17e5ca8d81d7e17e3ad748db645440a301afd804 100644 (file)
@@ -209,8 +209,8 @@ PUBLIC_DEPENDENCIES = \
 [MODULE::dcerpc_server]
 INIT_FUNCTION = server_service_rpc_init
 SUBSYSTEM = service
-#PUBLIC_HEADERS = dcerpc_server.h
-PRIVATE_PROTO_HEADER = dcerpc_server_proto.h
+PUBLIC_HEADERS = dcerpc_server.h
+PUBLIC_PROTO_HEADER = dcerpc_server_proto.h
 OBJ_FILES = \
                dcerpc_server.o \
                dcerpc_sock.o \