Print warning when config.status doesn't exist and the user tries to
authorJelmer Vernooij <jelmer@samba.org>
Mon, 11 Feb 2008 14:52:34 +0000 (15:52 +0100)
committerJelmer Vernooij <jelmer@samba.org>
Mon, 11 Feb 2008 14:52:34 +0000 (15:52 +0100)
run make.

source/Makefile

index e734b01834efa85945a0c818372056f5e0cd7334..a5f32e19d6b2c344ac03d8a73b2e497df6fd385d 100644 (file)
@@ -164,6 +164,10 @@ uninstallheader::
 uninstallman::
        @$(SHELL) $(srcdir)/script/uninstallman.sh $(DESTDIR)$(mandir) $(MANPAGES)
 
+config.status:
+       @echo "config.status does not exist. Please run ./configure."
+       @/bin/false
+
 data.mk: config.status $(MK_FILES)
        ./config.status