60d8099edbf787b1faeba413a136046b482c3dae
[garming/samba-autobuild/.git] / packaging / SuSE / 7.1 / samba.spec
1 #
2 # spec file for package samba (Version 2.0.7)
3
4 # Copyright  (c)  2000  SuSE GmbH  Nuernberg, Germany.
5 #
6 # please send bugfixes or comments to feedback@suse.de.
7 #
8
9 # neededforbuild  automake openldap
10 # usedforbuild    aaa_base aaa_dir autoconf automake base bash bindutil binutils bison bzip compress cpio cracklib devs diff ext2fs file fileutil find flex gawk gcc gdbm gettext gpm gppshare groff gzip kbd less libc libtool libz lx_suse make mktemp modules ncurses net_tool netcfg nkita nkitb nssv1 openldap pam patch perl pgp ps rcs rpm sendmail sh_utils shadow shlibs strace syslogd sysvinit texinfo textutil timezone unzip util vim xdevel xf86 xshared
11
12 Vendor:       SuSE GmbH, Nuernberg, Germany
13 Distribution: SuSE Linux 7.1a (i386)
14 Name:         samba
15 Release:      0
16 Packager:     feedback@suse.de
17
18 Copyright:    1992-95 Andrew Tridgell, Karl Auer, Jeremy Allison
19 Group:        Networking/Daemons
20 Url:          http://www.samba.org
21 Provides:     samba smbfs 
22 Requires:     smbclnt
23 Autoreqprov:  on
24 Version:      2.2
25 Summary:      An SMB file server for Unix
26 Source: samba-2.2.0-alpha0.tar.gz
27 Source1: samba.pamd
28 Patch: samba-2.2.0-alpha0.dif
29 %package -n smbclnt
30 Summary:      Samba client utilities
31 Autoreqprov:  on
32 Group:        Networking
33 %prep
34 %setup -n samba-2.2.0-alpha0
35 %patch
36
37 %build
38 cd source
39 %{?suse_update_config:%{suse_update_config -f}}
40 LIBS=-lnsl \
41 ./configure --prefix=/usr --libdir=/etc \
42         --with-privatedir=/etc --localstatedir=/var/log \
43         --with-smbmount --with-pam \
44         --mandir=%{_mandir} \
45         --with-swatdir=/usr/lib/samba/swat \
46         --with-sambabook=/usr/lib/samba/swat/using_samba
47 cd ..
48 make LOCKDIR=/var/lock/samba SBINDIR=/usr/sbin \
49         CODEPAGEDIR=/usr/lib/samba/codepages -C source
50
51 %install
52 mkdir -p /usr/lib/samba
53 make install LOCKDIR=/var/lock/samba SBINDIR=/usr/sbin \
54         CODEPAGEDIR=/usr/lib/samba/codepages -C source
55 # cleanup docs
56 rm -rf docs/*.[0-9]
57 chmod 644 `find docs examples -type f`
58 chmod 755 `find docs examples -type d`
59 #utility scripts
60 mkdir -p /usr/lib/samba/scripts
61 cp -a source/script/* /usr/lib/samba/scripts
62 # configuration files
63 install -m 644 smb.conf /etc/smb.conf
64 install -m 644 lmhosts /etc/lmhosts
65 install -m 600 smbpasswd -o root -g root /etc/smbpasswd
66 install -d 755 /etc/pam.d
67 install -m 644 $RPM_SOURCE_DIR/samba.pamd /etc/pam.d/samba
68 install -m 755 mount.smbfs /sbin/mount.smbfs
69 # start script
70 install rc /sbin/init.d/smb
71 ln -sf ../smb /sbin/init.d/rc2.d/S20smb
72 ln -sf ../smb /sbin/init.d/rc2.d/K20smb
73 ln -sf ../smb /sbin/init.d/rc3.d/S20smb
74 ln -sf ../smb /sbin/init.d/rc3.d/K20smb
75 ln -sf ../../sbin/init.d/smb /usr/sbin/rcsmb
76 install smbfs /sbin/init.d/smbfs
77 ln -sf ../smbfs /sbin/init.d/rc2.d/S21smbfs
78 ln -sf ../smbfs /sbin/init.d/rc2.d/K19smbfs
79 ln -sf ../smbfs /sbin/init.d/rc3.d/S21smbfs
80 ln -sf ../smbfs /sbin/init.d/rc3.d/K19smbfs
81 ln -sf ../../sbin/init.d/smbfs /usr/sbin/rcsmbfs
82 # rc.config fragment
83 mkdir -p /var/adm/fillup-templates
84 cp rc.config.samba /var/adm/fillup-templates
85 %{?suse_check}
86
87 %post
88 echo "Updating etc/rc.config..."
89 if [ -x bin/fillup ] ; then
90   bin/fillup -q -d = etc/rc.config var/adm/fillup-templates/rc.config.samba
91 else
92   echo "ERROR: fillup not found. This should not happen. Please compare"
93   echo "etc/rc.config and var/adm/fillup-templates/rc.config.samba and"
94   echo "update by hand."
95 fi
96 if grep -q '^[#[:space:]]*swat' etc/inetd.conf ; then
97    echo /etc/inetd.conf is up to date
98 else
99    echo updating inetd.conf
100    cat >> etc/inetd.conf << EOF
101 # swat is the Samba Web Administration Tool
102 swat    stream  tcp     nowait.400  root    /usr/sbin/swat swat
103 EOF
104 fi
105 if grep -q '^swat' etc/services ; then
106    echo /etc/services is up to date
107 else
108    echo updating services
109    cat >> etc/services << EOF
110 swat            901/tcp         # swat is the Samba Web Administration Tool
111 EOF
112 fi
113 mkdir -p var/adm/notify/messages
114 cat << EOF > var/adm/notify/messages/samba-notify
115 Achtung!
116 ========
117 Die Syntax des smbmount Kommandos hat sich geaendert!
118 smbmount kann nicht mehr direkt aufgerufen werden. Es wird von einem
119 Shellscript /sbin/mount.smbfs aufgerufen, welches wiederum von mount
120 aufgerufen wird.
121 Hier ein Beispielaufruf:
122 mount -t smbfs -o username=uname,password=passwd //smbserv/share /destination
123 *****************************************************************************
124 Attention!
125 ==========
126 The syntax of smbmount has changed!
127 smbmount can not be called direct anymore. It will be called by a shell
128 script /sbin/mount.smbfs, which will be called by mount.
129 A sample call to smbfs:
130 mount -t smbfs -o username=uname,password=passwd //smbserv/share /destination
131 EOF
132
133 %files
134 %config(noreplace) /etc/smb.conf
135 %config(noreplace) /etc/lmhosts
136 %config(noreplace) /etc/smbpasswd
137 %config /etc/pam.d/samba
138 /usr/lib/samba
139 /sbin/init.d/rc2.d/K20smb
140 /sbin/init.d/rc2.d/S20smb
141 /sbin/init.d/rc3.d/K20smb
142 /sbin/init.d/rc3.d/S20smb
143 %config /sbin/init.d/smb
144 /usr/bin/addtosmbpass
145 /usr/bin/convert_smbpasswd
146 /usr/bin/make_printerdef
147 /usr/bin/make_smbcodepage
148 /usr/bin/make_unicodemap
149 /usr/bin/smbpasswd
150 /usr/bin/smbstatus
151 /usr/bin/testparm
152 /usr/bin/testprns
153 %doc docs/* examples
154 %doc %{_mandir}/man1/make_smbcodepage.1.gz
155 %doc %{_mandir}/man1/make_unicodemap.1.gz
156 %doc %{_mandir}/man1/smbrun.1.gz
157 %doc %{_mandir}/man1/smbsh.1.gz
158 %doc %{_mandir}/man1/smbstatus.1.gz
159 %doc %{_mandir}/man1/testparm.1.gz
160 %doc %{_mandir}/man1/testprns.1.gz
161 %doc %{_mandir}/man5/lmhosts.5.gz
162 %doc %{_mandir}/man5/smb.conf.5.gz
163 %doc %{_mandir}/man5/smbpasswd.5.gz
164 %doc %{_mandir}/man7/samba.7.gz
165 %doc %{_mandir}/man8/nmbd.8.gz
166 %doc %{_mandir}/man8/smbd.8.gz
167 %doc %{_mandir}/man8/smbpasswd.8.gz
168 %doc %{_mandir}/man8/swat.8.gz
169 /usr/sbin/nmbd
170 /usr/sbin/rcsmb
171 /usr/sbin/smbd
172 /usr/sbin/swat
173 /var/adm/fillup-templates/rc.config.samba
174
175 %files -n smbclnt
176 /sbin/init.d/rc2.d/K19smbfs
177 /sbin/init.d/rc2.d/S21smbfs
178 /sbin/init.d/rc3.d/K19smbfs
179 /sbin/init.d/rc3.d/S21smbfs
180 %config /sbin/init.d/smbfs
181 /usr/sbin/rcsmbfs
182 /sbin/mount.smbfs
183 /usr/bin/nmblookup
184 /usr/bin/rpcclient
185 /usr/bin/smbclient
186 /usr/bin/smbmnt
187 /usr/bin/smbmount
188 /usr/bin/smbumount
189 /usr/bin/smbspool
190 /usr/bin/smbtar
191 %doc %{_mandir}/man1/nmblookup.1.gz
192 %doc %{_mandir}/man1/smbclient.1.gz
193 %doc %{_mandir}/man1/smbtar.1.gz
194 %doc %{_mandir}/man8/smbmnt.8.gz
195 %doc %{_mandir}/man8/smbmount.8.gz
196 %doc %{_mandir}/man8/smbspool.8.gz
197 %doc %{_mandir}/man8/smbumount.8.gz
198
199 %description
200 Samba is a suite of programs which work together to allow clients to
201 access Unix filespace and printers via the SMB protocol (Server Message
202 Block). 
203 In practice, this means that you can redirect disks and printers to
204 Unix disks and printers from LAN Manager clients, Windows for
205 Workgroups 3.11 clients, Windows'95 clients, Windows NT clients
206 and OS/2 clients. There is
207 also a Unix client program supplied as part of the suite which allows
208 Unix users to use an ftp-like interface to access filespace and
209 printers on any other SMB server.
210 Samba includes the following programs (in summary):
211 * smbd, the SMB server. This handles actual connections from clients.
212 * nmbd, the Netbios name server, which helps clients locate servers.
213 * smbclient, the Unix-hosted client program.
214 * smbrun, a little 'glue' program to help the server run external
215 programs. 
216 * testprns, a program to test server access to printers.
217 * testparm, a program to test the Samba configuration file for correctness.
218 * smb.conf, the Samba configuration file.
219 * smbprint, a sample script to allow a Unix host to use smbclient
220 to print to an SMB server.
221 The suite is supplied with full source and is GPLed.
222 This package expects its config file under /etc/smb.conf .
223
224 Authors:
225 --------
226     Andrew Tridgell <Andrew.Tridgell@anu.edu.au>
227     Karl Auer <Karl.Auer@anu.edu.au>
228     Jeremy Allison <jeremy@netcom.com>
229
230 SuSE series: n
231
232
233 %description -n smbclnt
234 This package contains all programs, that are needed to act as a samba
235 client. This includes also smbmount, of course.
236
237 Authors:
238 --------
239     Andrew Tridgell <Andrew.Tridgell@anu.edu.au>
240     Karl Auer <Karl.Auer@anu.edu.au>
241     Jeremy Allison <jeremy@netcom.com>
242
243 SuSE series: n
244
245
246 %changelog -n samba
247 * Mon Aug 28 2000 - choeger@suse.de
248 - changed $* to "$@" in mount.smbfs to make it also
249   possible to mount shares with spaces
250 * Mon Jul 31 2000 - choeger@suse.de
251 - improvement for rcsmb
252 - fix for spec-file to compile with NIS netgroups
253 * Thu Jul 20 2000 - choeger@suse.de
254 - added smbfs initscript that has been removed
255   by an error
256 * Tue Jul 11 2000 - choeger@suse.de
257 - split package into client and server parts
258   client package name: smbclnt
259 * Wed Apr 26 2000 - choeger@suse.de
260 - new version, 2.0.7
261 * Thu Apr 06 2000 - ro@suse.de
262 - removed pam,cracklib from neededforbuild: build handles this
263 * Wed Apr 05 2000 - bk@suse.de
264 - s390 team added config.{sub,guess} update macro for s390
265 * Mon Mar 27 2000 - choeger@suse.de
266 - fixed bug in specfile
267   the multilined configure call missed a "" :-(
268 * Thu Mar 09 2000 - choeger@suse.de
269 - fixed typo in specfile
270 * Wed Mar 01 2000 - choeger@suse.de
271 - added %{_mandir}
272 * Tue Feb 08 2000 - choeger@suse.de
273 - removed /sbin/init.d/smbfs because it is no longer needed
274 * Mon Jan 03 2000 - choeger@suse.de
275 - bugfix for ipc.c
276   to make roaming profiles work again.
277 * Tue Nov 30 1999 - choeger@suse.de
278 - changed kernel oplocks = off to
279   kernel oplocks = false
280 * Tue Nov 16 1999 - choeger@suse.de
281 - added kernel oplocks = off in smb.conf
282 * Fri Nov 12 1999 - choeger@suse.de
283 - new version, 2.0.6
284 * Fri Nov 05 1999 - choeger@suse.de
285 - Fix for the smbmount lost-connection problem
286   _seems_ to work...
287 * Fri Oct 29 1999 - choeger@suse.de
288 - removed comment sign in /etc/inetd.conf for swat
289 * Mon Sep 13 1999 - bs@suse.de
290 - ran old prepare_spec on spec file to switch to new prepare_spec.
291 * Tue Aug 10 1999 - fehr@suse.de
292 - set execute permissions for mksmbpasswd.sh and changesmbpasswd.sh
293 * Thu Jul 29 1999 - fehr@suse.de
294 - fixed typo in /sbin/init.d/smbfs
295 * Thu Jul 22 1999 - fehr@suse.de
296 - changed to new version 2.0.5a
297 * Wed Jul 21 1999 - fehr@suse.de
298 - changed to new version 2.0.5
299 * Tue Jul 20 1999 - fehr@suse.de
300 - install /sbin/init.d/smbfs
301 - changed to new version 2.0.5pre4
302 * Mon Jul 19 1999 - fehr@suse.de
303 - add /sbin/init.d/smbfs
304 - changed to new version 2.0.5pre3
305 * Fri Jul 02 1999 - fehr@suse.de
306 - removed "umount -a -t smbfs" from start sscript
307 * Tue Jun 22 1999 - kukuk@suse.de
308 - 2.0.4b changed default values, enable PAM again
309 * Fri Jun 18 1999 - kukuk@suse.de
310 - changed to new version 2.0.4b
311 * Mon Jun 14 1999 - kukuk@suse.de
312 - Enable PAM, add samba.pamd
313 * Mon May 03 1999 - fehr@suse.de
314 - add umount -a -t smbfs to shutdown sequence of samba
315 * Thu Mar 11 1999 - ro@suse.de
316 - smbmount: define NR_OPEN to 1024 if undefined (GLIBC-2.1)
317 * Wed Mar 10 1999 - choeger@suse.de
318 - some enhancements for smb.conf
319 * Wed Mar 10 1999 - choeger@suse.de
320 - new version 2.0.3 and smbmount now seems to work
321 * Tue Mar 09 1999 - ro@suse.de
322 - use samba-2.0.2 for STABLE
323 - use smbfs-2.1 with kernel 2.2.2
324 * Sun Feb 28 1999 - ro@suse.de
325 - for glibc-2.1 strncat uses strcat for one subcase, so don't
326   redefine strcat to "ERROR" for glibc-2.1
327 * Mon Feb 15 1999 - fehr@suse.de
328 - fix for umount problem from Volker
329 * Tue Feb 09 1999 - fehr@suse.de
330 - changed to version 2.0.2 of samba
331 * Fri Jan 15 1999 - bs@suse.de
332 - replaced /sbin/init.d/smb with newer style version (again)
333 * Fri Jan 15 1999 - fehr@suse.de
334 - switched to new version 2.0.0
335 * Wed Jan 13 1999 - bs@suse.de
336 - fixed entry in inetd.conf
337 * Wed Jan 13 1999 - bs@suse.de
338 - replaced /sbin/init.d/smb with newer style version
339 * Mon Jan 11 1999 - vl@suse.de
340 - make 2.0.0beta5 package of samba
341 * Mon Aug 24 1998 - vl@suse.de
342 - changed to version 1.9.18p10
343 * Mon Jun 29 1998 - vl@suse.de
344 - changed to version 1.9.18p8
345 * Mon Apr 20 1998 - vl@suse.de
346 - changed to version 1.9.18p4
347 * Thu Feb 19 1998 - vl@suse.de
348 - changed to version 1.9.18p3
349 * Tue Feb 03 1998 - vl@suse.de
350 - changed to version 1.9.18p2
351 - fixed some problems in spec-file, some files were missing :-(
352 - fixed smbfs-2.0.2/Makefile.Linux
353 * Tue Jan 13 1998 - vl@suse.de
354 - changed to version 1.9.18p1
355 * Fri Jan 09 1998 - vl@suse.de
356 - changed to version 1.9.18
357 * Tue Dec 02 1997 - bs@suse.de
358 - disable samba by default in /etc/rc.config
359 * Mon Oct 06 1997 - fehr@suse.de
360 - package prepared for automatic building
361 * Mon Sep 29 1997 - fehr@suse.de
362 - updated to version 1.9.17p2 due to security hole.
363 * Wed Jul 16 1997 - fehr@suse.de
364 - add fillup-template for rc.config and install it in doinst.sh
365 * Fri Jun 27 1997 - bs@suse.de
366 - update to smbfs-2.0.2, due to security hole.
367 * Tue Jun 17 1997 - fehr@suse.de
368 - changed init-skript to recognize entry START_SMB of rc.config
369 * Mon Jun 02 1997 - vl@suse.de
370 - update to version 1.9.16p11
371 - Starting Samba from /sbin/init.d, not from inetd.conf
372 * Sun Feb 02 1997 - vl@suse.de
373 - update to version 1.9.16p10
374 - Adapted /etc/smb.conf.sample to 4.4.1 manual
375 * Thu Jan 02 1997 - florian@suse.de
376 - update to version 1.9.16p9
377 - configuration file is now /etc/smb.conf
378 - smbd and nmbd are now in /usr/sbin
379 - added start-script /sbin/init.d/smb and entry in /etc/rc.config
380 * Thu Jan 02 1997 - florian@suse.de
381 - Update auf neue Version 1.9.16p6.