pam_wrapper: Be strict when checking __attribute__ features
authorAmitay Isaacs <amitay@gmail.com>
Tue, 3 Jul 2018 04:45:04 +0000 (14:45 +1000)
committerKarolin Seeger <kseeger@samba.org>
Tue, 10 Jul 2018 08:44:13 +0000 (10:44 +0200)
BUG: https://bugzilla.samba.org/show_bug.cgi?id=13493

Signed-off-by: Amitay Isaacs <amitay@gmail.com>
Reviewed-by: Andreas Schneider <asn@samba.org>
(cherry picked from commit 65b0746694a0cbd8f40c5e89dc9a680044f7a1a9)

third_party/pam_wrapper/wscript

index b9acf1b96ebeca241dcd0bd273177ba4f6c405f8..24bc4e5672b2366c4794534e9648f7b51f2390f7 100644 (file)
@@ -44,6 +44,7 @@ def configure(conf):
             ''',
             'HAVE_DESTRUCTOR_ATTRIBUTE',
             addmain=False,
+            strict=True,
             msg='Checking for library destructor support')
 
         # check HAVE_FUNCTION_ATTRIBUTE_FORMAT
@@ -56,6 +57,7 @@ def configure(conf):
             ''',
             'HAVE_FUNCTION_ATTRIBUTE_FORMAT',
             addmain=False,
+            strict=True,
             msg='Checking for printf format validation support')
 
         conf.CHECK_HEADERS('security/pam_appl.h')