lib: Change nss_wrapper to preloadable version.
[sfrench/samba-autobuild/.git] / wscript
1 #!/usr/bin/env python
2
3 srcdir = '.'
4 blddir = 'bin'
5
6 APPNAME='samba'
7 VERSION=None
8
9 import sys, os, tempfile
10 sys.path.insert(0, srcdir+"/buildtools/wafsamba")
11 import wafsamba, Options, samba_dist, Scripting, Utils, samba_version
12
13
14 samba_dist.DIST_DIRS('.')
15 samba_dist.DIST_BLACKLIST('.gitignore .bzrignore source4/selftest/provisions/alpha13 source4/selftest/provisions/release-4-0-0/ source4/selftest/provisions/release-4-1-0rc3/')
16
17 # install in /usr/local/samba by default
18 Options.default_prefix = '/usr/local/samba'
19
20 # This callback optionally takes a list of paths as arguments:
21 # --with-system_mitkrb5 /path/to/krb5 /another/path
22 def system_mitkrb5_callback(option, opt, value, parser):
23     setattr(parser.values, option.dest, True)
24     value = []
25     for arg in parser.rargs:
26         # stop on --foo like options
27         if arg[:2] == "--" and len(arg) > 2:
28             break
29         value.append(arg)
30     if len(value)>0:
31         del parser.rargs[:len(value)]
32         setattr(parser.values, option.dest, value)
33
34 def set_options(opt):
35     opt.BUILTIN_DEFAULT('NONE')
36     opt.PRIVATE_EXTENSION_DEFAULT('samba4')
37     opt.RECURSE('lib/replace')
38     opt.RECURSE('dynconfig')
39     opt.RECURSE('lib/ldb')
40     opt.RECURSE('lib/ntdb')
41     opt.RECURSE('selftest')
42     opt.RECURSE('source4/lib/tls')
43     opt.RECURSE('lib/socket_wrapper')
44     opt.RECURSE('pidl')
45     opt.RECURSE('source3')
46     opt.RECURSE('lib/util')
47
48     opt.add_option('--with-system-mitkrb5',
49                    help='enable system MIT krb5 build (includes Samba 4 client and Samba 3 code base).'+
50                         'You may specify list of paths where Kerberos is installed (e.g. /usr/local /usr/kerberos) to search krb5-config',
51                    action='callback', callback=system_mitkrb5_callback, dest='with_system_mitkrb5', default=False)
52
53     opt.add_option('--without-ad-dc',
54                    help='disable AD DC functionality (enables Samba 4 client and Samba 3 code base).',
55                    action='store_true', dest='without_ad_dc', default=False)
56
57     opt.add_option('--with-pie',
58                   help=("Build Position Independent Executables " +
59                         "(default if supported by compiler)"),
60                   action="store_true", dest='enable_pie')
61     opt.add_option('--without-pie',
62                   help=("Disable Position Independent Executable builds"),
63                   action="store_false", dest='enable_pie')
64
65     opt.add_option('--with-relro',
66                   help=("Build with full RELocation Read-Only (RELRO)" +
67                         "(default if supported by compiler)"),
68                   action="store_true", dest='enable_relro')
69     opt.add_option('--without-relro',
70                   help=("Disable RELRO builds"),
71                   action="store_false", dest='enable_relro')
72
73     gr = opt.option_group('developer options')
74
75
76     opt.tool_options('python') # options for disabling pyc or pyo compilation
77     # enable options related to building python extensions
78
79
80 def configure(conf):
81     version = samba_version.load_version(env=conf.env)
82
83     conf.DEFINE('CONFIG_H_IS_FROM_SAMBA', 1)
84     conf.DEFINE('_SAMBA_BUILD_', version.MAJOR, add_to_cflags=True)
85     conf.DEFINE('HAVE_CONFIG_H', 1, add_to_cflags=True)
86
87     if Options.options.developer:
88         conf.ADD_CFLAGS('-DDEVELOPER -DDEBUG_PASSWORD')
89         conf.env.DEVELOPER = True
90
91     conf.ADD_EXTRA_INCLUDES('#include/public #source4 #lib #source4/lib #source4/include #include #lib/replace')
92
93     conf.RECURSE('lib/replace')
94
95     conf.find_program('perl', var='PERL', mandatory=True)
96     conf.find_program('xsltproc', var='XSLTPROC')
97
98     conf.SAMBA_CHECK_PYTHON(mandatory=True, version=(2,5,0))
99     conf.SAMBA_CHECK_PYTHON_HEADERS(mandatory=True)
100
101     if sys.platform == 'darwin' and not conf.env['HAVE_ENVIRON_DECL']:
102         # Mac OSX needs to have this and it's also needed that the python is compiled with this
103         # otherwise you face errors about common symbols
104         if not conf.CHECK_SHLIB_W_PYTHON("Checking if -fno-common is needed"):
105             conf.ADD_CFLAGS('-fno-common')
106         if not conf.CHECK_SHLIB_W_PYTHON("Checking if -undefined dynamic_lookup is not need"):
107             conf.env.append_value('shlib_LINKFLAGS', ['-undefined', 'dynamic_lookup'])
108
109     if sys.platform == 'darwin':
110         conf.ADD_LDFLAGS('-framework CoreFoundation')
111
112     if int(conf.env['PYTHON_VERSION'][0]) >= 3:
113         raise Utils.WafError('Python version 3.x is not supported by Samba yet')
114
115     conf.RECURSE('dynconfig')
116     conf.RECURSE('lib/ldb')
117
118     if Options.options.with_system_mitkrb5:
119         conf.PROCESS_SEPARATE_RULE('system_mitkrb5')
120     if not (Options.options.without_ad_dc or Options.options.with_system_mitkrb5):
121         conf.DEFINE('AD_DC_BUILD_IS_ENABLED', 1)
122     # Only process heimdal_build for non-MIT KRB5 builds
123     # When MIT KRB5 checks are done as above, conf.env.KRB5_VENDOR will be set
124     # to the lowcased output of 'krb5-config --vendor'.
125     # If it is not set or the output is 'heimdal', we are dealing with
126     # system-provided or embedded Heimdal build
127     if conf.CONFIG_GET('KRB5_VENDOR') in (None, 'heimdal'):
128         conf.RECURSE('source4/heimdal_build')
129     conf.RECURSE('source4/lib/tls')
130     conf.RECURSE('source4/ntvfs/sysdep')
131     conf.RECURSE('lib/util')
132     conf.RECURSE('lib/ccan')
133     conf.RECURSE('lib/ntdb')
134     conf.RECURSE('lib/zlib')
135     conf.RECURSE('lib/util/charset')
136     conf.RECURSE('source4/auth')
137     conf.RECURSE('lib/nss_wrapper')
138     conf.RECURSE('nsswitch')
139     conf.RECURSE('lib/socket_wrapper')
140     conf.RECURSE('lib/uid_wrapper')
141     conf.RECURSE('lib/popt')
142     conf.RECURSE('lib/iniparser/src')
143     conf.RECURSE('lib/subunit/c')
144     conf.RECURSE('libcli/smbreadline')
145     conf.RECURSE('lib/crypto')
146     conf.RECURSE('pidl')
147     conf.RECURSE('selftest')
148     conf.RECURSE('source3')
149
150     conf.SAMBA_CHECK_UNDEFINED_SYMBOL_FLAGS()
151
152     # gentoo always adds this. We want our normal build to be as
153     # strict as the strictest OS we support, so adding this here
154     # allows us to find problems on our development hosts faster.
155     # It also results in faster load time.
156
157     if not sys.platform.startswith("openbsd"):
158         conf.env.asneeded_ldflags = conf.ADD_LDFLAGS('-Wl,--as-needed', testflags=True)
159
160     if not conf.CHECK_NEED_LC("-lc not needed"):
161         conf.ADD_LDFLAGS('-lc', testflags=False)
162
163     # we don't want PYTHONDIR in config.h, as otherwise changing
164     # --prefix causes a complete rebuild
165     del(conf.env.defines['PYTHONDIR'])
166     del(conf.env.defines['PYTHONARCHDIR'])
167
168     if not conf.CHECK_CODE('#include "tests/summary.c"',
169                            define='SUMMARY_PASSES',
170                            addmain=False,
171                            msg='Checking configure summary'):
172         raise Utils.WafError('configure summary failed')
173     
174     conf.SAMBA_CONFIG_H('include/config.h')
175
176     if Options.options.enable_pie != False:
177         if Options.options.enable_pie == True:
178                 need_pie = True
179         else:
180                 # not specified, only build PIEs if supported by compiler
181                 need_pie = False
182         if conf.check_cc(cflags='-fPIE', ldflags='-pie', mandatory=need_pie,
183                          msg="Checking compiler for PIE support"):
184                 conf.env['ENABLE_PIE'] = True
185
186     if Options.options.enable_relro != False:
187         if Options.options.enable_relro == True:
188             need_relro = True
189         else:
190             # not specified, only build RELROs if supported by compiler
191             need_relro = False
192         if conf.check_cc(cflags='', ldflags='-Wl,-z,relro,-z,now', mandatory=need_relro,
193                          msg="Checking compiler for full RELRO support"):
194             conf.env['ENABLE_RELRO'] = True
195
196 def etags(ctx):
197     '''build TAGS file using etags'''
198     import Utils
199     source_root = os.path.dirname(Utils.g_module.root_path)
200     cmd = 'rm -f %s/TAGS && (find %s -name "*.[ch]" | egrep -v \.inst\. | xargs -n 100 etags -a)' % (source_root, source_root)
201     print("Running: %s" % cmd)
202     os.system(cmd)
203
204 def ctags(ctx):
205     "build 'tags' file using ctags"
206     import Utils
207     source_root = os.path.dirname(Utils.g_module.root_path)
208     cmd = 'ctags --python-kinds=-i $(find %s -name "*.[ch]" | grep -v "*_proto\.h" | egrep -v \.inst\.) $(find %s -name "*.py")' % (source_root, source_root)
209     print("Running: %s" % cmd)
210     os.system(cmd)
211
212 # putting this here enabled build in the list
213 # of commands in --help
214 def build(bld):
215     '''build all targets'''
216     samba_version.load_version(env=bld.env, is_install=bld.is_install)
217     pass
218
219
220 def pydoctor(ctx):
221     '''build python apidocs'''
222     bp = os.path.abspath('bin/python')
223     mpaths = {}
224     for m in ['talloc', 'tdb', 'ldb', 'ntdb']:
225         f = os.popen("PYTHONPATH=%s python -c 'import %s; print %s.__file__'" % (bp, m, m), 'r')
226         try:
227             mpaths[m] = f.read().strip()
228         finally:
229             f.close()
230     cmd='PYTHONPATH=%s pydoctor --introspect-c-modules --project-name=Samba --project-url=http://www.samba.org --make-html --docformat=restructuredtext --add-package bin/python/samba --add-module %s --add-module %s --add-module %s' % (
231         bp, mpaths['tdb'], mpaths['ldb'], mpaths['talloc'], mpaths['ntdb'])
232     print("Running: %s" % cmd)
233     os.system(cmd)
234
235
236 def pep8(ctx):
237     '''run pep8 validator'''
238     cmd='PYTHONPATH=bin/python pep8 -r bin/python/samba'
239     print("Running: %s" % cmd)
240     os.system(cmd)
241
242
243 def wafdocs(ctx):
244     '''build wafsamba apidocs'''
245     from samba_utils import recursive_dirlist
246     os.system('pwd')
247     list = recursive_dirlist('../buildtools/wafsamba', '.', pattern='*.py')
248
249     cmd='PYTHONPATH=bin/python pydoctor --project-name=wafsamba --project-url=http://www.samba.org --make-html --docformat=restructuredtext'
250     print(list)
251     for f in list:
252         cmd += ' --add-module %s' % f
253     print("Running: %s" % cmd)
254     os.system(cmd)
255
256
257 def dist():
258     '''makes a tarball for distribution'''
259     sambaversion = samba_version.load_version(env=None)
260
261     os.system(srcdir + "/release-scripts/build-manpages-nogit")
262     samba_dist.DIST_FILES('bin/docs:docs', extend=True)
263
264     if sambaversion.IS_SNAPSHOT:
265         # write .distversion file and add to tar
266         if not os.path.isdir(blddir):
267             os.makedirs(blddir)
268         distversionf = tempfile.NamedTemporaryFile(mode='w', prefix='.distversion',dir=blddir)
269         for field in sambaversion.vcs_fields:
270             distveroption = field + '=' + str(sambaversion.vcs_fields[field])
271             distversionf.write(distveroption + '\n')
272         distversionf.flush()
273         samba_dist.DIST_FILES('%s:.distversion' % distversionf.name, extend=True)
274
275         samba_dist.dist()
276         distversionf.close()
277     else:
278         samba_dist.dist()
279
280
281 def distcheck():
282     '''test that distribution tarball builds and installs'''
283     samba_version.load_version(env=None)
284     import Scripting
285     d = Scripting.distcheck
286     d()
287
288 def wildcard_cmd(cmd):
289     '''called on a unknown command'''
290     from samba_wildcard import run_named_build_task
291     run_named_build_task(cmd)
292
293 def main():
294     from samba_wildcard import wildcard_main
295     wildcard_main(wildcard_cmd)
296 Scripting.main = main
297
298 def reconfigure(ctx):
299     '''reconfigure if config scripts have changed'''
300     import samba_utils
301     samba_utils.reconfigure(ctx)