Merge tag 'firewire-update' of git://git.kernel.org/pub/scm/linux/kernel/git/ieee1394...
authorLinus Torvalds <torvalds@linux-foundation.org>
Sun, 6 Jan 2019 02:33:21 +0000 (18:33 -0800)
committerLinus Torvalds <torvalds@linux-foundation.org>
Sun, 6 Jan 2019 02:33:21 +0000 (18:33 -0800)
Pull firewire fixlet from Stefan Richter:
 "Remove an explicit dependency in Kconfig which is implied by another
  dependency"

* tag 'firewire-update' of git://git.kernel.org/pub/scm/linux/kernel/git/ieee1394/linux1394:
  firewire: Remove depends on HAS_DMA in case of platform dependency

drivers/firewire/Kconfig

index 145974f9662b63e603e18ac40a013f1f9a8ba2ad..4199849e37585181eace8176b55d4e81cbfd06db 100644 (file)
@@ -1,5 +1,4 @@
 menu "IEEE 1394 (FireWire) support"
-       depends on HAS_DMA
        depends on PCI || COMPILE_TEST
        # firewire-core does not depend on PCI but is
        # not useful without PCI controller driver