From Gerhard Gappmeier: Here is some information for Gentoo users who want to contrib...
authorjake <jake@f5534014-38df-0310-8fa8-9805f1628bb7>
Wed, 12 Jul 2006 16:44:23 +0000 (16:44 +0000)
committerjake <jake@f5534014-38df-0310-8fa8-9805f1628bb7>
Wed, 12 Jul 2006 16:44:23 +0000 (16:44 +0000)
git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@18722 f5534014-38df-0310-8fa8-9805f1628bb7

docbook/README.txt

index 1c64bf668a6fa3bab7bcb016923f16b5665573a0..23c26301237d6c4c8119d933b3e17c756994bb78 100644 (file)
@@ -90,7 +90,26 @@ jimi:                N/A - build yourself - see above
 
 Packages for Gentoo
 -------------------
-TODO
+Like with all packages do...
+Check dependencies: emerge -p <package>
+Install it:         emerge <package>
+
+Tool/File      Package                  Opt./Mand.   Comments
+---------      -------                  ----------   --------
+xsltproc:      libxslt                  M            XSLT processer. A very fast processor writtin in C.
+xmllint:       libxml2                  O            Xml Validator. You probably want to install that.
+fop:           fop                      O            Only needed to generate PDFs. Has a lot of JAVA dependencies.
+docbook.xsl:   docbook-xsl-stylesheets  M            Necessary docbook catalogs are built automatically by portage in /etc/xml and /etc/sgml
+chunk.xsl:     docbook-xsl-stylesheets  M              using "/usr/bin/build-docbook-catalog".
+htmlhelp.xsl:  docbook-xsl-stylesheets  M              So docbook runs out of the box on Gentoo.
+docbookx.dtd:  docbook-xml-dtd          M
+jimi:          sun-jimi                 O            Jimi is a class library for managing images. Used by fop.
+Quanta+         quanta or kdewebdev      O            Nice HTML/XML/SGML and Docbook editor with Syntaxhighlighting, Autocompletion, etc.
+
+Tip: The actual DTD version of Gentoo is 4.4, but wireshark docs still use 4.2.
+     To be able to generate the docs, change the version in the second line of developer-guide.xml
+     or install an older version of the DTD.
+     See into the Gentoo handbook howto unmask old versions.
 
 Packages for Fedora Core
 ------------------------