Define GTK_DISABLE_DEPRECATED only if GTK lt 3.2 since
authorwmeier <wmeier@f5534014-38df-0310-8fa8-9805f1628bb7>
Thu, 29 Dec 2011 16:58:41 +0000 (16:58 +0000)
committerwmeier <wmeier@f5534014-38df-0310-8fa8-9805f1628bb7>
Thu, 29 Dec 2011 16:58:41 +0000 (16:58 +0000)
GTK 3.2 deprecates GtkVBox & GtkHBox which are currently used extensively by Wireshark.

git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@40326 f5534014-38df-0310-8fa8-9805f1628bb7

configure.in

index 70e693d27e27ba81e4d016a105e0e612897d3ce1..cdaefdcbfe327be072a40cc35bf1912f55449688 100644 (file)
@@ -860,7 +860,11 @@ else
        AM_PATH_GLIB_2_0(2.14.0, , AC_MSG_ERROR(GLib 2.14 or later distribution not found.), gthread gmodule)
 
        CFLAGS="-DGTK_DISABLE_SINGLE_INCLUDES $CFLAGS"
-       CFLAGS="-DGTK_DISABLE_DEPRECATED $CFLAGS"
+       ## Define GTK_DISABLE_DEPRECATED only if GTK lt 3.2
+       ## GTK 3.2 deprecates GtkVBox & GtkHBox which are currently used extensively by Wireshark.
+       if test $gtk_config_major_version -eq 2 -o $gtk_config_minor_version -lt 2; then
+               CFLAGS="-DGTK_DISABLE_DEPRECATED $CFLAGS"
+       fi
        # CFLAGS="-DGDK_DISABLE_DEPRECATED $CFLAGS"
        if test $gtk_config_major_version -eq 2 -a $gtk_config_minor_version -ge 20; then
                # Enable GSEAL when building with GTK > 2.20 and < 3.0