Simplify logic wrt. GTK_INST_VERSION
authorkrj <krj@f5534014-38df-0310-8fa8-9805f1628bb7>
Sat, 29 Aug 2009 05:39:33 +0000 (05:39 +0000)
committerkrj <krj@f5534014-38df-0310-8fa8-9805f1628bb7>
Sat, 29 Aug 2009 05:39:33 +0000 (05:39 +0000)
git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@29612 f5534014-38df-0310-8fa8-9805f1628bb7

config.nmake

index 502c8e6cf3245f902e3e463db6db64447c68c1bc..4788b55ef531ab0c2b797e4a1c6fc5baa637e741 100644 (file)
@@ -929,27 +929,7 @@ GTK_LIBS=$(GTK_DIR)\lib\gtk-win32-2.0.lib \
        $(GTK_DIR)\lib\pango-1.0.lib \
        $(GLIB_LIBS)
 
-!IF "$(GTK_INST_VERSION)" == "2.16"
-GTK_LIB_DIR=2.10.0
-NEED_LIBPNG_DLL=USE
-NEED_LIBJPEG_DLL=USE
-NEED_LIBTIFF_DLL=USE
-NEED_CAIRO_DLL=USE
-GTK_WIMP_DLLSRC_DIR=$(GTK_DIR)\lib\gtk-2.0\2.10.0\engines
-GTK_WIMP_DLLDST_DIR=lib\gtk-2.0\2.10.0\engines
-GTK_WIMP_RCSRC_DIR=$(GTK_DIR)\share\themes\MS-Windows\gtk-2.0
-GTK_WIMP_RCDST_DIR=etc\gtk-2.0
-!ELSEIF "$(GTK_INST_VERSION)" == "2.14"
-GTK_LIB_DIR=2.10.0
-NEED_LIBPNG_DLL=USE
-NEED_LIBJPEG_DLL=USE
-NEED_LIBTIFF_DLL=USE
-NEED_CAIRO_DLL=USE
-GTK_WIMP_DLLSRC_DIR=$(GTK_DIR)\lib\gtk-2.0\2.10.0\engines
-GTK_WIMP_DLLDST_DIR=lib\gtk-2.0\2.10.0\engines
-GTK_WIMP_RCSRC_DIR=$(GTK_DIR)\share\themes\MS-Windows\gtk-2.0
-GTK_WIMP_RCDST_DIR=etc\gtk-2.0
-!ELSEIF "$(GTK_INST_VERSION)" == "2.12"
+!IF "$(GTK_INST_VERSION)" == "2.16" || "$(GTK_INST_VERSION)" == "2.14" || "$(GTK_INST_VERSION)" == "2.12"
 GTK_LIB_DIR=2.10.0
 NEED_LIBPNG_DLL=USE
 NEED_LIBJPEG_DLL=USE