Move some code (including the optional objects) into libwsutil
[obnox/wireshark/wip.git] / wsutil / Makefile.am
index f99671e77304ad9afd690b8059c4537357d6e117..84a643b6cfd185488ae190ebbbe212f76347695c 100644 (file)
@@ -6,7 +6,6 @@
 # By Gerald Combs <gerald@wireshark.org>
 # Copyright 1998 Gerald Combs
 #
-#
 # This program is free software; you can redistribute it and/or
 # modify it under the terms of the GNU General Public License
 # as published by the Free Software Foundation; either version 2
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
 
+ACLOCAL_AMFLAGS = `../aclocal-flags`
+
+include Makefile.common
+
 if HAVE_WARNINGS_AS_ERRORS
 AM_CFLAGS = -Werror
 endif
 
+# Optional objects that I know how to build. These will be
+# linked into libwsutil.
+wsutil_optional_objects =      \
+       @GETOPT_O@              \
+       @STRERROR_O@            \
+       @STRNCASECMP_O@         \
+       @STRPTIME_O@            \
+       @INET_PTON_LO@          \
+       @INET_NTOP_LO@
+
 lib_LTLIBRARIES = libwsutil.la
 
+INCLUDES = -I$(srcdir)/..
+
+libwsutil_la_SOURCES =         \
+       $(LIBWSUTIL_SRC)        \
+       $(LIBWSUTIL_INCLUDES)
+
+libwsutil_la_LIBADD =  \
+       @GLIB_LIBS@     \
+       $(wsutil_optional_objects)
+
+EXTRA_DIST =           \
+       Makefile.common \
+       Makefile.nmake  \
+       file_util.c     \
+       file_util.h     \
+       inet_ntop.c     \
+       inet_pton.c     \
+       inet_v6defs.h   \
+       libwsutil.def   \
+       strerror.c      \
+       strerror.h      \
+       strncasecmp.c   \
+       strptime.c      \
+       strptime.h      \
+       unicode-utils.c \
+       unicode-utils.h \
+       wsgetopt.c      \
+       wsgetopt.h
+
 CLEANFILES = \
        libwsutil.a     \
        libwsutil.la    \
@@ -35,12 +77,7 @@ CLEANFILES = \
 MAINTAINERCLEANFILES = \
        Makefile.in
 
-libwsutil_la_SOURCES = \
-       mpeg-audio.c    \
-       mpeg-audio.h
-
-libwsutil_la_LIBADD = @GLIB_LIBS@
-
-EXTRA_DIST = \
-       Makefile.nmake
-
+checkapi:
+       $(PERL) ../tools/checkAPIs.pl -g abort -g termoutput \
+       $(LIBWSUTIL_SRC)
+#      file_util.c unicode-utils.c