Add Cmake stuff to the source distribution so more people can try it out.
[obnox/wireshark/wip.git] / tools / lemon / Makefile.am
index acdca29d65746d46c92dd6f518cdf30db192b9ef..20d6200e4b4d3fc33cdd2964eee05c5412a161ee 100644 (file)
@@ -3,9 +3,8 @@
 # $Id$
 #
 # Wireshark - Network traffic analyzer
-# By Gerald Combs <gerald@zing.org>
+# By Gerald Combs <gerald@wireshark.org>
 # Copyright 2001 Gerald Combs
-#
 # 
 # This program is free software; you can redistribute it and/or
 # modify it under the terms of the GNU General Public License
 # is an archive library, any executable linking against libwireshark will
 # also need to link against libftypes.
 
+if HAVE_WARNINGS_AS_ERRORS
+AM_CFLAGS = -Werror
+endif
+
 noinst_PROGRAMS = lemon
 
 CLEANFILES = \
@@ -34,8 +37,8 @@ CLEANFILES = \
 MAINTAINERCLEANFILES = \
        Makefile.in
 
-lemon_SOURCES = \
-       lemon.c
+lemon$(EXEEXT): lemon.c
+       $(CC_FOR_BUILD) -D_U_="" $(CFLAGS_FOR_BUILD) $(LDFLAGS_FOR_BUILD) -o $@ $?
 
 EXTRA_DIST = \
        cppmagic.h              \
@@ -44,5 +47,6 @@ EXTRA_DIST = \
        lemonflex-tail.inc      \
        lempar.c                \
        Makefile.nmake          \
-       README
+       README                  \
+       CMakeLists.txt