From Alexis La Goutte:
[obnox/wireshark/wip.git] / tools / Makefile.am
index 1fb8621e33b695c299fb28168ba3aeae521a3ff1..b7835b125ccb7551685b7ff1cb7625257101c861 100644 (file)
@@ -25,26 +25,31 @@ SUBDIRS = lemon
 
 PIDL_FILES= \
        pidl/MANIFEST                                   \
+       pidl/META.yml                                   \
        pidl/Makefile.PL                                \
        pidl/README                                     \
        pidl/TODO                                       \
        pidl/expr.yp                                    \
        pidl/idl.yp                                     \
        pidl/lib/Parse/Pidl.pm                          \
+       pidl/lib/Parse/Pidl/CUtil.pm                    \
        pidl/lib/Parse/Pidl/Compat.pm                   \
        pidl/lib/Parse/Pidl/Dump.pm                     \
        pidl/lib/Parse/Pidl/Expr.pm                     \
        pidl/lib/Parse/Pidl/IDL.pm                      \
        pidl/lib/Parse/Pidl/NDR.pm                      \
+       pidl/lib/Parse/Pidl/ODL.pm                      \
        pidl/lib/Parse/Pidl/Samba3/ClientNDR.pm         \
        pidl/lib/Parse/Pidl/Samba3/ServerNDR.pm         \
        pidl/lib/Parse/Pidl/Samba4.pm                   \
-       pidl/lib/Parse/Pidl/Samba4/EJS.pm               \
+       pidl/lib/Parse/Pidl/Samba4/COM/Header.pm        \
+       pidl/lib/Parse/Pidl/Samba4/COM/Proxy.pm         \
+       pidl/lib/Parse/Pidl/Samba4/COM/Stub.pm          \
        pidl/lib/Parse/Pidl/Samba4/Header.pm            \
        pidl/lib/Parse/Pidl/Samba4/NDR/Client.pm        \
        pidl/lib/Parse/Pidl/Samba4/NDR/Parser.pm        \
        pidl/lib/Parse/Pidl/Samba4/NDR/Server.pm        \
-       pidl/lib/Parse/Pidl/Samba4/SWIG.pm              \
+       pidl/lib/Parse/Pidl/Samba4/Python.pm            \
        pidl/lib/Parse/Pidl/Samba4/TDR.pm               \
        pidl/lib/Parse/Pidl/Samba4/Template.pm          \
        pidl/lib/Parse/Pidl/Typelist.pm                 \
@@ -53,10 +58,8 @@ PIDL_FILES= \
        pidl/lib/Parse/Pidl/Wireshark/NDR.pm            \
        pidl/lib/Parse/Yapp/Driver.pm                   \
        pidl/pidl                                       \
-       pidl/ref_notes.txt                              \
-       pidl/smb_interfaces.pm                          \
-       pidl/smb_interfaces.yp                          \
        pidl/tests/Util.pm                              \
+       pidl/tests/cutil.pl                             \
        pidl/tests/dump.pl                              \
        pidl/tests/header.pl                            \
        pidl/tests/ndr.pl                               \
@@ -74,6 +77,7 @@ PIDL_FILES= \
        pidl/tests/parse_idl.pl                         \
        pidl/tests/samba-ndr.pl                         \
        pidl/tests/samba3-cli.pl                        \
+       pidl/tests/samba3-srv.pl                        \
        pidl/tests/tdr.pl                               \
        pidl/tests/test_util.pl                         \
        pidl/tests/typelist.pl                          \
@@ -84,7 +88,8 @@ PIDL_FILES= \
 EXTRA_DIST = \
        $(PIDL_FILES)                                   \
        asn2wrs.py                                      \
-       cvsdiff-fix.py                                  \
+       checkhf.pl                                      \
+       checkAPIs.pl                                    \
        dfilter-test.py                                 \
        extract_asn1_from_spec.pl                       \
        fuzz-test.sh                                    \
@@ -93,9 +98,12 @@ EXTRA_DIST = \
        idl2wrs.sh.in                                   \
        lex.py                                          \
        Makefile.nmake                                  \
-       make-dissector-reg                                      \
+       make-dissector-reg                              \
        make-dissector-reg.py                           \
-       make-tapreg-dotc                        \
+       make-manuf                                      \
+       make-sminmpec.pl                                \
+       make-services.pl                                \
+       make-tapreg-dotc                                \
        make-tap-reg.py                                 \
        msnchat                                         \
        native-nmake.cmd                                \
@@ -104,11 +112,12 @@ EXTRA_DIST = \
        pkt-from-core.py                                \
        process-x11-fields.pl                           \
        process-x11-xcb.pl                              \
+       randpkt-test.sh                                 \
        rdps.py                                         \
        runlex.sh                                       \
        setuid-root.pl.in                               \
-       make-sminmpec.pl                        \
-       unix2dos.pl                                     \
+       test-fuzzed-cap.sh                              \
+       textify.sh                                      \
        win32-setup.sh                                  \
        win64-setup.sh                                  \
        win-setup.sh                                    \