Add Windows version info resource.
[obnox/wireshark/wip.git] / plugins / pcli / Makefile.am
index 1aa126be2caa7618e3cf773b792ad54a211a8625..77ed754b08cd54d28912582b9853347f958e3736 100644 (file)
@@ -1,10 +1,10 @@
 # Makefile.am
-# Automake file for Ethereal/Gryphon
+# Automake file for Packet Cable Lawful Intercept plugin
 #
 # $Id$
 #
-# Ethereal - Network traffic analyzer
-# By Gerald Combs <gerald@ethereal.com>
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
 # Copyright 1998 Gerald Combs
 # 
 # This program is free software; you can redistribute it and/or
 # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
 #
 
-INCLUDES = -I$(top_srcdir)
+INCLUDES = -I$(top_srcdir) -I$(includedir)
+
+include Makefile.common
 
 plugindir = @plugindir@
 
 plugin_LTLIBRARIES = pcli.la
-pcli_la_SOURCES = packet-pcli.c moduleinfo.h
+pcli_la_SOURCES = \
+       plugin.c \
+       moduleinfo.h \
+       $(DISSECTOR_SRC) \
+       $(DISSECTOR_INCLUDES)
 pcli_la_LDFLAGS = -module -avoid-version
 pcli_la_LIBADD = @PLUGIN_LIBS@
 
@@ -36,12 +42,80 @@ pcli_la_LIBADD = @PLUGIN_LIBS@
 # add them here.
 LIBS =
 
+#
+# Build plugin.c, which contains the plugin version[] string, a
+# function plugin_register() that calls the register routines for all
+# protocols, and a function plugin_reg_handoff() that calls the handoff
+# registration routines for all protocols.
+#
+# We do this by scanning sources.  If that turns out to be too slow,
+# maybe we could just require every .o file to have an register routine
+# of a given name (packet-aarp.o -> proto_register_aarp, etc.).
+#
+# Formatting conventions:  The name of the proto_register_* routines an
+# proto_reg_handoff_* routines must start in column zero, or must be
+# preceded only by "void " starting in column zero, and must not be
+# inside #if.
+#
+# DISSECTOR_SRC is assumed to have all the files that need to be scanned.
+#
+# For some unknown reason, having a big "for" loop in the Makefile
+# to scan all the files doesn't work with some "make"s; they seem to
+# pass only the first few names in the list to the shell, for some
+# reason.
+#
+# Therefore, we have a script to generate the plugin.c file.
+# The shell script runs slowly, as multiple greps and seds are run
+# for each input file; this is especially slow on Windows.  Therefore,
+# if Python is present (as indicated by PYTHON being defined), we run
+# a faster Python script to do that work instead.
+#
+# The first argument is the directory in which the source files live.
+# The second argument is "plugin", to indicate that we should build
+# a plugin.c file for a plugin.
+# All subsequent arguments are the files to scan.
+#
+plugin.c: $(DISSECTOR_SRC) $(top_srcdir)/tools/make-dissector-reg \
+    $(top_srcdir)/tools/make-dissector-reg.py
+       @if test -n $(PYTHON); then \
+               echo Making plugin.c with python ; \
+               $(PYTHON) $(top_srcdir)/tools/make-dissector-reg.py $(srcdir) \
+                   plugin $(DISSECTOR_SRC) ; \
+       else \
+               echo Making plugin.c with shell script ; \
+               $(top_srcdir)/tools/make-dissector-reg $(srcdir) \
+                   $(plugin_src) plugin $(DISSECTOR_SRC) ; \
+       fi
+
+#
+# Currently plugin.c can be included in the distribution because
+# we always build all protocol dissectors. We used to have to check
+# whether or not to build the snmp dissector. If we again need to
+# variably build something, making plugin.c non-portable, uncomment
+# the dist-hook line below.
+#
+# Oh, yuk.  We don't want to include "plugin.c" in the distribution, as
+# its contents depend on the configuration, and therefore we want it
+# to be built when the first "make" is done; however, Automake insists
+# on putting *all* source into the distribution.
+#
+# We work around this by having a "dist-hook" rule that deletes
+# "plugin.c", so that "dist" won't pick it up.
+#
+#dist-hook:
+#      @rm -f $(distdir)/plugin.c
+
 CLEANFILES = \
        pcli \
        *~
 
 MAINTAINERCLEANFILES = \
-       Makefile.in
+       Makefile.in     \
+       plugin.c
 
 EXTRA_DIST = \
-       Makefile.nmake
+       Makefile.common         \
+       Makefile.nmake          \
+       moduleinfo.nmake        \
+       plugin.rc.in
+