Add Cmake stuff to the source distribution so more people can try it out.
[obnox/wireshark/wip.git] / plugins / docsis / Makefile.am
index 213f0377485745f43e376804b44e432547ccf0aa..afffc521651e04df01ba3c2a317c16103709095a 100644 (file)
@@ -6,17 +6,17 @@
 # Wireshark - Network traffic analyzer
 # By Gerald Combs <gerald@wireshark.org>
 # Copyright 1998 Gerald Combs
-# 
+#
 # This program is free software; you can redistribute it and/or
 # modify it under the terms of the GNU General Public License
 # as published by the Free Software Foundation; either version 2
 # of the License, or (at your option) any later version.
-# 
+#
 # This program is distributed in the hope that it will be useful,
 # but WITHOUT ANY WARRANTY; without even the implied warranty of
 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
 # GNU General Public License for more details.
-# 
+#
 # You should have received a copy of the GNU General Public License
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
@@ -122,7 +122,8 @@ EXTRA_DIST = \
        Makefile.nmake          \
        moduleinfo.nmake        \
        plugin.rc.in            \
-       README
+       README                  \
+       CMakeLists.txt
 
 checkapi:
-       $(PERL) $(top_srcdir)/tools/checkAPIs.pl -g abort -g termoutput $(DISSECTOR_SRC)
+       $(PERL) $(top_srcdir)/tools/checkAPIs.pl -g abort -g termoutput $(DISSECTOR_SRC) $(DISSECTOR_INCLUDES)