Add a few more menu items.
[obnox/wireshark/wip.git] / plugins / Makefile.am
index d3ff9279a20ed29cade21cde26a7ea5068514ad2..309b940a00356d0fdc851a0419a0f9b167e2dddb 100644 (file)
@@ -1,10 +1,10 @@
 # Makefile.am
-# Automake file for Ethereal
+# Automake file for Wireshark plugins
 #
-# $Id: Makefile.am,v 1.14 2003/04/21 21:28:37 guy Exp $
+# $Id$
 #
-# Ethereal - Network traffic analyzer
-# By Gerald Combs <gerald@ethereal.com>
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
 # Copyright 1998 Gerald Combs
 #
 # This program is free software; you can redistribute it and/or
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
 
-SUBDIRS = artnet docsis giop gryphon megaco mgcp pcli
+-include Custom.make
+SUBDIRS = $(_CUSTOM_SUBDIRS_) \
+       asn1 \
+       docsis \
+       ethercat \
+       giop \
+       gryphon \
+       irda \
+       m2m \
+       mate \
+       opcua \
+       profinet \
+       stats_tree \
+       unistim \
+       wimax \
+       wimaxasncp
 
 plugindir = @plugindir@
 
 EXTRA_DIST = \
-       plugin_api.c    \
-       plugin_api.h    \
-       plugin_api_decls.h      \
-       plugin_api_defs.h       \
-       plugin_table.h  \
+       $(_CUSTOM_EXTRA_DIST_) \
+       plugins.vcproj  \
        Makefile.nmake
+
+MAINTAINERCLEANFILES = \
+       Makefile.in
+
+checkapi:
+       for i in $(SUBDIRS); do \
+               (cd "$$i"; $(MAKE) checkapi); \
+       done
+