Add a few more menu items.
[obnox/wireshark/wip.git] / plugins / Makefile.am
index c9e081eff4d59adebe8cf33749b82172a49e68c9..309b940a00356d0fdc851a0419a0f9b167e2dddb 100644 (file)
@@ -1,10 +1,10 @@
 # Makefile.am
-# Automake file for Ethereal
+# Automake file for Wireshark plugins
 #
-# $Id: Makefile.am,v 1.27 2003/12/18 19:01:30 guy Exp $
+# $Id$
 #
-# Ethereal - Network traffic analyzer
-# By Gerald Combs <gerald@ethereal.com>
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
 # Copyright 1998 Gerald Combs
 #
 # This program is free software; you can redistribute it and/or
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
 
-SUBDIRS = acn asn1 artnet docsis enttec giop gryphon irda lwres megaco mgcp pcli rdm rtnet v5ua
+-include Custom.make
+SUBDIRS = $(_CUSTOM_SUBDIRS_) \
+       asn1 \
+       docsis \
+       ethercat \
+       giop \
+       gryphon \
+       irda \
+       m2m \
+       mate \
+       opcua \
+       profinet \
+       stats_tree \
+       unistim \
+       wimax \
+       wimaxasncp
 
 plugindir = @plugindir@
 
-ADDRESS_EXPORT_FILES = \
-       Xass-list       \
-       Xplugin_api.c   \
-       Xplugin_api.h   \
-       Xplugin_api_decls.h     \
-       Xplugin_table.h
-
-$(ADDRESS_EXPORT_FILES): xyzzy plugin_gen.py plugin_api.c plugin_api_list.c
-       $(PYTHON) $(srcdir)/plugin_gen.py xyzzy
+EXTRA_DIST = \
+       $(_CUSTOM_EXTRA_DIST_) \
+       plugins.vcproj  \
+       Makefile.nmake
 
-xyzzy: plugin_api_list.c
-       gcc -aux-info xyzzy -DHAVE_CONFIG_H $(GLIB_CFLAGS) -I$(top_srcdir) -I$(top_builddir) -c $(srcdir)/plugin_api_list.c
+MAINTAINERCLEANFILES = \
+       Makefile.in
 
-EXTRA_DIST = \
-       plugin_api.c    \
-       plugin_api.h    \
-       plugin_api_decls.h      \
-       plugin_api_defs.h       \
-       plugin_api_list.c       \
-       plugin_gen.py   \
-       plugin_table.h  \
-       Makefile.nmake  \
-       README.interface        \
-       Xass-list       \
-       Xplugin_api.c   \
-       Xplugin_api.h   \
-       Xplugin_api_decls.h     \
-       Xplugin_table.h
+checkapi:
+       for i in $(SUBDIRS); do \
+               (cd "$$i"; $(MAKE) checkapi); \
+       done
 
-CLEANFILES = \
-       Xass-list       \
-       Xplugin_api.c   \
-       Xplugin_api.h   \
-       Xplugin_api_decls.h     \
-       Xplugin_table.h \
-       plugin_api_list.o       \
-       xyzzy