Fix for bug 2964.
[obnox/wireshark/wip.git] / gtk / Makefile.am
index 24ba41f2b6d7a0f0c2182c547f628052a1958adc..fef0ca8036cf93c8ce86291e0f2717d6230a46a7 100644 (file)
@@ -41,114 +41,14 @@ wireshark-tap-register.c: $(WIRESHARK_TAP_SRC) $(top_srcdir)/make-tapreg-dotc
        @echo Making wireshark-tap-register.c
        @$(top_srcdir)/make-tapreg-dotc wireshark-tap-register.c $(srcdir) $(WIRESHARK_TAP_SRC)
 
-noinst_HEADERS = \
-       about_dlg.h     \
-       airpcap_dlg.h \
-       airpcap_gui_utils.h \
-       capture_dlg.h   \
-       capture_file_dlg.h      \
-       capture_if_details_dlg.h        \
-       capture_prefs.h \
-       cfilter_combo_utils.h \
-       color_dlg.h     \
-       color_edit_dlg.h        \
-       colors.h        \
-       column_prefs.h  \
-       conversations_table.h \
-       decode_as_ber.h \
-       decode_as_dlg.h \
-       decode_as_dcerpc.h \
-       dfilter_expr_dlg.h \
-       dlg_utils.h     \
-       drag_and_drop.h \
-       expert_comp_dlg.h       \
-       expert_comp_table.h     \
-       export_object.h \
-       file_dlg.h      \
-       fileset_dlg.h   \
-       filter_dlg.h    \
-       find_dlg.h      \
-       firewall_dlg.h  \
-       follow_ssl.h    \
-       follow_stream.h \
-       follow_tcp.h    \
-       follow_udp.h    \
-       font_utils.h    \
-       goto_dlg.h      \
-       graph_analysis.h \
-       gsm_map_stat.h  \
-       gtkglobals.h    \
-       gtkvumeter.h \
-       gui_stat_util.h \
-       gui_prefs.h     \
-       gui_utils.h     \
-       help_dlg.h      \
-       hostlist_table.h \
-       isprint.h       \
-       keys.h          \
-       layout_prefs.h  \
-       macros_dlg.h    \
-       main.h          \
-       main_menu.h             \
-       main_statusbar.h                \
-       main_toolbar.h  \
-       main_welcome.h          \
-       mtp3_stat.h     \
-       nameres_prefs.h \
-       packet_history.h        \
-       packet_list.h   \
-       packet_win.h    \
-       pixmap_save.h   \
-       plugins_dlg.h   \
-       prefs_dlg.h     \
-       print_prefs.h   \
-       profile_dlg.h   \
-       proto_dlg.h     \
-       proto_draw.h    \
-       proto_hier_stats_dlg.h  \
-       range_utils.h \
-       recent.h        \
-       rtp_analysis.h  \
-       rtp_player.h    \
-       rtp_player_prefs.h      \
-       rtp_stream.h    \
-       rtp_stream_dlg.h \
-       mcast_stream.h  \
-       mcast_stream_dlg.h \
-       sat.h           \
-       sctp_stat.h     \
-       service_response_time_table.h   \
-       gui_stat_menu.h \
-       stock_icons.h   \
-       stream_prefs.h  \
-       summary_dlg.h   \
-       supported_protos_dlg.h   \
-       text_page.h     \
-       u3.h \
-       uat_gui.h \
-       voip_calls.h    \
-       voip_calls_dlg.h \
-       webbrowser.h
-
 libui_a_SOURCES = \
        $(WIRESHARK_GTK_SRC) \
+       $(GENERATED_C_FILES) \
        $(noinst_HEADERS) \
        $(WIRESHARK_TAP_SRC)
 
 libui_a_DEPENDENCIES = 
 
-EXTRA_DIST = \
-       airpcap_dlg.c \
-       airpcap_gui_utils.c \
-       capture_if_details_dlg.c        \
-       doxygen.cfg.in \
-       Makefile.common \
-       Makefile.nmake \
-       print_mswin.c  \
-       print_mswin.h  \
-       win32-file-dlg.c \
-       win32-file-dlg.h
-
 # Common headers
 AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/wiretap $(LIBGCRYPT_CFLAGS) $(LIBGNUTLS_CFLAGS) $(PORTAUDIO_INCLUDES)
 
@@ -158,3 +58,10 @@ if HAVE_DOXYGEN
        $(DOXYGEN) doxygen.cfg
 endif          # HAVE_DOXYGEN
 
+checkapi:
+       $(PERL) ../tools/checkAPIs.pl \
+       $(WIRESHARK_GTK_SRC) \
+       $(WIRESHARK_TAP_SRC) \
+       capture_if_details_dlg_win32.c  \
+       file_dlg_win32.c \
+       print_win32.c