"ssn_range" needs to be a copy of "global_ssn_range", so that it's not
[obnox/wireshark/wip.git] / gtk / Makefile.am
index 43b9941348dbc78eddbb1ae06c21a28b923b90de..f99f2793e87bda68765f3c9ef46c4cdf43b57d7e 100644 (file)
@@ -1,7 +1,7 @@
 # Makefile.am
 # Automake file for the GTK interface routines for Ethereal
 #
-# $Id: Makefile.am,v 1.78 2003/12/03 23:46:22 guy Exp $
+# $Id$
 #
 # Ethereal - Network traffic analyzer
 # By Gerald Combs <gerald@ethereal.com>
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
 
+include Makefile.common
+
 noinst_LIBRARIES = libui.a
 
 CLEANFILES = \
        libui.a         \
        *~
 
-ETHEREAL_TAP_SRC = \
-       ansi_a_stat.c   \
-       bootp_stat.c    \
-       dcerpc_stat.c   \
-       endpoint_talkers_eth.c  \
-       endpoint_talkers_fc.c   \
-       endpoint_talkers_fddi.c \
-       endpoint_talkers_ip.c   \
-       endpoint_talkers_ipx.c  \
-       endpoint_talkers_tcpip.c        \
-       endpoint_talkers_tr.c   \
-       endpoint_talkers_udpip.c        \
-       fc_stat.c       \
-       h225_counter.c  \
-       h225_ras_srt.c  \
-       http_stat.c     \
-       io_stat.c       \
-       ldap_stat.c     \
-       mgcp_stat.c     \
-       rpc_stat.c      \
-       rpc_progs.c     \
-       smb_stat.c      \
-       rtp_analysis.c  \
-       rtp_stream_dlg.c \
-       wsp_stat.c
-
 ethereal-tap-register.c: $(ETHEREAL_TAP_SRC) $(top_srcdir)/make-tapreg-dotc
        @echo Making ethereal-tap-register.c
        @$(top_srcdir)/make-tapreg-dotc ethereal-tap-register.c $(srcdir) $(ETHEREAL_TAP_SRC)
 
-if USE_GTK2
-libui_a_SOURCES = \
-       capture_combo_utils.c \
-       capture_combo_utils.h \
-       capture_dlg.c   \
+noinst_HEADERS = \
+       about_dlg.h     \
        capture_dlg.h   \
-       capture_prefs.c \
        capture_prefs.h \
-       capture_info_dlg.c \
-       color_dlg.c     \
+       cfilter_combo_utils.h \
        color_dlg.h     \
-       color_filters.c \
-       color_filters.h \
-       color_utils.c   \
-       color_utils.h   \
-       colors.c        \
        colors.h        \
-       column_prefs.c  \
        column_prefs.h  \
        compat_macros.h \
-       decode_as_dlg.c \
+       conversations_table.h \
        decode_as_dlg.h \
-       dfilter_expr_dlg.c \
+       decode_as_dcerpc.h \
        dfilter_expr_dlg.h \
-       display_opts.c  \
-       display_opts.h  \
-       dlg_utils.c     \
        dlg_utils.h     \
-       endpoint_talkers_table.c \
-       endpoint_talkers_table.h \
-       ethereal-tap-register.c \
-       file_dlg.c      \
        file_dlg.h      \
-       filter_prefs.c  \
-       filter_prefs.h  \
-       find_dlg.c      \
+       filter_dlg.h    \
        find_dlg.h      \
-       follow_dlg.c    \
        follow_dlg.h    \
-       goto_dlg.c      \
+       font_utils.h    \
        goto_dlg.h      \
+       gsm_map_stat.h  \
        gtkglobals.h    \
-       gtk_stat_util.c \
        gtk_stat_util.h \
-       gui_prefs.c     \
        gui_prefs.h     \
-       help_dlg.c      \
+       h323_analysis.h \
+       h323_conversations.h    \
+       h323_conversations_dlg.h \
        help_dlg.h      \
+       hostlist_table.h \
+       isprint.h       \
        keys.h          \
-       main.c          \
+       layout_prefs.h  \
        main.h          \
-       menu.c          \
        menu.h          \
-       nameres_prefs.c \
+       mtp3_stat.h     \
        nameres_prefs.h \
-       packet_list.c   \
-       packet_win.c    \
+       packet_list.h   \
        packet_win.h    \
-       plugins_dlg.c   \
-       prefs_dlg.c     \
        prefs_dlg.h     \
-       print_dlg.c     \
-       print_prefs.c   \
        print_prefs.h   \
-       progress_dlg.c  \
-       proto_dlg.c     \
        proto_dlg.h     \
-       proto_draw.c    \
        proto_draw.h    \
        proto_hier_stats_dlg.h  \
-       proto_hier_stats_dlg.c  \
+       range_utils.h \
+       recent.h        \
        rtp_analysis.h  \
-       rtp_stream.c    \
        rtp_stream.h    \
        rtp_stream_dlg.h \
-       service_response_time_table.c   \
+       sat.h           \
+       sctp_stat.h     \
        service_response_time_table.h   \
-       simple_dialog.c \
-       stream_prefs.c  \
        stream_prefs.h  \
-       summary_dlg.c   \
        summary_dlg.h   \
-       supported_protos_dlg.c   \
        supported_protos_dlg.h   \
-       tcp_graph.c     \
-       tcp_graph.h     \
-       toolbar.c       \
+       tap_dfilter_dlg.h \
+       tap_menu.h      \
+       text_page.h     \
        toolbar.h       \
-       ui_util.c       \
        ui_util.h       \
+       webbrowser.h
+
+if USE_GTK2
+libui_a_SOURCES = \
+       $(ETHEREAL_GTK_SRC) \
+       $(noinst_HEADERS) \
        $(ETHEREAL_TAP_SRC)
 else
 libui_a_SOURCES = \
-       capture_combo_utils.c \
-       capture_combo_utils.h \
-       capture_dlg.c   \
-       capture_dlg.h   \
-       capture_prefs.c \
-       capture_prefs.h \
-       capture_info_dlg.c \
-       color_dlg.c     \
-       color_dlg.h     \
-       color_filters.c \
-       color_filters.h \
-       color_utils.c   \
-       color_utils.h   \
-       colors.c        \
-       colors.h        \
-       column_prefs.c  \
-       column_prefs.h  \
-       decode_as_dlg.c \
-       decode_as_dlg.h \
-       dfilter_expr_dlg.c \
-       dfilter_expr_dlg.h \
-       display_opts.c  \
-       display_opts.h  \
-       dlg_utils.c     \
-       dlg_utils.h     \
-       endpoint_talkers_table.c \
-       endpoint_talkers_table.h \
-       ethereal-tap-register.c \
-       file_dlg.c      \
-       file_dlg.h      \
-       filter_prefs.c  \
-       filter_prefs.h  \
-       find_dlg.c      \
-       find_dlg.h      \
-       follow_dlg.c    \
-       follow_dlg.h    \
-       goto_dlg.c      \
-       goto_dlg.h      \
-       gtkclist_v12.c  \
-       gtkclist_v12.h  \
-       gtkglobals.h    \
-       gtk_stat_util.c \
-       gtk_stat_util.h \
-       gui_prefs.c     \
-       gui_prefs.h     \
-       help_dlg.c      \
-       help_dlg.h      \
-       keys.h          \
-       main.c          \
-       main.h          \
-       menu.c          \
-       menu.h          \
-       nameres_prefs.c \
-       nameres_prefs.h \
-       packet_list.c   \
-       packet_win.c    \
-       packet_win.h    \
-       plugins_dlg.c   \
-       prefs_dlg.c     \
-       prefs_dlg.h     \
-       print_dlg.c     \
-       print_prefs.c   \
-       print_prefs.h   \
-       progress_dlg.c  \
-       proto_dlg.c     \
-       proto_dlg.h     \
-       proto_draw.c    \
-       proto_draw.h    \
-       proto_hier_stats_dlg.h  \
-       proto_hier_stats_dlg.c  \
-       rtp_analysis.h  \
-       rtp_stream.c    \
-       rtp_stream.h    \
-       rtp_stream_dlg.h \
-       service_response_time_table.c   \
-       service_response_time_table.h   \
-       simple_dialog.c \
-       stream_prefs.c  \
-       stream_prefs.h  \
-       summary_dlg.c   \
-       summary_dlg.h   \
-       supported_protos_dlg.c   \
-       supported_protos_dlg.h   \
-       tcp_graph.c     \
-       tcp_graph.h     \
-       toolbar.c       \
-       toolbar.h       \
-       ui_util.c       \
-       ui_util.h       \
+       ethclist.c      \
+       ethclist.h      \
+       $(ETHEREAL_GTK_SRC) \
+       $(noinst_HEADERS) \
        $(ETHEREAL_TAP_SRC)
 endif
 
+libui_a_DEPENDENCIES = 
+
 EXTRA_DIST = \
+       doxygen.cfg.in \
+       ethclist.c      \
+       ethclist.h      \
+       Makefile.common \
        Makefile.nmake \
-       compat_macros.h \
        print_mswin.c  \
        print_mswin.h
 
 # Common headers
 AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/wiretap
+
+doxygen:
+if HAVE_DOXYGEN
+       $(DOXYGEN) doxygen.cfg
+endif          # HAVE_DOXYGEN
+