Move the contents of image/expert_*.h to gtk/expert_indicators.h. Add
[obnox/wireshark/wip.git] / gtk / Makefile.am
index 8e26b978b0cd34002b4407955422aae204d4b5d8..eb8ee9714d9a351f1e63d9b7b765f007c450da2f 100644 (file)
@@ -1,10 +1,10 @@
 # Makefile.am
-# Automake file for the GTK interface routines for Ethereal
+# Automake file for the GTK interface routines for Wireshark
 #
 # $Id$
 #
-# Ethereal - Network traffic analyzer
-# By Gerald Combs <gerald@ethereal.com>
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
 # Copyright 1998 Gerald Combs
 #
 # This program is free software; you can redistribute it and/or
 
 include Makefile.common
 
+if HAVE_WARNINGS_AS_ERRORS
+AM_CFLAGS = -Werror
+endif
+
 noinst_LIBRARIES = libui.a
 
 CLEANFILES = \
@@ -33,109 +37,45 @@ MAINTAINERCLEANFILES = \
        $(GENERATED_FILES)      \
        Makefile.in
 
-ethereal-tap-register.c: $(ETHEREAL_TAP_SRC) $(top_srcdir)/make-tapreg-dotc
-       @echo Making ethereal-tap-register.c
-       @$(top_srcdir)/make-tapreg-dotc ethereal-tap-register.c $(srcdir) $(ETHEREAL_TAP_SRC)
-
-noinst_HEADERS = \
-       about_dlg.h     \
-       capture_dlg.h   \
-       capture_prefs.h \
-       capture_if_details_dlg.h        \
-       cfilter_combo_utils.h \
-       color_dlg.h     \
-       colors.h        \
-       column_prefs.h  \
-       compat_macros.h \
-       conversations_table.h \
-       decode_as_dlg.h \
-       decode_as_dcerpc.h \
-       dfilter_expr_dlg.h \
-       dlg_utils.h     \
-       expert_comp_table.h     \
-       file_dlg.h      \
-       fileset_dlg.h   \
-       filter_dlg.h    \
-       find_dlg.h      \
-       follow_dlg.h    \
-       font_utils.h    \
-       goto_dlg.h      \
-       graph_analysis.h \
-       gsm_map_stat.h  \
-       gtkglobals.h    \
-       gui_stat_util.h \
-       gui_prefs.h     \
-       gui_utils.h     \
-       help_dlg.h      \
-       hostlist_table.h \
-       isprint.h       \
-       keys.h          \
-       layout_prefs.h  \
-       main.h          \
-       menu.h          \
-       mtp3_stat.h     \
-       nameres_prefs.h \
-       packet_history.h        \
-       packet_list.h   \
-       packet_win.h    \
-       plugins_dlg.h   \
-       prefs_dlg.h     \
-       print_prefs.h   \
-       proto_dlg.h     \
-       proto_draw.h    \
-       proto_hier_stats_dlg.h  \
-       range_utils.h \
-       recent.h        \
-       rtp_analysis.h  \
-       rtp_stream.h    \
-       rtp_stream_dlg.h \
-       sat.h           \
-       sctp_stat.h     \
-       service_response_time_table.h   \
-       gui_stat_menu.h \
-       ssl-dlg.h       \
-       stream_prefs.h  \
-       summary_dlg.h   \
-       supported_protos_dlg.h   \
-       text_page.h     \
-       toolbar.h       \
-       voip_calls.h    \
-       voip_calls_dlg.h \
-       webbrowser.h
+wireshark-tap-register.c: $(WIRESHARK_TAP_SRC) $(top_srcdir)/tools/make-tapreg-dotc
+       @echo Making wireshark-tap-register.c
+       @$(top_srcdir)/tools/make-tapreg-dotc wireshark-tap-register.c $(srcdir) $(WIRESHARK_TAP_SRC)
 
-if USE_GTK2
-libui_a_SOURCES = \
-       $(ETHEREAL_GTK_SRC) \
-       $(noinst_HEADERS) \
-       $(ETHEREAL_TAP_SRC)
-else
 libui_a_SOURCES = \
-       ethclist.c      \
-       ethclist.h      \
-       $(ETHEREAL_GTK_SRC) \
+       $(WIRESHARK_GTK_SRC) \
+       $(GENERATED_C_FILES) \
        $(noinst_HEADERS) \
-       $(ETHEREAL_TAP_SRC)
-endif
+       $(WIRESHARK_TAP_SRC)
 
 libui_a_DEPENDENCIES = 
 
-EXTRA_DIST = \
-       capture_if_details_dlg.c        \
-       doxygen.cfg.in \
-       ethclist.c      \
-       ethclist.h      \
-       Makefile.common \
-       Makefile.nmake \
-       print_mswin.c  \
-       print_mswin.h  \
-       win32-file-dlg.c \
-       win32-file-dlg.h
-
 # Common headers
-AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/wiretap
+AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/wiretap $(LIBGCRYPT_CFLAGS) $(LIBGNUTLS_CFLAGS) $(PORTAUDIO_INCLUDES)
+
 
 doxygen:
 if HAVE_DOXYGEN
        $(DOXYGEN) doxygen.cfg
 endif          # HAVE_DOXYGEN
 
+checkapi:
+       $(PERL) ../tools/checkAPIs.pl \
+       $(WIRESHARK_GTK_SRC) \
+       $(WIRESHARK_TAP_SRC) \
+       capture_if_details_dlg_win32.c  \
+       file_dlg_win32.c \
+       print_win32.c
+
+expert_indicators.h:
+       echo "/* This file was automatically generated. DO NOT EDIT. */" > $@
+       echo >> $@
+       for elevel in chat error none note warn ; do \
+               gdk-pixbuf-csource --raw --name=expert_$${elevel}_pb_data ../image/expert_$${elevel}.png >> $@ ;\
+       done
+
+network_icons.h:
+       echo "/* This file was automatically generated. DO NOT EDIT. */" > $@
+       echo >> $@
+       for icon in bluetooth wired wireless ; do \
+               gdk-pixbuf-csource --raw --name=network_$${icon}_pb_data ../image/toolbar/network_$${icon}_16.png >> $@ ;\
+       done