Fix the wireless settings button for AirPCap devices in the
[obnox/wireshark/wip.git] / gtk / Makefile.am
index 9f6c71bdb4e1e746faa8c1ec616328062454444f..6091417119ab03e25febbeb8aa66eb182395946a 100644 (file)
@@ -1,10 +1,10 @@
 # Makefile.am
-# Automake file for the GTK interface routines for Ethereal
+# Automake file for the GTK interface routines for Wireshark
 #
-# $Id: Makefile.am,v 1.101 2004/06/09 03:08:13 gerald Exp $
+# $Id$
 #
-# Ethereal - Network traffic analyzer
-# By Gerald Combs <gerald@ethereal.com>
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
 # Copyright 1998 Gerald Combs
 #
 # This program is free software; you can redistribute it and/or
 # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
 
 include Makefile.common
+include ../Makefile.am.inc
 
-noinst_LIBRARIES = libui.a
+if HAVE_WARNINGS_AS_ERRORS
+AM_CLEAN_CFLAGS = -Werror
+endif
+
+noinst_LIBRARIES = libui.a libui_dirty.a
 
 CLEANFILES = \
        libui.a         \
+       libui_dirty.a   \
        *~
 
-ethereal-tap-register.c: $(ETHEREAL_TAP_SRC) $(top_srcdir)/make-tapreg-dotc
-       @echo Making ethereal-tap-register.c
-       @$(top_srcdir)/make-tapreg-dotc ethereal-tap-register.c $(srcdir) $(ETHEREAL_TAP_SRC)
-
-noinst_HEADERS = \
-       about_dlg.h     \
-       capture_combo_utils.h \
-       capture_dlg.h   \
-       capture_prefs.h \
-       color_dlg.h     \
-       color_filters.h \
-       color_utils.h   \
-       colors.h        \
-       column_prefs.h  \
-       compat_macros.h \
-       decode_as_dlg.h \
-       dfilter_expr_dlg.h \
-       dlg_utils.h     \
-       endpoint_talkers_table.h \
-       file_dlg.h      \
-       filter_prefs.h  \
-       find_dlg.h      \
-       follow_dlg.h    \
-       goto_dlg.h      \
-       gsm_map_stat.h  \
-       gtkglobals.h    \
-       gtk_stat_util.h \
-       gui_prefs.h     \
-       help_dlg.h      \
-       hostlist_table.h \
-       keys.h          \
-       layout_prefs.h  \
-       main.h          \
-       menu.h          \
-       mtp3_stat.h     \
-       nameres_prefs.h \
-       packet_list.h   \
-       packet_win.h    \
-       prefs_dlg.h     \
-       print_prefs.h   \
-       proto_dlg.h     \
-       proto_draw.h    \
-       proto_hier_stats_dlg.h  \
-       range_utils.h \
-       recent.h        \
-       rtp_analysis.h  \
-       rtp_stream.h    \
-       rtp_stream_dlg.h \
-       sat.h           \
-       service_response_time_table.h   \
-       stream_prefs.h  \
-       summary_dlg.h   \
-       supported_protos_dlg.h   \
-       tap_dfilter_dlg.h \
-       tap_menu.h      \
-       text_page.h     \
-       toolbar.h       \
-       ui_util.h
-
-if USE_GTK2
-libui_a_SOURCES = \
-       $(ETHEREAL_GTK_SRC) \
-       $(noinst_HEADERS) \
-       $(ETHEREAL_TAP_SRC)
-else
+MAINTAINERCLEANFILES = \
+       $(GENERATED_FILES)      \
+       Makefile.in
+
+RUNLEX=$(top_srcdir)/tools/runlex.sh
+
+text_import_scanner_lex.h: text_import_scanner.c
+
+wireshark-tap-register.c: $(WIRESHARK_TAP_SRC) $(top_srcdir)/tools/make-tapreg-dotc
+       @echo Making wireshark-tap-register.c
+       @$(top_srcdir)/tools/make-tapreg-dotc wireshark-tap-register.c $(srcdir) $(WIRESHARK_TAP_SRC)
+
 libui_a_SOURCES = \
-       ethclist.c      \
-       ethclist.h      \
-       $(ETHEREAL_GTK_SRC) \
+       $(WIRESHARK_GTK_SRC) \
+       $(GENERATED_C_FILES) \
+       $(GENERATED_H_FILES) \
        $(noinst_HEADERS) \
-       $(ETHEREAL_TAP_SRC)
-endif
+       $(WIRESHARK_TAP_SRC)
 
-libui_a_DEPENDENCIES = doxygen
+libui_a_CFLAGS = $(AM_CLEAN_CFLAGS)
 
-EXTRA_DIST = \
-       doxygen.cfg \
-       Makefile.common \
-       Makefile.nmake \
-       print_mswin.c  \
-       print_mswin.h
+libui_a_DEPENDENCIES =
+
+
+libui_dirty_a_SOURCES = \
+       $(DIRTY_GENERATED_C_FILES)
+
+libui_dirty_a_DEPENDENCIES =
 
 # Common headers
-AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/wiretap
+AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/wiretap $(LIBGCRYPT_CFLAGS) $(LIBGNUTLS_CFLAGS) $(PORTAUDIO_INCLUDES)
 
-# Doxygen
-doxygen.tmp: ../config.nmake doxygen.cfg
-       sed -e s/@VERSION@/$(VERSION)/ \
-           < doxygen.cfg > $@
 
-doxygen-run:
+doxygen:
 if HAVE_DOXYGEN
-       $(DOXYGEN) doxygen.tmp
+       $(DOXYGEN) doxygen.cfg
 endif          # HAVE_DOXYGEN
 
-doxygen: doxygen.tmp doxygen-run
+checkapi: checkapi-base checkapi-todo
+
+checkapi-base:
+       $(PERL) ../tools/checkAPIs.pl -g deprecated-gtk \
+       $(WIRESHARK_GTK_SRC) \
+       $(WIRESHARK_TAP_SRC) \
+       capture_if_details_dlg_win32.c \
+       gtkvumeter.c
 
+checkapi-todo:
+       $(PERL) ../tools/checkAPIs.pl -M -g deprecated-gtk-todo \
+       $(WIRESHARK_GTK_SRC) \
+       $(WIRESHARK_TAP_SRC) \
+       capture_if_details_dlg_win32.c \
+       gtkvumeter.c
+
+expert_indicators.h:
+       echo "/* This file was automatically generated. DO NOT EDIT. */" > $@
+       echo >> $@
+       for elevel in chat error none note warn ; do \
+               gdk-pixbuf-csource --raw --name=expert_$${elevel}_pb_data ../image/expert_$${elevel}.png >> $@ ;\
+       done
+
+network_icons.h:
+       echo "/* This file was automatically generated. DO NOT EDIT. */" > $@
+       echo >> $@
+       for icon in bluetooth usb wired wireless ; do \
+               gdk-pixbuf-csource --raw --name=network_$${icon}_pb_data ../image/toolbar/network_$${icon}_16.png >> $@ ;\
+       done
+
+EXTRA_DIST = \
+       $(GENERATOR_FILES)      \
+       airpcap_dlg.c                   \
+       airpcap_gui_utils.c             \
+       capture_if_details_dlg_win32.c  \
+       capture_if_details_dlg_win32.h  \
+       gtkvumeter.c                    \
+       gtkvumeter.h                    \
+       doxygen.cfg.in                  \
+       libui.vcproj                    \
+       main_airpcap_toolbar.c          \
+       Makefile.common                 \
+       Makefile.nmake                  \
+       CMakeLists.txt                  \
+       Makefile_custom.common