Fix the wireless settings button for AirPCap devices in the
[obnox/wireshark/wip.git] / gtk / Makefile.am
index 8b5b02595ef28fa4ea12a5cd9399218a9f68d889..6091417119ab03e25febbeb8aa66eb182395946a 100644 (file)
 # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
 
 include Makefile.common
+include ../Makefile.am.inc
 
 if HAVE_WARNINGS_AS_ERRORS
-AM_CFLAGS = -Werror
+AM_CLEAN_CFLAGS = -Werror
 endif
 
-noinst_LIBRARIES = libui.a
+noinst_LIBRARIES = libui.a libui_dirty.a
 
 CLEANFILES = \
        libui.a         \
+       libui_dirty.a   \
        *~
 
 MAINTAINERCLEANFILES = \
        $(GENERATED_FILES)      \
        Makefile.in
 
-wireshark-tap-register.c: $(WIRESHARK_TAP_SRC) $(top_srcdir)/make-tapreg-dotc
+RUNLEX=$(top_srcdir)/tools/runlex.sh
+
+text_import_scanner_lex.h: text_import_scanner.c
+
+wireshark-tap-register.c: $(WIRESHARK_TAP_SRC) $(top_srcdir)/tools/make-tapreg-dotc
        @echo Making wireshark-tap-register.c
-       @$(top_srcdir)/make-tapreg-dotc wireshark-tap-register.c $(srcdir) $(WIRESHARK_TAP_SRC)
-
-noinst_HEADERS = \
-       about_dlg.h     \
-       airpcap_dlg.h \
-       airpcap_gui_utils.h \
-       capture_dlg.h   \
-       capture_file_dlg.h      \
-       capture_if_details_dlg.h        \
-       capture_prefs.h \
-       cfilter_combo_utils.h \
-       color_dlg.h     \
-       color_edit_dlg.h        \
-       colors.h        \
-       column_prefs.h  \
-       conversations_table.h \
-       decode_as_ber.h \
-       decode_as_dlg.h \
-       decode_as_dcerpc.h \
-       dfilter_expr_dlg.h \
-       dlg_utils.h     \
-       drag_and_drop.h \
-       expert_comp_dlg.h       \
-       expert_comp_table.h     \
-       export_object.h \
-       file_dlg.h      \
-       fileset_dlg.h   \
-       filter_dlg.h    \
-       find_dlg.h      \
-       firewall_dlg.h  \
-       follow_ssl.h    \
-       follow_stream.h \
-       follow_tcp.h    \
-       follow_udp.h    \
-       font_utils.h    \
-       goto_dlg.h      \
-       graph_analysis.h \
-       gsm_map_stat.h  \
-       gtkglobals.h    \
-       gtkvumeter.h \
-       gui_stat_util.h \
-       gui_prefs.h     \
-       gui_utils.h     \
-       help_dlg.h      \
-       hostlist_table.h \
-       isprint.h       \
-       keys.h          \
-       layout_prefs.h  \
-       macros_dlg.h    \
-       main.h          \
-       main_statusbar.h                \
-       main_welcome.h          \
-       menu.h          \
-       mtp3_stat.h     \
-       nameres_prefs.h \
-       packet_history.h        \
-       packet_list.h   \
-       packet_win.h    \
-       pixmap_save.h   \
-       plugins_dlg.h   \
-       prefs_dlg.h     \
-       print_prefs.h   \
-       profile_dlg.h   \
-       proto_dlg.h     \
-       proto_draw.h    \
-       proto_hier_stats_dlg.h  \
-       range_utils.h \
-       recent.h        \
-       rtp_analysis.h  \
-       rtp_player.h    \
-       rtp_player_prefs.h      \
-       rtp_stream.h    \
-       rtp_stream_dlg.h \
-       mcast_stream.h  \
-       mcast_stream_dlg.h \
-       sat.h           \
-       sctp_stat.h     \
-       service_response_time_table.h   \
-       gui_stat_menu.h \
-       stock_icons.h   \
-       stream_prefs.h  \
-       summary_dlg.h   \
-       supported_protos_dlg.h   \
-       text_page.h     \
-       toolbar.h       \
-       u3.h \
-       uat_gui.h \
-       voip_calls.h    \
-       voip_calls_dlg.h \
-       webbrowser.h
+       @$(top_srcdir)/tools/make-tapreg-dotc wireshark-tap-register.c $(srcdir) $(WIRESHARK_TAP_SRC)
 
 libui_a_SOURCES = \
        $(WIRESHARK_GTK_SRC) \
+       $(GENERATED_C_FILES) \
+       $(GENERATED_H_FILES) \
        $(noinst_HEADERS) \
        $(WIRESHARK_TAP_SRC)
 
-libui_a_DEPENDENCIES = 
+libui_a_CFLAGS = $(AM_CLEAN_CFLAGS)
+
+libui_a_DEPENDENCIES =
 
-EXTRA_DIST = \
-       airpcap_dlg.c \
-       airpcap_gui_utils.c \
-       capture_if_details_dlg.c        \
-       doxygen.cfg.in \
-       Makefile.common \
-       Makefile.nmake \
-       print_mswin.c  \
-       print_mswin.h  \
-       win32-file-dlg.c \
-       win32-file-dlg.h
+
+libui_dirty_a_SOURCES = \
+       $(DIRTY_GENERATED_C_FILES)
+
+libui_dirty_a_DEPENDENCIES =
 
 # Common headers
 AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/wiretap $(LIBGCRYPT_CFLAGS) $(LIBGNUTLS_CFLAGS) $(PORTAUDIO_INCLUDES)
@@ -158,3 +73,48 @@ if HAVE_DOXYGEN
        $(DOXYGEN) doxygen.cfg
 endif          # HAVE_DOXYGEN
 
+checkapi: checkapi-base checkapi-todo
+
+checkapi-base:
+       $(PERL) ../tools/checkAPIs.pl -g deprecated-gtk \
+       $(WIRESHARK_GTK_SRC) \
+       $(WIRESHARK_TAP_SRC) \
+       capture_if_details_dlg_win32.c \
+       gtkvumeter.c
+
+checkapi-todo:
+       $(PERL) ../tools/checkAPIs.pl -M -g deprecated-gtk-todo \
+       $(WIRESHARK_GTK_SRC) \
+       $(WIRESHARK_TAP_SRC) \
+       capture_if_details_dlg_win32.c \
+       gtkvumeter.c
+
+expert_indicators.h:
+       echo "/* This file was automatically generated. DO NOT EDIT. */" > $@
+       echo >> $@
+       for elevel in chat error none note warn ; do \
+               gdk-pixbuf-csource --raw --name=expert_$${elevel}_pb_data ../image/expert_$${elevel}.png >> $@ ;\
+       done
+
+network_icons.h:
+       echo "/* This file was automatically generated. DO NOT EDIT. */" > $@
+       echo >> $@
+       for icon in bluetooth usb wired wireless ; do \
+               gdk-pixbuf-csource --raw --name=network_$${icon}_pb_data ../image/toolbar/network_$${icon}_16.png >> $@ ;\
+       done
+
+EXTRA_DIST = \
+       $(GENERATOR_FILES)      \
+       airpcap_dlg.c                   \
+       airpcap_gui_utils.c             \
+       capture_if_details_dlg_win32.c  \
+       capture_if_details_dlg_win32.h  \
+       gtkvumeter.c                    \
+       gtkvumeter.h                    \
+       doxygen.cfg.in                  \
+       libui.vcproj                    \
+       main_airpcap_toolbar.c          \
+       Makefile.common                 \
+       Makefile.nmake                  \
+       CMakeLists.txt                  \
+       Makefile_custom.common