carve out the (currently disabled) welcome page into it's own file to slightly reduce...
[obnox/wireshark/wip.git] / gtk / Makefile.am
index 639e3591cabbc045fcce9b41c2a276571787e1ec..530311d8c581726a53039adef34663ff0ac2a3ac 100644 (file)
@@ -1,10 +1,10 @@
 # Makefile.am
-# Automake file for the GTK interface routines for Ethereal
+# Automake file for the GTK interface routines for Wireshark
 #
-# $Id: Makefile.am,v 1.100 2004/06/03 21:46:27 guy Exp $
+# $Id$
 #
-# Ethereal - Network traffic analyzer
-# By Gerald Combs <gerald@ethereal.com>
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
 # Copyright 1998 Gerald Combs
 #
 # This program is free software; you can redistribute it and/or
 
 include Makefile.common
 
+if HAVE_WARNINGS_AS_ERRORS
+AM_CFLAGS = -Werror
+endif
+
 noinst_LIBRARIES = libui.a
 
 CLEANFILES = \
        libui.a         \
        *~
 
-ethereal-tap-register.c: $(ETHEREAL_TAP_SRC) $(top_srcdir)/make-tapreg-dotc
-       @echo Making ethereal-tap-register.c
-       @$(top_srcdir)/make-tapreg-dotc ethereal-tap-register.c $(srcdir) $(ETHEREAL_TAP_SRC)
+MAINTAINERCLEANFILES = \
+       $(GENERATED_FILES)      \
+       Makefile.in
+
+wireshark-tap-register.c: $(WIRESHARK_TAP_SRC) $(top_srcdir)/make-tapreg-dotc
+       @echo Making wireshark-tap-register.c
+       @$(top_srcdir)/make-tapreg-dotc wireshark-tap-register.c $(srcdir) $(WIRESHARK_TAP_SRC)
 
 noinst_HEADERS = \
        about_dlg.h     \
-       capture_combo_utils.h \
+       airpcap_dlg.h \
+       airpcap_gui_utils.h \
        capture_dlg.h   \
+       capture_file_dlg.h      \
+       capture_if_details_dlg.h        \
        capture_prefs.h \
+       cfilter_combo_utils.h \
        color_dlg.h     \
-       color_filters.h \
-       color_utils.h   \
+       color_edit_dlg.h        \
        colors.h        \
        column_prefs.h  \
        compat_macros.h \
+       conversations_table.h \
+       decode_as_ber.h \
        decode_as_dlg.h \
+       decode_as_dcerpc.h \
        dfilter_expr_dlg.h \
        dlg_utils.h     \
-       endpoint_talkers_table.h \
+       expert_comp_table.h     \
+       export_object.h \
        file_dlg.h      \
-       filter_prefs.h  \
+       fileset_dlg.h   \
+       filter_dlg.h    \
        find_dlg.h      \
-       follow_dlg.h    \
+       firewall_dlg.h  \
+       follow_ssl.h    \
+       follow_stream.h \
+       follow_tcp.h    \
+       follow_udp.h    \
+       font_utils.h    \
        goto_dlg.h      \
+       graph_analysis.h \
        gsm_map_stat.h  \
        gtkglobals.h    \
-       gtk_stat_util.h \
+       gtkvumeter.h \
+       gui_stat_util.h \
        gui_prefs.h     \
+       gui_utils.h     \
        help_dlg.h      \
        hostlist_table.h \
+       isprint.h       \
        keys.h          \
        layout_prefs.h  \
+       macros_dlg.h    \
        main.h          \
+       main_welcome.h          \
        menu.h          \
        mtp3_stat.h     \
        nameres_prefs.h \
+       packet_history.h        \
        packet_list.h   \
        packet_win.h    \
+       pixmap_save.h   \
+       plugins_dlg.h   \
        prefs_dlg.h     \
        print_prefs.h   \
+       profile_dlg.h   \
        proto_dlg.h     \
        proto_draw.h    \
        proto_hier_stats_dlg.h  \
        range_utils.h \
        recent.h        \
        rtp_analysis.h  \
+       rtp_player.h    \
+       rtp_player_prefs.h      \
        rtp_stream.h    \
        rtp_stream_dlg.h \
+       mcast_stream.h  \
+       mcast_stream_dlg.h \
        sat.h           \
+       sctp_stat.h     \
        service_response_time_table.h   \
+       gui_stat_menu.h \
        stream_prefs.h  \
        summary_dlg.h   \
        supported_protos_dlg.h   \
-       tap_dfilter_dlg.h \
-       tap_menu.h      \
        text_page.h     \
-       toolbar.h       \
-       ui_util.h
+       toolbar.h       \
+       u3.h \
+       uat_gui.h \
+       voip_calls.h    \
+       voip_calls_dlg.h \
+       webbrowser.h
 
 if USE_GTK2
 libui_a_SOURCES = \
-       $(ETHEREAL_GTK_SRC) \
+       $(WIRESHARK_GTK_SRC) \
        $(noinst_HEADERS) \
-       $(ETHEREAL_TAP_SRC)
+       $(WIRESHARK_TAP_SRC)
 else
 libui_a_SOURCES = \
        ethclist.c      \
        ethclist.h      \
-       $(ETHEREAL_GTK_SRC) \
+       $(WIRESHARK_GTK_SRC) \
        $(noinst_HEADERS) \
-       $(ETHEREAL_TAP_SRC)
+       $(WIRESHARK_TAP_SRC)
 endif
 
+libui_a_DEPENDENCIES = 
+
 EXTRA_DIST = \
-       doxygen.cfg \
+       airpcap_dlg.c \
+       airpcap_gui_utils.c \
+       capture_if_details_dlg.c        \
+       doxygen.cfg.in \
+       ethclist.c      \
+       ethclist.h      \
        Makefile.common \
        Makefile.nmake \
        print_mswin.c  \
-       print_mswin.h
+       print_mswin.h  \
+       win32-file-dlg.c \
+       win32-file-dlg.h
 
 # Common headers
-AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/wiretap
+AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/wiretap $(LIBGCRYPT_CFLAGS) $(LIBGNUTLS_CFLAGS) $(PORTAUDIO_INCLUDES)
+
+
+doxygen:
+if HAVE_DOXYGEN
+       $(DOXYGEN) doxygen.cfg
+endif          # HAVE_DOXYGEN
+