carve out the (currently disabled) welcome page into it's own file to slightly reduce...
[obnox/wireshark/wip.git] / gtk / Makefile.am
index 2d85306bfdcfe1f162ce4175bf12789cc66a8c36..530311d8c581726a53039adef34663ff0ac2a3ac 100644 (file)
@@ -1,10 +1,10 @@
 # Makefile.am
-# Automake file for the GTK interface routines for Ethereal
+# Automake file for the GTK interface routines for Wireshark
 #
-# $Id: Makefile.am,v 1.67 2003/09/10 05:35:25 guy Exp $
+# $Id$
 #
-# Ethereal - Network traffic analyzer
-# By Gerald Combs <gerald@ethereal.com>
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
 # Copyright 1998 Gerald Combs
 #
 # This program is free software; you can redistribute it and/or
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
 
+include Makefile.common
+
+if HAVE_WARNINGS_AS_ERRORS
+AM_CFLAGS = -Werror
+endif
+
 noinst_LIBRARIES = libui.a
 
 CLEANFILES = \
        libui.a         \
        *~
 
-ETHEREAL_TAP_SRC = \
-               bootp_stat.c    \
-       dcerpc_stat.c   \
-       endpoint_talkers_eth.c  \
-       endpoint_talkers_fc.c   \
-       endpoint_talkers_fddi.c \
-       endpoint_talkers_ip.c   \
-       endpoint_talkers_ipx.c  \
-       endpoint_talkers_tcpip.c        \
-       endpoint_talkers_tr.c   \
-       endpoint_talkers_udpip.c        \
-       fc_stat.c       \
-       http_stat.c     \
-       io_stat.c       \
-       mgcp_stat.c     \
-       rpc_stat.c      \
-       rpc_progs.c     \
-       smb_stat.c      \
-       tap_rtp.c       \
-       wsp_stat.c
+MAINTAINERCLEANFILES = \
+       $(GENERATED_FILES)      \
+       Makefile.in
 
-ethereal-tap-register.c: $(ETHEREAL_TAP_SRC) $(top_srcdir)/make-tapreg-dotc
-       @echo Making ethereal-tap-register.c
-       @$(top_srcdir)/make-tapreg-dotc ethereal-tap-register.c $(srcdir) $(ETHEREAL_TAP_SRC)
+wireshark-tap-register.c: $(WIRESHARK_TAP_SRC) $(top_srcdir)/make-tapreg-dotc
+       @echo Making wireshark-tap-register.c
+       @$(top_srcdir)/make-tapreg-dotc wireshark-tap-register.c $(srcdir) $(WIRESHARK_TAP_SRC)
 
-if USE_GTK2
-libui_a_SOURCES = \
-       capture_combo_utils.c \
-       capture_combo_utils.h \
-       capture_dlg.c   \
+noinst_HEADERS = \
+       about_dlg.h     \
+       airpcap_dlg.h \
+       airpcap_gui_utils.h \
        capture_dlg.h   \
-       capture_prefs.c \
+       capture_file_dlg.h      \
+       capture_if_details_dlg.h        \
        capture_prefs.h \
-       color_dlg.c     \
+       cfilter_combo_utils.h \
        color_dlg.h     \
-       color_filters.c \
-       color_filters.h \
-       color_utils.c   \
-       color_utils.h   \
-       colors.c        \
+       color_edit_dlg.h        \
        colors.h        \
-       column_prefs.c  \
        column_prefs.h  \
        compat_macros.h \
-       decode_as_dlg.c \
+       conversations_table.h \
+       decode_as_ber.h \
        decode_as_dlg.h \
-       dfilter_expr_dlg.c \
+       decode_as_dcerpc.h \
        dfilter_expr_dlg.h \
-       display_opts.c  \
-       display_opts.h  \
-       dlg_utils.c     \
        dlg_utils.h     \
-       endpoint_talkers_table.c \
-       endpoint_talkers_table.h \
-       ethereal-tap-register.c \
-       file_dlg.c      \
+       expert_comp_table.h     \
+       export_object.h \
        file_dlg.h      \
-       filter_prefs.c  \
-       filter_prefs.h  \
-       find_dlg.c      \
+       fileset_dlg.h   \
+       filter_dlg.h    \
        find_dlg.h      \
-       follow_dlg.c    \
-       follow_dlg.h    \
-       goto_dlg.c      \
+       firewall_dlg.h  \
+       follow_ssl.h    \
+       follow_stream.h \
+       follow_tcp.h    \
+       follow_udp.h    \
+       font_utils.h    \
        goto_dlg.h      \
+       graph_analysis.h \
+       gsm_map_stat.h  \
        gtkglobals.h    \
-       gtk_stat_util.c \
-       gtk_stat_util.h \
-       gui_prefs.c     \
+       gtkvumeter.h \
+       gui_stat_util.h \
        gui_prefs.h     \
-       help_dlg.c      \
+       gui_utils.h     \
        help_dlg.h      \
+       hostlist_table.h \
+       isprint.h       \
        keys.h          \
-       main.c          \
+       layout_prefs.h  \
+       macros_dlg.h    \
        main.h          \
-       menu.c          \
+       main_welcome.h          \
        menu.h          \
-       nameres_prefs.c \
+       mtp3_stat.h     \
        nameres_prefs.h \
-       packet_list.c   \
-       packet_win.c    \
+       packet_history.h        \
+       packet_list.h   \
        packet_win.h    \
-       plugins_dlg.c   \
-       prefs_dlg.c     \
+       pixmap_save.h   \
+       plugins_dlg.h   \
        prefs_dlg.h     \
-       print_dlg.c     \
-       print_prefs.c   \
        print_prefs.h   \
-       progress_dlg.c  \
-       proto_dlg.c     \
+       profile_dlg.h   \
        proto_dlg.h     \
-       proto_draw.c    \
        proto_draw.h    \
        proto_hier_stats_dlg.h  \
-       proto_hier_stats_dlg.c  \
-       simple_dialog.c \
-       service_response_time_table.c   \
+       range_utils.h \
+       recent.h        \
+       rtp_analysis.h  \
+       rtp_player.h    \
+       rtp_player_prefs.h      \
+       rtp_stream.h    \
+       rtp_stream_dlg.h \
+       mcast_stream.h  \
+       mcast_stream_dlg.h \
+       sat.h           \
+       sctp_stat.h     \
        service_response_time_table.h   \
-       stream_prefs.c  \
+       gui_stat_menu.h \
        stream_prefs.h  \
-       summary_dlg.c   \
        summary_dlg.h   \
-       tcp_graph.c     \
-       tcp_graph.h     \
-       ui_util.c       \
-       ui_util.h       \
-       $(ETHEREAL_TAP_SRC)
+       supported_protos_dlg.h   \
+       text_page.h     \
+       toolbar.h       \
+       u3.h \
+       uat_gui.h \
+       voip_calls.h    \
+       voip_calls_dlg.h \
+       webbrowser.h
+
+if USE_GTK2
+libui_a_SOURCES = \
+       $(WIRESHARK_GTK_SRC) \
+       $(noinst_HEADERS) \
+       $(WIRESHARK_TAP_SRC)
 else
 libui_a_SOURCES = \
-       capture_combo_utils.c \
-       capture_combo_utils.h \
-       capture_dlg.c   \
-       capture_dlg.h   \
-       capture_prefs.c \
-       capture_prefs.h \
-       color_dlg.c     \
-       color_dlg.h     \
-       color_filters.c \
-       color_filters.h \
-       color_utils.c   \
-       color_utils.h   \
-       colors.c        \
-       colors.h        \
-       column_prefs.c  \
-       column_prefs.h  \
-       decode_as_dlg.c \
-       decode_as_dlg.h \
-       dfilter_expr_dlg.c \
-       dfilter_expr_dlg.h \
-       display_opts.c  \
-       display_opts.h  \
-       dlg_utils.c     \
-       dlg_utils.h     \
-       endpoint_talkers_table.c \
-       endpoint_talkers_table.h \
-       ethereal-tap-register.c \
-       file_dlg.c      \
-       file_dlg.h      \
-       filter_prefs.c  \
-       filter_prefs.h  \
-       find_dlg.c      \
-       find_dlg.h      \
-       follow_dlg.c    \
-       follow_dlg.h    \
-       goto_dlg.c      \
-       goto_dlg.h      \
-       gtkclist.c      \
-       gtkclist.h      \
-       gtkglobals.h    \
-       gtk_stat_util.c \
-       gtk_stat_util.h \
-       gui_prefs.c     \
-       gui_prefs.h     \
-       help_dlg.c      \
-       help_dlg.h      \
-       keys.h          \
-       main.c          \
-       main.h          \
-       menu.c          \
-       menu.h          \
-       nameres_prefs.c \
-       nameres_prefs.h \
-       packet_list.c   \
-       packet_win.c    \
-       packet_win.h    \
-       plugins_dlg.c   \
-       prefs_dlg.c     \
-       prefs_dlg.h     \
-       print_dlg.c     \
-       print_prefs.c   \
-       print_prefs.h   \
-       progress_dlg.c  \
-       proto_dlg.c     \
-       proto_dlg.h     \
-       proto_draw.c    \
-       proto_draw.h    \
-       proto_hier_stats_dlg.h  \
-       proto_hier_stats_dlg.c  \
-       service_response_time_table.c   \
-       service_response_time_table.h   \
-       simple_dialog.c \
-       stream_prefs.c  \
-       stream_prefs.h  \
-       summary_dlg.c   \
-       summary_dlg.h   \
-       tcp_graph.c     \
-       tcp_graph.h     \
-       ui_util.c       \
-       ui_util.h       \
-       $(ETHEREAL_TAP_SRC)
+       ethclist.c      \
+       ethclist.h      \
+       $(WIRESHARK_GTK_SRC) \
+       $(noinst_HEADERS) \
+       $(WIRESHARK_TAP_SRC)
 endif
 
+libui_a_DEPENDENCIES = 
+
 EXTRA_DIST = \
+       airpcap_dlg.c \
+       airpcap_gui_utils.c \
+       capture_if_details_dlg.c        \
+       doxygen.cfg.in \
+       ethclist.c      \
+       ethclist.h      \
+       Makefile.common \
        Makefile.nmake \
-       compat_macros.h \
        print_mswin.c  \
-       print_mswin.h
+       print_mswin.h  \
+       win32-file-dlg.c \
+       win32-file-dlg.h
+
+# Common headers
+AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/wiretap $(LIBGCRYPT_CFLAGS) $(LIBGNUTLS_CFLAGS) $(PORTAUDIO_INCLUDES)
+
+
+doxygen:
+if HAVE_DOXYGEN
+       $(DOXYGEN) doxygen.cfg
+endif          # HAVE_DOXYGEN
+