Trying to get buildbot Ubuntu-5.10-x86 distcheck to build again
[obnox/wireshark/wip.git] / epan / Makefile.am
index c97626b103efe918c091047718a1279c2c3b9a20..4e7aa40fa3bf1fa9dcb88c6e5c873aefad41a924 100644 (file)
@@ -2,12 +2,11 @@
 # Automake file for the EPAN library
 # (Ethereal Protocol ANalyzer Library)
 #
-# $Id: Makefile.am,v 1.14 2000/11/20 16:18:08 gram Exp $
+# $Id$
 #
-# Ethereal - Network traffic analyzer
-# By Gerald Combs <gerald@zing.org>
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
 # Copyright 1998 Gerald Combs
-#
 # 
 # This program is free software; you can redistribute it and/or
 # modify it under the terms of the GNU General Public License
 # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
 
 
-# Any POSIX-compatible YACC should honor the -p flag
-YFLAGS=-d -p dfilter_
+if HAVE_LIBLUA
+wslua_lib = wslua/libwslua.la
+wslua_dir = wslua
+wslua_dist_dir = 
+else            # HAVE_LIBLUA
+wslua_lib =
+wslua_dir =
+wslua_dist_dir = wslua
+endif           # HAVE_LIBLUA
+
+
+SUBDIRS = crypt ftypes dfilter dissectors $(wslua_dir)
+
+DIST_SUBDIRS = $(SUBDIRS) $(wslua_dist_dir)
 
 # EPAN will eventually be a shared library. While I move source code around,
 # however, it is an archive library.
 
 ACLOCAL_AMFLAGS = `../aclocal-flags`
 
-noinst_LIBRARIES = libethereal.a
-
-INCLUDES = -I$(srcdir)/..
-
-libethereal_a_SOURCES = \
-       bitswap.c               \
-       bitswap.h               \
-       conversation.c          \
-       conversation.h          \
-       dfilter-int.h           \
-       dfilter-grammar.y       \
-       dfilter-scanner.l       \
-       dfilter.c               \
-       dfilter.h               \
-       epan.c                  \
-       epan.h                  \
-       except.c                \
-       except.h                \
-       exceptions.h            \
-       filesystem.c            \
-       filesystem.h            \
-       ipv4.c                  \
-       ipv4.h                  \
-       packet.c                \
-       packet.h                \
-       pint.h                  \
-       plugins.c               \
-       plugins.h               \
-       proto.c                 \
-       proto.h                 \
-       resolv.c                \
-       resolv.h                \
-       strutil.c               \
-       strutil.h               \
-       tvbuff.c                \
-       tvbuff.h
-
-EXTRA_libethereal_a_SOURCES =  \
-       dfilter-grammar.c       \
-       dfilter-grammar.h       \
-       dfilter-scanner.c       \
-        inet_aton.c            \
+lib_LTLIBRARIES = libwireshark.la
+libwireshark_la_LDFLAGS = -version-info 0:1:0 @SHAREDLIB_LDFLAGS@
+
+include Makefile.common
+
+INCLUDES = -I$(srcdir)/.. -I$(srcdir)/$(LEMON) @LUA_INCLUDES@ \
+       $(LIBGNUTLS_CFLAGS) $(LIBGCRYPT_CFLAGS)
+
+libwireshark_la_SOURCES = \
+       $(LIBWIRESHARK_SRC)     \
+       $(LIBWIRESHARK_INCLUDES)
+
+EXTRA_libwireshark_la_SOURCES =        \
+       g_ascii_strtoull.c      \
+       g_ascii_strtoull.h      \
+       inet_aton.c             \
        inet_pton.c             \
        inet_ntop.c             \
        inet_aton.h             \
        inet_v6defs.h
 
 EXTRA_DIST = \
-       config.h.win32          \
-       Makefile.nmake          \
-       tvbtest.c
+       dtd_grammar.lemon \
+       dtd_parse.l \
+       dtd_preparse.l \
+       load_snmp_users_file.l \
+       enterprise-numbers  \
+       libwireshark.def        \
+       Makefile.common \
+       Makefile.nmake  \
+       make-sminmpec.pl \
+       radius_dict.l   \
+       tvbtest.c       \
+       exntest.c       \
+       doxygen.cfg.in
 
 CLEANFILES = \
-       libethereal.a   \
+       libwireshark.a          \
+       libwireshark.la         \
        *~
 
+DISTCLEANFILES = \
+       dtd_grammar.out         \
+       dtd_grammar.c           \
+       dtd_grammar.h           \
+       dtd_parse.c             \
+       dtd_preparse.c          \
+       load_snmp_users_file.c          \
+       radius_dict.c
+       
+
+MAINTAINERCLEANFILES = \
+       Makefile.in             \
+       sminmpec.c
+
+
 #
 # Add the object files for missing routines, if any.
 #
-libethereal_a_LIBADD = @INET_ATON_O@ @INET_PTON_O@ @INET_NTOP_O@
-libethereal_a_DEPENDENCIES = @INET_ATON_O@ @INET_PTON_O@ @INET_NTOP_O@
+libwireshark_la_LIBADD = @G_ASCII_STRTOULL_LO@ @INET_ATON_LO@ @INET_PTON_LO@ @INET_NTOP_LO@ crypt/libairpdcap.la ftypes/libftypes.la dfilter/libdfilter.la dissectors/libdissectors.la $(wslua_lib) @ADNS_LIBS@ @LIBGNUTLS_LIBS@ @LIBICONV@ @KRB5_LIBS@ @SNMP_LIBS@ @SSL_LIBS@ -lm
+libwireshark_la_DEPENDENCIES = @G_ASCII_STRTOULL_LO@ @INET_ATON_LO@ @INET_PTON_LO@ @INET_NTOP_LO@ crypt/libairpdcap.la ftypes/libftypes.la dfilter/libdfilter.la dissectors/libdissectors.la $(wslua_lib)
+
+tvbtest: tvbtest.o tvbuff.o except.o strutil.o emem.o
+       $(LINK) $^ $(GLIB_LIBS) -lz
+
+exntest: exntest.o except.o
+       $(LINK) $^ $(GLIB_LIBS)
+
+radius_dict.c: radius_dict.l
+       $(LEX) $^
+
+load_snmp_users_file.c: load_snmp_users_file.l
+       $(LEX) -oload_snmp_users_file.c $(srcdir)/load_snmp_users_file.l
+       
+dtd_parse.c : dtd_parse.l
+       $(LEX) -odtd_parse.c $(srcdir)/dtd_parse.l
+
+dtd_preparse.c : dtd_preparse.l
+       $(LEX) -odtd_preparse.c $(srcdir)/dtd_preparse.l
+
+dtd_grammar.h: dtd_grammar.c
+
+LEMON=../tools/lemon
+
+dtd_grammar.c: dtd_grammar.lemon $(LEMON)/lemon$(EXEEXT)
+       $(LEMON)/lemon$(EXEEXT) t=$(srcdir)/$(LEMON)/lempar.c $(srcdir)/dtd_grammar.lemon
+       
+tvbtest.o exntest.o: exceptions.h
+
+sminmpec.c: enterprise-numbers make-sminmpec.pl
+       $(PERL) $(srcdir)/make-sminmpec.pl $(srcdir)/enterprise-numbers sminmpec.c
+
+if HAVE_PLUGINS
+
+if ENABLE_STATIC
+
+plugin_src = \
+       ../plugins/artnet/packet-artnet.c \
+       ../plugins/asn1/packet-asn1.c \
+       ../plugins/docsis/packet-bpkmattr.c \
+       ../plugins/docsis/packet-bpkmreq.c \
+       ../plugins/docsis/packet-bpkmrsp.c \
+       ../plugins/docsis/packet-docsis.c \
+       ../plugins/docsis/packet-dsaack.c \
+       ../plugins/docsis/packet-dsareq.c \
+       ../plugins/docsis/packet-dsarsp.c \
+       ../plugins/docsis/packet-dscack.c \
+       ../plugins/docsis/packet-dscreq.c \
+       ../plugins/docsis/packet-dscrsp.c \
+       ../plugins/docsis/packet-dsdreq.c \
+       ../plugins/docsis/packet-dsdrsp.c \
+       ../plugins/docsis/packet-intrngreq.c \
+       ../plugins/docsis/packet-macmgmt.c \
+       ../plugins/docsis/packet-map.c \
+       ../plugins/docsis/packet-regack.c \
+       ../plugins/docsis/packet-regreq.c \
+       ../plugins/docsis/packet-regrsp.c \
+       ../plugins/docsis/packet-rngreq.c \
+       ../plugins/docsis/packet-rngrsp.c \
+       ../plugins/docsis/packet-tlv.c \
+       ../plugins/docsis/packet-type29ucd.c \
+       ../plugins/docsis/packet-uccreq.c \
+       ../plugins/docsis/packet-uccrsp.c \
+       ../plugins/docsis/packet-ucd.c \
+       ../plugins/enttec/packet-enttec.c \
+       ../plugins/giop/packet-cosnaming.c \
+       ../plugins/giop/packet-coseventcomm.c \
+       ../plugins/gryphon/packet-gryphon.c \
+       ../plugins/irda/packet-irda.c \
+       ../plugins/lwres/packet-lwres.c \
+       ../plugins/megaco/packet-megaco.c \
+       ../plugins/mgcp/packet-mgcp.c \
+       ../plugins/pcli/packet-pcli.c \
+       ../plugins/rdm/packet-rdm.c \
+       ../plugins/rtnet/packet-rtnet.c \
+       ../plugins/v5ua/packet-v5ua.c
+
+else           # ENABLE_STATIC
+
+plugin_src =
+
+endif          # ENABLE_STATIC
+
+else           # HAVE_PLUGINS
+plugin_src =
+
+endif          # HAVE_PLUGINS
 
-dfilter-scanner.c : dfilter-scanner.l
-       $(LEX) -Pdfilter_ -odfilter-scanner.c $(srcdir)/dfilter-scanner.l
+doxygen:
+if HAVE_DOXYGEN
+       $(DOXYGEN) doxygen.cfg
+endif          # HAVE_DOXYGEN
 
-tvbtest: tvbtest.o tvbuff.o except.o strutil.o
-       $(LINK) -o tvbtest tvbtest.o tvbuff.o except.o strutil.o `glib-config --libs`