change all file offsets from long to gint64 so we can - theoretically - handle files...
[obnox/wireshark/wip.git] / doc / Makefile.am
index ebe49fe5da81b2e5a75400788b6ea6e8c7007d71..205438270d08303865d629e715b41efd10da32dc 100644 (file)
@@ -1,10 +1,10 @@
 # Makefile.am
-# Automake file for Ethereal documentation
+# Automake file for Wireshark documentation
 #
 # $Id$
 #
-# Ethereal - Network traffic analyzer
-# By Gerald Combs <gerald@ethereal.com>
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
 # Copyright 1998 Gerald Combs
 # 
 # This program is free software; you can redistribute it and/or
 # We include dependencies on ../config.h in order to
 # capture when $(VERSION) changes.
 
-ethereal-tmp.pod: $(srcdir)/ethereal.pod $(top_builddir)/AUTHORS-SHORT-FORMAT
-       cat $(srcdir)/ethereal.pod $(top_builddir)/AUTHORS-SHORT-FORMAT > ethereal-tmp.pod
+wireshark-tmp.pod: $(srcdir)/wireshark.pod $(top_builddir)/AUTHORS-SHORT-FORMAT
+       cat $(srcdir)/wireshark.pod $(top_builddir)/AUTHORS-SHORT-FORMAT > wireshark-tmp.pod
 
-../ethereal.1: ethereal-tmp.pod ../config.h
+../wireshark.1: wireshark-tmp.pod ../config.h
        $(POD2MAN)                                      \
-       --center="The Ethereal Network Analyzer"        \
+       --center="The Wireshark Network Analyzer"       \
        --release=$(VERSION)                            \
-       ethereal-tmp.pod | sed 's/ETHEREAL-TMP/ETHEREAL/' > ../ethereal.1
+       wireshark-tmp.pod | sed 's/WIRESHARK-TMP/WIRESHARK/' > ../wireshark.1
 
-../ethereal.html: ethereal-tmp.pod ../config.h
+../wireshark.html: wireshark-tmp.pod ../config.h
        $(POD2HTML)                                             \
-       --title="The Ethereal Network Analyzer $(VERSION)"      \
+       --title="The Wireshark Network Analyzer $(VERSION)"     \
        --noindex                                               \
-       ethereal-tmp.pod > ../ethereal.html
+       wireshark-tmp.pod > ../wireshark.html
 
-../tethereal.1: tethereal.pod ../config.h
+../tshark.1: tshark.pod ../config.h
        $(POD2MAN)                                      \
-       --center="The Ethereal Network Analyzer"        \
+       --center="The Wireshark Network Analyzer"       \
        --release=$(VERSION)                            \
-       $(srcdir)/tethereal.pod > ../tethereal.1
+       $(srcdir)/tshark.pod > ../tshark.1
 
-../tethereal.html: tethereal.pod ../config.h
+../tshark.html: tshark.pod ../config.h
        $(POD2HTML)                                                     \
-       --title="tethereal - The Ethereal Network Analyzer $(VERSION)"  \
+       --title="tshark - The Wireshark Network Analyzer $(VERSION)"    \
        --noindex                                                       \
-       $(srcdir)/tethereal.pod > ../tethereal.html
+       $(srcdir)/tshark.pod > ../tshark.html
 
-../ethereal-filter.4: ethereal-filter.pod ../config.h
+../wireshark-filter.4: wireshark-filter.pod ../config.h
        $(POD2MAN)                                      \
        --section=4                                     \
-       --center="The Ethereal Network Analyzer"        \
+       --center="The Wireshark Network Analyzer"       \
        --release=$(VERSION)                            \
-       ethereal-filter.pod > ../ethereal-filter.4
+       wireshark-filter.pod > ../wireshark-filter.4
 
-../ethereal-filter.html: ethereal-filter.pod ../config.h
+../wireshark-filter.html: wireshark-filter.pod ../config.h
        $(POD2HTML)                                                             \
-       --title="ethereal-filter - The Ethereal Network Analyzer $(VERSION)"    \
+       --title="wireshark-filter - The Wireshark Network Analyzer $(VERSION)"  \
        --noindex                                                               \
-       ethereal-filter.pod > ../ethereal-filter.html
+       wireshark-filter.pod > ../wireshark-filter.html
 
-ethereal-filter.pod: ethereal-filter.pod.template  ../tethereal
-       ../tethereal -G fields | $(PERL) $(srcdir)/dfilter2pod.pl $(srcdir)/ethereal-filter.pod.template > ethereal-filter.pod
+wireshark-filter.pod: wireshark-filter.pod.template  ../tshark
+       ../tshark -G fields | $(PERL) $(srcdir)/dfilter2pod.pl $(srcdir)/wireshark-filter.pod.template > wireshark-filter.pod
 
 ../capinfos.1: capinfos.pod ../config.h
        $(POD2MAN)                                      \
-       --center="The Ethereal Network Analyzer"        \
+       --center="The Wireshark Network Analyzer"       \
        --release=$(VERSION)                            \
        $(srcdir)/capinfos.pod > ../capinfos.1
 
 ../capinfos.html: capinfos.pod ../config.h
        $(POD2HTML)                                                     \
-       --title="capinfos - The Ethereal Network Analyzer $(VERSION)"   \
+       --title="capinfos - The Wireshark Network Analyzer $(VERSION)"  \
        --noindex                                                       \
        $(srcdir)/capinfos.pod > ../capinfos.html
 
 ../editcap.1: editcap.pod ../config.h
        $(POD2MAN)                                      \
-       --center="The Ethereal Network Analyzer"        \
+       --center="The Wireshark Network Analyzer"       \
        --release=$(VERSION)                            \
        $(srcdir)/editcap.pod > ../editcap.1
 
 ../editcap.html: editcap.pod ../config.h
        $(POD2HTML)                                                     \
-       --title="editcap - The Ethereal Network Analyzer $(VERSION)"    \
+       --title="editcap - The Wireshark Network Analyzer $(VERSION)"   \
        --noindex                                                       \
        $(srcdir)/editcap.pod > ../editcap.html
 
-../idl2eth.1: idl2eth.pod ../config.h
+../idl2wrs.1: idl2wrs.pod ../config.h
        $(POD2MAN)                                      \
-       --center="The Ethereal Network Analyzer"        \
+       --center="The Wireshark Network Analyzer"       \
        --release=$(VERSION)                            \
-       $(srcdir)/idl2eth.pod > ../idl2eth.1
+       $(srcdir)/idl2wrs.pod > ../idl2wrs.1
 
-../idl2eth.html: idl2eth.pod ../config.h
+../idl2wrs.html: idl2wrs.pod ../config.h
        $(POD2HTML)                                                     \
-       --title="idl2eth - The Ethereal Network Analyzer $(VERSION)"    \
+       --title="idl2wrs - The Wireshark Network Analyzer $(VERSION)"   \
        --noindex                                                       \
-       $(srcdir)/idl2eth.pod > ../idl2eth.html
+       $(srcdir)/idl2wrs.pod > ../idl2wrs.html
 
 ../mergecap.1: mergecap.pod ../config.h
        $(POD2MAN)                                      \
-       --center="The Ethereal Network Analyzer"        \
+       --center="The Wireshark Network Analyzer"       \
        --release=$(VERSION)                            \
        $(srcdir)/mergecap.pod > ../mergecap.1
 
 ../mergecap.html: mergecap.pod ../config.h
        $(POD2HTML)                                                     \
-       --title="mergecap - The Ethereal Network Analyzer $(VERSION)"   \
+       --title="mergecap - The Wireshark Network Analyzer $(VERSION)"  \
        --noindex                                                       \
        $(srcdir)/mergecap.pod > ../mergecap.html
 
 ../text2pcap.1: text2pcap.pod ../config.h
        $(POD2MAN)                                      \
-       --center="The Ethereal Network Analyzer"        \
+       --center="The Wireshark Network Analyzer"       \
        --release=$(VERSION)                            \
        $(srcdir)/text2pcap.pod > ../text2pcap.1
 
 ../text2pcap.html: text2pcap.pod ../config.h
        $(POD2HTML)                     \
-       --title="text2pcap - The Ethereal Network Analyzer $(VERSION)"  \
+       --title="text2pcap - The Wireshark Network Analyzer $(VERSION)" \
        --noindex                                                       \
        $(srcdir)/text2pcap.pod > ../text2pcap.html
 
+../dumpcap.1: dumpcap.pod ../config.h
+       $(POD2MAN)                                      \
+       --center="The Wireshark Network Analyzer"       \
+       --release=$(VERSION)                            \
+       $(srcdir)/dumpcap.pod > ../dumpcap.1
+
+../dumpcap.html: dumpcap.pod ../config.h
+       $(POD2HTML)                     \
+       --title="dumpcap - The Wireshark Network Analyzer $(VERSION)"   \
+       --noindex                                                       \
+       $(srcdir)/dumpcap.pod > ../dumpcap.html
+
 CLEANFILES =           \
-       ethereal-filter.pod \
-       ethereal-tmp.pod \
-       ../ethereal-filter.4 \
-       ../ethereal-filter.html \
-       ../ethereal.1   \
-       ../ethereal.html        \
+       wireshark-filter.pod \
+       wireshark-tmp.pod \
+       ../wireshark-filter.4 \
+       ../wireshark-filter.html \
+       ../wireshark.1  \
+       ../wireshark.html       \
        ../capinfos.1   \
        ../capinfos.html        \
        ../editcap.1    \
        ../editcap.html \
        ../mergecap.1   \
        ../mergecap.html        \
-       ../tethereal.1  \
-       ../tethereal.html       \
+       ../tshark.1     \
+       ../tshark.html  \
        ../text2pcap.1  \
        ../text2pcap.html       \
-       ../idl2eth.1    \
-       ../idl2eth.html
+       ../dumpcap.1    \
+       ../dumpcap.html \
+       ../idl2wrs.1    \
+       ../idl2wrs.html
 
 DISTCLEANFILES =       \
        pod2htmi.tmp    \