mate_grammar.lemon:
[obnox/wireshark/wip.git] / configure.in
index e171b7cdc6ff981fbf7798bf9c1802f61a694c36..a522a1d31f70579a1791172b880efd0c7a548c95 100644 (file)
@@ -885,6 +885,8 @@ AC_MSG_CHECKING(whether GLib supports loadable modules)
 ac_save_CFLAGS="$CFLAGS"
 ac_save_LIBS="$LIBS"
 CFLAGS="$CFLAGS $GLIB_CFLAGS"
+# Error out on the usage of deprecated glib functions
+CFLAGS="$CFLAGS -DG_DISABLE_DEPRECATED"
 LIBS="$GLIB_LIBS $LIBS"
 AC_TRY_RUN([
 #include <glib.h>