- Move setting _U_ into config.h, because
[obnox/wireshark/wip.git] / README.hpux
index cc061fb9c99afb3fe11c9f787213a3639182a32d..e3b3a8aa01e48ef6794060124b988c22ea8f0d69 100644 (file)
@@ -2,13 +2,13 @@ $Id$
 
 Contents:
 
-1 - Building ethereal
+1 - Building wireshark
 2 - Building GTK+/GLib with HP's C compiler
 3 - nettl support
 4 - libpcap on HP-UX
 5 - HP-UX patches to fix packet capture problems
 
-1 - Building ethereal
+1 - Building wireshark
 
 The Software Porting And Archive Centre for HP-UX, at
 
@@ -16,11 +16,11 @@ The Software Porting And Archive Centre for HP-UX, at
 
 (with mirrors in various countries, listed on the Centre's home page;
 you may want to choose a mirror closer to you) has ported versions, in
-both source and binary form, for Ethereal, as well as for the libpcap,
+both source and binary form, for Wireshark, as well as for the libpcap,
 GLib, GTK+, and zlib libraries that it uses.
 
 The changes they've made appear largely to be compile option changes; if
-you've downloaded the source to the latest version of Ethereal (the
+you've downloaded the source to the latest version of Wireshark (the
 version on the Centre's site may not necessarily be the latest version),
 it should be able to compile, perhaps with those changes.
 
@@ -40,12 +40,12 @@ By default, HP's C compiler doesn't support "long long int" to provide
 64-bit integral data types on 32-bit platforms; the "-Ae" flag must be
 supplied to enable extensions such as that.
 
-Ethereal's "configure" script automatically includes that flag if it
+Wireshark's "configure" script automatically includes that flag if it
 detects that the native compiler is being used on HP-UX; however, the
 configure scripts for GTK+ and GLib don't do so, which means that 64-bit
 integer support won't be enabled.
 
-This may prevent some parts of Ethereal from compiling; in order to get
+This may prevent some parts of Wireshark from compiling; in order to get
 64-bit integer support in GTK+/GLib, edit all the Makefiles for GTK+ and
 GLib, as generated by the GTK+ and GLib "configure" scripts, to add
 "-Ae" to all "CFLAGS = " definitions found in those Makefiles.  (If a
@@ -54,7 +54,7 @@ definition that includes "-Ae".)
 
 3 - nettl support
 
-nettl is used on HP-UX to trace various streams based subsystems.  Ethereal
+nettl is used on HP-UX to trace various streams based subsystems.  Wireshark
 can read nettl files containing raw IP frames (NS_LS_IP, NS_LS_TCP,
 NS_LS_UDP, NS_LS_ICMP subsystems), all ethernet/tokenring/fddi driver
 level frames (such as BTLAN, BASE100, GELAN, IGELAN subsystems) and LAPB
@@ -80,7 +80,7 @@ on old versions of 10.20 and 9.04.
 
 4 - libpcap on HP-UX
 
-If you want to use Ethereal to capture packets, you will have to install
+If you want to use Wireshark to capture packets, you will have to install
 libpcap; binary distributions are, as noted above, available from the
 Software Porting And Archive Centre for HP-UX, as well as source code.
 
@@ -99,7 +99,7 @@ as a shared library.
 
 5 - HP-UX patches to fix packet capture problems
 
-Note that packet-capture programs such as Ethereal/Tethereal or tcpdump
+Note that packet-capture programs such as Wireshark/TShark or tcpdump
 may, on HP-UX, not be able to see packets sent from the machine on which
 they're running.  Make sure you have a recent "LAN Cummulative/DLPI" patch
 installed.
@@ -253,11 +253,11 @@ promiscuous mode support.
 
 An additional note, from Jost Martin, for HP-UX 10.20:
 
-       Q: How do I get ethereral on HPUX to capture the _outgoing_ packets
+       Q: How do I get wireshark on HPUX to capture the _outgoing_ packets
           of an interface
        A: You need to get PHNE_20892,PHNE_20725 and PHCO_10947 (or
           newer, this is as of 4.4.00) and its dependencies.  Then you can
-          enable the feature as descibed below:
+          enable the feature as described below:
 
        Patch Name: PHNE_20892
        Patch Description: s700 10.20 PCI 100Base-T cumulative patch