* Modified Makefile.am and configure.in so that wiretap isn't built unless
[obnox/wireshark/wip.git] / ethereal.spec
1 # Note that this is NOT a relocatable package
2 %define ver      0.5.1
3 %define rel      1
4 %define prefix   /usr/X11R6
5
6 Summary:        Network traffic analyzer
7 Name:           ethereal
8 Version:        %ver
9 Release:        %rel
10 Copyright:      GPL
11 Group:          Networking/Utilities
12 Source:         ethereal-%{PACKAGE_VERSION}.tar.gz
13 URL:            http://ethereal.zing.org/
14 BuildRoot:      /tmp/ethereal-%{PACKAGE_VERSION}-root
15 Packager:       FastJack <fastjack@i-s-o.net>
16 Requires:       gtk+10
17 Requires:       libpcap
18
19 %description
20 Ethereal is a network traffic analyzer for Unix-ish operating systems.
21
22 %prep
23 %setup
24 CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%prefix --sysconfdir=/etc
25 make
26
27 %install
28 rm -rf $RPM_BUILD_ROOT
29 mkdir -p $RPM_BUILD_ROOT/{etc,usr/X11R6/bin,usr/X11R6/man/man1}
30
31 # can't use make install here. It would put manuf directly into /etc
32 cp ethereal $RPM_BUILD_ROOT/usr/X11R6/bin
33 cp ethereal.1 $RPM_BUILD_ROOT/usr/X11R6/man/man1
34 cp manuf $RPM_BUILD_ROOT/etc
35
36 %clean
37 rm -rf $RPM_BUILD_ROOT
38
39 %files
40 %defattr(-, root, root)
41 %doc AUTHORS COPYING ChangeLog INSTALL NEWS README
42 %config /etc/manuf
43 /usr/X11R6/bin/ethereal
44 /usr/X11R6/man/man1/ethereal.1
45
46 %changelog
47 * Sun Jan 01 1999 Gerald Combs <gerald@zing.org>
48 - updated to 0.5.1
49
50 * Fri Nov 20 1998 FastJack <fastjack@i-s-o.net>
51 - updated to 0.5.0
52
53 * Sun Nov 15 1998 FastJack <fastjack@i-s-o.net>
54 - created .spec file
55