Update some links.
[obnox/wireshark/wip.git] / config.nmake
1 # $Id$
2
3 # Some more information about the settings in this file can be found in
4 # the file README.windows and the Developer's Guide (available online).
5
6 ##### Target platform #####
7 # Only "win32" and "win64" are valid (for now).
8 # This can be defined in the system environment.
9 !IFNDEF WIRESHARK_TARGET_PLATFORM
10 WIRESHARK_TARGET_PLATFORM=win32
11 !ENDIF
12
13 ##### Versions #####
14
15 # The current Wireshark version
16 # It's highly recommended to leave MAJOR/MINOR/MICRO unchanged
17 VERSION_MAJOR=1
18 VERSION_MINOR=5
19 VERSION_MICRO=0
20 VERSION_BUILD=0
21 # It's recommended to change VERSION_EXTRA for your own custom builds
22 # e.g. "-SVN-12345"
23 VERSION_EXTRA=
24
25 # The version of the wiretap library (recommended: leave unchanged)
26 WTAP_VERSION_MAJOR=0
27 WTAP_VERSION_MINOR=3
28 WTAP_VERSION_MICRO=1
29
30
31
32 ##### Directories #####
33
34 #
35 # Base directory, where your libraries reside, which are needed to
36 # compile the sources. This setting is used only inside this file.
37 #
38 WIRESHARK_LIBS=C:\wireshark-$(WIRESHARK_TARGET_PLATFORM)-libs
39
40 #
41 # Base directory, where your programs reside.
42 # This setting is used only inside this file.
43 #
44 PROGRAM_FILES=$(PROGRAMFILES)
45
46 #
47 # Location of the "tools" directory. This affects HTML2TXT below and should
48 # be overridden by makefiles in any subdirectories that use HTML2TXT.
49 !IFNDEF TOOLS_DIR
50 TOOLS_DIR=tools
51 !ENDIF
52
53 #
54 # Machine type for the compiler and linker
55 # TARGET_MACHINE (Used for link /MACHINE) should be one of "X86" or "X64"
56 # (sorry ARM, Alpha, MIPS, and Itanium fans).
57 # CPU (Used by win32.mak) should be one of "i386" or "AMD64".
58 !if "$(WIRESHARK_TARGET_PLATFORM)" == "win32"
59 TARGET_MACHINE=x86
60 CPU=i386
61 VCREDIST_DLL=x86
62 !else if "$(WIRESHARK_TARGET_PLATFORM)" == "win64"
63 TARGET_MACHINE=x64
64 CPU=AMD64
65 VCREDIST_DLL=amd64
66 !else
67 !error Your mysterious moon-man architecture "$(WIRESHARK_TARGET_PLATFORM)" frightens and confuses us.
68 !endif
69
70
71 ##### Microsoft Visual C / Studio Variant #####
72 # for the different Studios, see: http://en.wikipedia.org/wiki/Microsoft_Visual_Studio
73 # only one of the following MSVC_VARIANT settings should be used
74 # BTW: The "Microsoft Visual C++ Toolkit 2003" DOESN'T WORK for WS!
75
76 # "Microsoft Visual Studio 6.0"
77 # Visual C++ 6.0, _MSC_VER 1200, msvcrt.dll (version 6)
78 #MSVC_VARIANT=MSVC6
79
80 # "Microsoft Visual Studio .NET (2002)"
81 # Visual C++ 7.0, _MSC_VER 1300, msvcr70.dll
82 #MSVC_VARIANT=MSVC2002
83
84 # "Microsoft .Net Framework SDK Version 1.0"
85 # needs additional Platform SDK installation
86 # Visual C++ 7.0, _MSC_VER 1300, msvcr70.dll
87 #MSVC_VARIANT=DOTNET10
88
89 # "Microsoft Visual Studio .NET 2003"
90 # Visual C++ 7.1, _MSC_VER 1310, msvcr71.dll
91 #MSVC_VARIANT=MSVC2003
92
93 # "Microsoft .Net Framework SDK Version 1.1"
94 # needs additional Platform SDK installation
95 # Visual C++ 7.1, _MSC_VER 1310, msvcr71.dll
96 #MSVC_VARIANT=DOTNET11
97
98 # "Microsoft Visual Studio 2005"
99 # Visual C++ 8.0, _MSC_VER 1400, msvcr80.dll
100 #MSVC_VARIANT=MSVC2005
101
102 # "Microsoft Visual C++ 2005 Express Edition"
103 # needs additional Platform SDK installation
104 # Visual C++ 8.0, _MSC_VER 1400, msvcr80.dll
105 #MSVC_VARIANT=MSVC2005EE
106
107 # "Microsoft .Net Framework 2.0 SDK"
108 # needs additional Platform SDK installation
109 # Visual C++ 8.0, _MSC_VER 1400, msvcr80.dll
110 #MSVC_VARIANT=DOTNET20
111
112 # "Microsoft Visual Studio 2008"
113 # Visual C++ 9.0, _MSC_VER 1500, msvcr90.dll
114 MSVC_VARIANT=MSVC2008
115
116 # "Microsoft Visual C++ 2008 Express Edition"
117 # Visual C++ 9.0, _MSC_VER 1500, msvcr90.dll
118 #MSVC_VARIANT=MSVC2008EE
119
120 # Warning, building with this setting does not work yet
121 # "Microsoft Visual Studio 2010"
122 # Visual C++ 10.0, _MSC_VER 1600, msvcr100.dll
123 #MSVC_VARIANT=MSVC2010
124
125 # Warning, building with this setting does not work yet
126 # "Microsoft Visual C++ 2010 Express Edition"
127 # Visual C++ 10.0, _MSC_VER 1600, msvcr100.dll
128 #MSVC_VARIANT=MSVC2010EE
129
130 #
131 # Optional: To compile some time critical code from assembler instead of C
132 #
133 # If you have the NASM compiler, set this to the NASM executable.
134 # http://nasm.sourceforge.net/
135 #
136 # If you don't have NASM, comment this line out, so that NASM
137 # isn't defined.
138 #
139 NASM=$(WIRESHARK_LIBS)\nasm-2.02\nasm.exe
140
141 #
142 # Optional: the Python library enables scripting support.
143 #
144 # If you don't have the Python library, comment this line out, so that
145 # PYTHON_EMBED isn't defined.
146 #
147 # NOTE: The Python library must have been compiled with the same
148 # compiler (MSVC_VARIANT) as Wireshark. Kown python.org Python
149 # CRT versions:
150 #
151 # Python version    CRT (32-bit)    CRT (64-bit)
152 # 2.4.4             7.1             ?
153 # 2.6.1             9.0             ?
154 # 2.6.2                             9.0
155 #
156 # If you versions of Python and Visual C++ use different CRTs
157 # comment this out.
158 #
159 # XXX The DLL path in epan/wspython/wspy_libws.py likely needs to
160 # be fixed before this is enabled by default.
161 #PYTHON_EMBED=1
162
163 #
164 # Optional: the Python interpreter is used as part of the buildsystem
165 #
166 # If you have the Python interpreter, set this to the directory in which
167 # the Python package is stored
168 #
169 # If you don't have the Python interpreter, comment this line out, so that
170 # PYTHON_DIR isn't defined.
171 #
172 # V2.4 to V2.6 should work
173 #
174 #PYTHON_VER=26
175 #PYTHON_DIR=C:\Python$(PYTHON_VER)
176
177
178 !if "$(WIRESHARK_TARGET_PLATFORM)" == "win32"
179 ##### Win32 Libraries #####
180 #
181 # Mandatory: GLib settings
182 #
183 # Please note: Since Wireshark release 1.0.0, we no longer support GLib1.x
184 #
185 GLIB_VERSION=2.0
186
187 ##### To use the old packet list comment out this line ####
188 NEW_PACKET_LIST_CONFIG=^#define NEW_PACKET_LIST 1
189
190 #
191 # Mandatory: GLib, GTK & related library settings
192 #
193 # Please note: Since Wireshark release 1.0.0, we no longer support GTK1.x
194 #
195 # If you want building with GTK+, set GTK_DIR to the pathname of the
196 # directory in which the "include" and "lib" directories reside.
197 #
198 GTK_DIR=$(WIRESHARK_LIBS)\gtk2
199 # These macros are used by the nsis installer script and by the install target.
200 PNG_DLL=libpng14-14.dll
201 FREETYPE_DLL=freetype6.dll
202 FONTCONFIG_DLL=libfontconfig-1.dll
203 EXPAT_DLL=libexpat-1.dll
204 INTL_DLL=intl.dll
205 # This macro is used by the setup target.
206 GTK_PKG=2.16.6-20100207
207
208 #
209 # Mandatory: Version numbers of GTK and pango.
210 #
211 # (MAJOR + MINOR Version number but without MICRO version number)
212 # These macros are used by the nsis installer script and by the setup target.
213 #
214 GTK_INST_VERSION=2.16
215
216 #
217 # Optional: WinPcap developer's pack to capture network traffic.
218 #
219 # If you have the WinPcap developer's pack (at least version 3.0),
220 # set this to the directory in which the WinPcap developer's pack resides.
221 #
222 # If you don't have the WPdpack, comment this line out, so that
223 # PCAP_DIR isn't defined.
224 #
225 PCAP_DIR=$(WIRESHARK_LIBS)\WPdpack
226 # This macro is used by the nsis installer script, by the u3/portable apps and by the setup target.
227 PCAP_VERSION=4_1_2
228
229 #
230 # Optional: WinPcap remote capture support and new API
231 # (pcap_open(), pcap_findalldevs_ex(), etc.)
232 #
233 PCAP_REMOTE=1
234
235 #
236 # Optional: The ZLib enables unzipping of gzip compressed capture files
237 # "on the fly".
238 #
239 # If you have Zlib, set this to directory in which the Zlib headers
240 # and .lib file are stored.
241 #
242 # If you don't have Zlib, comment this line out, so that ZLIB_DIR isn't
243 # defined.
244 #
245 ZLIB_DIR=$(WIRESHARK_LIBS)\zlib123
246
247 #
248 # Optional: the ADNS library enables asynchronous (nonblocking) DNS
249 # name resolvings.
250 #
251 # If you have GNU ADNS, set this to the directory in which the GNU ADNS
252 # .lib file is stored.
253 #
254 # If you don't have GNU ADNS, comment this line out, so that ADNS_DIR
255 # isn't defined.
256 #
257 # If C_ARES_DIR is defined below, it will override this setting.
258 #
259 #ADNS_DIR=$(WIRESHARK_LIBS)\adns-1.0-win32-05ws
260
261 #
262 # Optional: the c-ares library enables asynchronous (nonblocking) DNS
263 # name resolvings.
264 #
265 # If you have c-ares, set this to the directory in which the c-ares
266 # .lib file is stored. Setting this will override ADNS_DIR above. You
267 # can't have both.
268 #
269 # If you're using Visual C++ 6.0, you'll have to use a platform SDK that
270 # defines socklen_t, such as Windows Server 2003 PSDK.
271 #
272 # If you don't have c-ares, comment this line out, so that C_ARES_DIR
273 # isn't defined.
274 #
275 C_ARES_PKG=1.7.1
276
277 #
278 # Optional: the PCRE (Perl Compatible Regular Expressions) library
279 # enables regular expressions for display filters.
280 #
281 # If you have the PCRE library, set this to the directory in which
282 # the GNUWIN32 pcre-lib package is stored.
283 #
284 # If you don't have PCRE, comment this line out, so that PCRE_DIR
285 # isn't defined.
286 #
287 #PCRE_DIR=$(WIRESHARK_LIBS)\pcre-7.0
288
289 #
290 # Optional: the GNUTLS library enables ssl decryption.
291 #
292 # If you have the GNUTLS library, set this to the package version.
293 #
294 # If you don't have GNUTLS, comment this line out, so that GNUTLS_PKG
295 # isn't defined.
296 #
297 # Platform SDK conflicts with openssl.h header
298 GNUTLS_PKG=2.8.5-4.12
299
300 #
301 # Optional: the KFW library enables kerberos/sasl/dcerpc decryption.
302 #
303 # If you have the kerberos for windows (mit) library, set this to the
304 # directory where the kfw package is stored.
305 #
306 # If you don't have KFW, comment this line out, so that KFW_DIR
307 # isn't defined.
308 #
309 KFW_DIR=$(WIRESHARK_LIBS)\kfw-3-2-2-i386-ws-vc6
310
311 #
312 # Optional: the Nettle library enables ??? decryption.
313 #
314 # If you have the Nettle encryption library, set this to the
315 # directory in which the nettle package is stored.
316 #
317 # If you don't have Nettle, comment this line out, so that NETTLE_DIR
318 # isn't defined.
319 #
320 # NETTLE_DIR=$(WIRESHARK_LIBS)\nettle-1.10
321
322 #
323 # Optional: the LUA library enables scripting support.
324 #
325 # If you have the LUA library, set this to the directory in which
326 # the LUA package is stored.
327 #
328 # If you don't have LUA, comment this line out, so that LUA_DIR
329 # isn't defined.
330 #
331 LUA_DIST=5_1_4_Win32_dll6
332 LUA_DIR=$(WIRESHARK_LIBS)\lua5.1.4
333
334 #
335 # Optional: the PORTAUDIO library enables audio output for RTP streams.
336 #
337 # If you have the PORTAUDIO library (used for rtp_player), set this to
338 # the directory in which the PORTAUDIO library is stored.
339 #
340 # If you don't have PORTAUDIO, comment this line out, so that
341 # PORTAUDIO_DIR isn't defined.
342 #
343 #PORTAUDIO_DIR=$(WIRESHARK_LIBS)\portaudio_v18_1
344 PORTAUDIO_DIR=$(WIRESHARK_LIBS)\portaudio_v19_2
345
346 #
347 # Version number of PortAudio
348 #
349 #PORTAUDIO_VERSION=18
350 PORTAUDIO_VERSION=19
351
352 #
353 # Optional: AirPcap developer's pack to capture wireless network traffic
354 # incl. 802.11 management frames.
355 #
356 # If you have the AirPcap developer's pack, set this to the directory
357 # in which the AirPcap developer's pack resides.
358 #
359 # If you don't have the AirPcap developer's pack, comment this line out,
360 # so that AIRPCAP_DIR isn't defined.
361 #
362 AIRPCAP_DIR=$(WIRESHARK_LIBS)\AirPcap_Devpack_4_1_0_1622\AirPcap_Devpack
363
364 #
365 # Optional: LIBSMI, System Management Interface
366 #
367 # Used for oid-name resolution for SNMP and other protocols
368 #
369 SMI_DIR=$(WIRESHARK_LIBS)\libsmi-0.4.8
370
371 #
372 # Optional: GeoIP, IP address database lookups
373 #
374 # Used to map IP addresses to MaxMind GeoIP database entries
375 #
376 # GeoIP requires IPv6 definitions that don't ship with Visual C++ 6.0.
377 # However, the Microsoft Platform SDK for Windows Server 2003 R2 provides
378 # these definitions. The SDK's SetEnv.bat script defines INETSDK.
379 !IF "$(MSVC_VARIANT)" != "MSVC6" || DEFINED(INETSDK)
380 GEOIP_DIR=$(WIRESHARK_LIBS)\GeoIP-1.4.6-win32ws\libGeoIP
381 !ENDIF
382
383 !else
384 ##### Win64 Libraries #####
385 #
386 # Mandatory: GLib settings
387 #
388 # Please note: Since Wireshark release 1.0.0, we no longer support GLib1.x
389 #
390 GLIB_VERSION=2.0
391
392 ##### To use the old packet list comment out this line ####
393 NEW_PACKET_LIST_CONFIG=^#define NEW_PACKET_LIST 1
394
395 #
396 # Mandatory: GLib, GTK & related library settings
397 #
398 # Please note: Since Wireshark release 1.0.0, we no longer support GTK1.x
399 #
400 # If you want building with GTK+, set GTK_DIR to the pathname of the
401 # directory in which the "include" and "lib" directories reside.
402 #
403 GTK_DIR=$(WIRESHARK_LIBS)\gtk2
404 # These macros are used by the nsis installer script and by the install target.
405 PNG_DLL=libpng14-14.dll
406 #TIFF_DLL=libtiff-3.dll
407 #JPEG_DLL=libjpeg-7.dll
408 FREETYPE_DLL=libfreetype-6.dll
409 FONTCONFIG_DLL=libfontconfig-1.dll
410 EXPAT_DLL=libexpat-1.dll
411 INTL_DLL=libintl-8.dll
412
413 # These macros are used by the setup target.
414 GTK_PKG=2.16.6-20100208
415
416 #
417 # Mandatory: Version numbers of GTK and pango.
418 #
419 # (MAJOR + MINOR Version number but without MICRO version number)
420 # These macros are used by the nsis installer script and by the setup target.
421 #
422 GTK_INST_VERSION=2.16
423
424 #
425 # Optional: WinPcap developer's pack to capture network traffic.
426 #
427 # If you have the WinPcap developer's pack (at least version 3.0),
428 # set this to the directory in which the WinPcap developer's pack resides.
429 #
430 # If you don't have the WPdpack, comment this line out, so that
431 # PCAP_DIR isn't defined.
432 #
433 PCAP_DIR=$(WIRESHARK_LIBS)\WPdpack
434 # This macro is used by the nsis installer script, by the u3/portable apps and by the setup target.
435 PCAP_VERSION=4_1_2
436
437 #
438 # Optional: WinPcap remote capture support and new API
439 # (pcap_open(), pcap_findalldevs_ex(), etc.)
440 #
441 PCAP_REMOTE=1
442
443 #
444 # Optional: The ZLib enables unzipping of gzip compressed capture files
445 # "on the fly".
446 #
447 # If you have Zlib, set this to directory in which the Zlib headers
448 # and .lib file are stored.
449 #
450 # If you don't have Zlib, comment this line out, so that ZLIB_DIR isn't
451 # defined.
452 #
453 ZLIB_DIR=$(WIRESHARK_LIBS)\zlib123
454
455 #
456 # Optional: the ADNS library enables asynchronous (nonblocking) DNS
457 # name resolvings.
458 #
459 # If you have GNU ADNS, set this to the directory in which the GNU ADNS
460 # .lib file is stored.
461 #
462 # If you don't have GNU ADNS, comment this line out, so that ADNS_DIR
463 # isn't defined.
464 #
465 # If C_ARES_DIR is defined below, it will override this setting.
466 #
467 #ADNS_DIR=$(WIRESHARK_LIBS)\adns-1.0-win32-05ws
468
469 #
470 # Optional: the c-ares library enables asynchronous (nonblocking) DNS
471 # name resolvings.
472 #
473 # If you have c-ares, set this to the directory in which the c-ares
474 # .lib file is stored. Setting this will override ADNS_DIR above. You
475 # can't have both.
476 #
477 # If you're using Visual C++ 6.0, you'll have to use a platform SDK that
478 # defines socklen_t, such as Windows Server 2003 PSDK.
479 #
480 # If you don't have c-ares, comment this line out, so that C_ARES_DIR
481 # isn't defined.
482 #
483 C_ARES_PKG=1.7.1
484
485 #
486 # Optional: the PCRE (Perl Compatible Regular Expressions) library
487 # enables regular expressions for display filters.
488 #
489 # If you have the PCRE library, set this to the directory in which
490 # the GNUWIN32 pcre-lib package is stored.
491 #
492 # If you don't have PCRE, comment this line out, so that PCRE_DIR
493 # isn't defined.
494 #
495 #PCRE_DIR=$(WIRESHARK_LIBS)\pcre-7.0
496
497 #
498 # Optional: the GNUTLS library enables ssl decryption.
499 #
500 # If you have the GNUTLS library, set this to the package version.
501 #
502 # If you don't have GNUTLS, comment this line out, so that GNUTLS_PKG
503 # isn't defined.
504 #
505 # Platform SDK conflicts with openssl.h header
506 GNUTLS_PKG=2.8.5-3.16
507
508 #
509 # Optional: the KFW library enables kerberos/sasl/dcerpc decryption.
510 #
511 # If you have the kerberos for windows (mit) library, set this to the
512 # directory where the kfw package is stored.
513 #
514 # If you don't have KFW, comment this line out, so that KFW_DIR
515 # isn't defined.
516 #
517 #KFW_DIR=$(WIRESHARK_LIBS)\kfw-3.2.2-ws1
518
519 #
520 # Optional: the Nettle library enables ??? decryption.
521 #
522 # If you have the Nettle encryption library, set this to the
523 # directory in which the nettle package is stored.
524 #
525 # If you don't have Nettle, comment this line out, so that NETTLE_DIR
526 # isn't defined.
527 #
528 # NETTLE_DIR=$(WIRESHARK_LIBS)\nettle-1.10
529
530 #
531 # Optional: the LUA library enables scripting support.
532 #
533 # If you have the LUA library, set this to the directory in which
534 # the LUA package is stored.
535 #
536 # If you don't have LUA, comment this line out, so that LUA_DIR
537 # isn't defined.
538 #
539 LUA_DIST=5_1_4_Win64_dll9
540 LUA_DIR=$(WIRESHARK_LIBS)\lua5.1.4
541
542 #
543 # Optional: the PORTAUDIO library enables audio output for RTP streams.
544 #
545 # If you have the PORTAUDIO library (used for rtp_player), set this to
546 # the directory in which the PORTAUDIO library is stored.
547 #
548 # If you don't have PORTAUDIO, comment this line out, so that
549 # PORTAUDIO_DIR isn't defined.
550 #
551 #PORTAUDIO_DIR=$(WIRESHARK_LIBS)\portaudio_v18_1
552 PORTAUDIO_DIR=$(WIRESHARK_LIBS)\portaudio_v19_2
553
554 #
555 # Version number of PortAudio
556 #
557 #PORTAUDIO_VERSION=18
558 PORTAUDIO_VERSION=19
559
560 #
561 # Optional: AirPcap developer's pack to capture wireless network traffic
562 # incl. 802.11 management frames.
563 #
564 # If you have the AirPcap developer's pack, set this to the directory
565 # in which the AirPcap developer's pack resides.
566 #
567 # If you don't have the AirPcap developer's pack, comment this line out,
568 # so that AIRPCAP_DIR isn't defined.
569 #
570 AIRPCAP_DIR=$(WIRESHARK_LIBS)\AirPcap_Devpack_4_1_0_1622\AirPcap_Devpack
571
572 #
573 # Optional: LIBSMI, System Management Interface
574 #
575 # Used for oid-name resolution for SNMP and other protocols
576 #
577 #SMI_DIR=$(WIRESHARK_LIBS)\libsmi-0.4.8
578
579 #
580 # Optional: GeoIP, IP address database lookups
581 #
582 # Used to map IP addresses to MaxMind GeoIP database entries
583 #
584 GEOIP_DIR=$(WIRESHARK_LIBS)\GeoIP-1.4.6-win64ws\libGeoIP
585
586 !endif
587
588 ##### Tools #####
589
590 # Set the following mandatory commands to find the tools.
591 # The easiest way is to use the corresponding packages from cygwin.
592
593 # Set up the path to the cygwin binaries
594 CYGWIN_PATH=c:\cygwin\bin
595
596 # command for a shell (cygwin's bash package recommended)
597 SH_PROG=bash
598
599 # bash versions after 3.1.6 need the 'igncr' shell option to be able to
600 #  process scripts in windows 'native format' (dos crlf format).
601 # The following !IF results in the option being used only if it is available
602 #  since using it on bash version 3.1.6 (or earlier) is not required and
603 #  will cause an error message.
604 !if "$(SH_PROG)"=="bash" && [$(CYGWIN_PATH)\bash -c "set -o igncr" 2>nul: ] == 0
605 SH_FLAGS=-o igncr
606 !endif
607
608 SH=$(SH_PROG) $(SH_FLAGS)
609
610
611 # command for perl (cygwin's perl package recommended)
612 PERL=perl
613
614 # command for pod2man and pod2html
615 # (part of the perl package, usually leave these unchanged)
616 POD2MAN=$(SH) pod2man
617 POD2HTML=$(SH) pod2html
618
619 #
620 # If you don't have the native Python package installed, you can use
621 # the Cygwin version (not recommended)
622 #
623 #PYTHON=env python
624
625 # command for lex/flexx (cygwin's flex recommended)
626 LEX=flex
627
628 # command for yacc/bison (cygwin's bison recommended)
629 YACC=bison
630
631 # Commands to convert UNIX line endings to DOS/Windows
632 UNIX2DOS=u2d
633 TEXTIFY=$(SH) $(TOOLS_DIR)/textify.sh
634
635 #
636 # Optional: To build the NSIS installer.
637 #
638 # If you have the NSIS package, set this to the NSIS executable.
639 #
640 # If you don't have NSIS, comment this line out, so that MAKENSIS
641 # isn't defined.
642 #
643 MAKENSIS="$(PROGRAM_FILES)\nsis\makensis.exe"
644
645 #
646 # Optional: To build the developers API documentation with doxygen and dot.
647 # Currently experimental, outdated and incomplete.
648 #
649 # You will have to download and install:
650 # Doxygen from: http://www.doxygen.org
651 # Graphviz from: http://www.research.att.com/sw/tools/graphviz/
652 #
653 # If you have doxygen, set this to the doxygen executable.
654 #
655 # If you don't want the developers documentation (or don't have the tools),
656 # comment this line out, so that DOXYGEN isn't defined.
657 #
658 #DOXYGEN="$(PROGRAM_FILES)/doxygen/bin/doxygen.exe"
659
660 #
661 # Recommended: Use the compressed html help format .chm as the Wireshark integrated help.
662 #
663 # The required htmlhelp.h and htmlhelp.lib should be included in MSVC_VARIANT > MSVC6.
664 #
665 # For MSVC_VARIANT == MSVC6 you will have to download and install the html help workshop from:
666 #
667 # http://msdn.microsoft.com/library/default.asp?url=/library/en-us/htmlhelp/html
668 # /hwMicrosoftHTMLHelpDownloads.asp
669 #
670 # Then point HHC_DIR to the html help dir (where hhc.exe resides).
671 #
672 # If you don't want the online help (or don't have the tools),
673 # comment this line out, so that HHC_DIR isn't defined.
674 #
675 HHC_DIR=$(PROGRAM_FILES)/HTML Help Workshop
676
677 #
678 # Optional: To reduce the size of dlls and exes, which is especially useful for USB device distributions (U3, PortableApps)
679 #
680 # If you have the UPX package, set this to the upx.exe executable.
681 #
682 # UPX can be downloaded from:
683 #   http://upx.sourceforge.net/
684 #
685 # If you don't have UPX, or don't want to pack exes and dlls,
686 # comment this line out, so that UPX isn't defined.
687 #
688
689 UPX=$(WIRESHARK_LIBS)\upx303w\upx.exe
690
691 ##### Flags, PATHs and Miscellaneous #####
692
693 # Santity check: native vs Cygwin Python options
694 !IF DEFINED(PYTHON) && DEFINED(PYTHON_DIR)
695 !ERROR PYTHON and PYTHON_DIR cannot be specified at the same time
696 !ENDIF
697
698 # Find native Python automatically if PYTHON(_DIR) wasn't defined
699 !IF !DEFINED(PYTHON) && !DEFINED(PYTHON_DIR)
700 !IF EXIST(c:\Python26\python.exe)
701 PYTHON_VER=26
702 !ELSE IF EXIST(c:\Python25\python.exe)
703 PYTHON_VER=25
704 !ELSE IF EXIST(c:\Python24\python.exe)
705 PYTHON_VER=24
706 !ENDIF
707
708 !IF DEFINED(PYTHON_VER)
709 PYTHON_DIR=C:\Python$(PYTHON_VER)
710 !ENDIF
711 !ENDIF
712
713 !IF DEFINED(PYTHON_DIR)
714 PYTHON="$(PYTHON_DIR)\python.exe"
715 PATH=$(PYTHON_DIR);$(PATH)
716 !ENDIF
717
718 # Santity check: Python embedding requires a valid PYTHON_DIR
719 !IF DEFINED(PYTHON_EMBED) && !DEFINED(PYTHON_DIR)
720 !ERROR PYTHON_EMBED requires that PYTHON_DIR is defined
721 !ENDIF
722
723 # "convert" the MSVC variant into the required MSC compiler version
724 !IF "$(MSVC_VARIANT)" == "MSVC6"
725 MSC_VER_REQUIRED=1200
726 !ELSEIF "$(MSVC_VARIANT)" == "MSVC2002" || "$(MSVC_VARIANT)" == "DOTNET10"
727 MSC_VER_REQUIRED=1300
728 !ELSEIF "$(MSVC_VARIANT)" == "MSVC2003" || "$(MSVC_VARIANT)" == "DOTNET11"
729 MSC_VER_REQUIRED=1310
730 !ELSEIF "$(MSVC_VARIANT)" == "MSVC2005" || "$(MSVC_VARIANT)" == "MSVC2005EE" || "$(MSVC_VARIANT)" == "DOTNET20"
731 MSC_VER_REQUIRED=1400
732 !ELSEIF "$(MSVC_VARIANT)" == "MSVC2008" ||  "$(MSVC_VARIANT)" == "MSVC2008EE"
733 MSC_VER_REQUIRED=1500
734 !ELSEIF "$(MSVC_VARIANT)" == "MSVC2010" ||  "$(MSVC_VARIANT)" == "MSVC2010EE"
735 MSC_VER_REQUIRED=1600
736 !ELSE
737 !ERROR MSVC_VARIANT unknown
738 !ENDIF
739
740 ## Manifest processing is not needed for VC10 (Visual Studio 2010 C)
741 ## See: http://msdn.microsoft.com/en-us/library/dd293574.aspx
742 !IF ($(MSC_VER_REQUIRED) >= 1400) && ($(MSC_VER_REQUIRED) < 1600)
743 MANIFEST_INFO_REQUIRED=1
744 !ENDIF
745
746 # Compiler flags:
747 # /W3  warning level 3 (0 less - 4 most, 1 default)
748 # /Zi  create .pdb file for debugging
749 # /MD  use "Multithreading Debug" libraries
750 # /D_CRT_SECURE_NO_DEPRECATE        Don't warn for "insecure" calls, see MSDN "Security Enhancements in the CRT"
751 # /D_CRT_NONSTDC_NO_DEPRECATE       Don't warn for "Deprecated CRT Functions" as MSDN calls this
752 # /D_BIND_TO_CURRENT_CRT_VERSION=1  Make sure our CRT and manifest versions match (http://msdn.microsoft.com/en-us/library/cc664727.aspx)
753 # /DWIN32_LEAN_AND_MEAN             Don't include unnecessary Windows include files (see windows.h)
754 # /MANIFEST:no                      Don't create a SxS manifest. Makes sure our plugins don't load a second copy of the CRT.
755 #
756 !IF "$(MSVC_VARIANT)" == "MSVC6" || "$(MSVC_VARIANT)" == "MSVC2002" || "$(MSVC_VARIANT)" == "DOTNET10" || "$(MSVC_VARIANT)" == "MSVC2003" || "$(MSVC_VARIANT)" == "DOTNET11"
757 LOCAL_CFLAGS=/Zi /W3 /MD /DWIN32_LEAN_AND_MEAN /DMSC_VER_REQUIRED=$(MSC_VER_REQUIRED)
758 !ELSEIF "$(MSVC_VARIANT)" == "MSVC2005" || "$(MSVC_VARIANT)" == "MSVC2005EE" || "$(MSVC_VARIANT)" == "DOTNET20" || "$(MSVC_VARIANT)" == "MSVC2008" || "$(MSVC_VARIANT)" == "MSVC2008EE" || "$(MSVC_VARIANT)" == "MSVC2010" || "$(MSVC_VARIANT)" == "MSVC2010EE"
759 LOCAL_CFLAGS=/Zi /W3 /MD /D_CRT_SECURE_NO_DEPRECATE /D_CRT_NONSTDC_NO_DEPRECATE /DWIN32_LEAN_AND_MEAN /DMSC_VER_REQUIRED=$(MSC_VER_REQUIRED)
760 !IF "$(WIRESHARK_TARGET_PLATFORM)" != "win64"
761 LOCAL_CFLAGS=$(LOCAL_CFLAGS) /D_BIND_TO_CURRENT_CRT_VERSION=1
762 !ENDIF
763 !ELSE
764 !ERROR MSVC_VARIANT unknown
765 !ENDIF
766
767 # http://msdn.microsoft.com/en-us/library/bb385193.aspx
768 # /MP               Compiles multiple source files by using multiple processes
769 # /MP[processMax]   If you omit the processMax argument, the compiler retrieves the number of effective processors
770 #                   on your computer from the operating system, and creates a process for each processor.
771 #
772 # The following compiler options and language features that are incompatible with the /MP option:
773 #
774 # * #import preprocessor directive
775 # * /E, /EP
776 # * /Gm
777 # * /showIncludes
778 # * /Yc
779 #
780 !IF "$(MSVC_VARIANT)" == "MSVC2008" || "$(MSVC_VARIANT)" == "MSVC2008EE" || "$(MSVC_VARIANT)" == "MSVC2010" || "$(MSVC_VARIANT)" == "MSVC2010EE"
781 LOCAL_CFLAGS= $(LOCAL_CFLAGS) /MP
782 !ENDIF
783 # Linker flags:
784 # /DEBUG  generate debug info
785 # /PROFILE generate map file(s) for profiling
786 # /DEFAULTLIB:xxx use xxx as the standard C library
787 # /NODEFAULTLIB:xxx don't use xxx as the standard C library
788 #
789 LOCAL_LDFLAGS=/DEBUG /MACHINE:$(TARGET_MACHINE)
790 DLL_LDFLAGS =
791 !IFDEF MANIFEST_INFO_REQUIRED
792 DLL_LDFLAGS = /MANIFEST:no
793 !ENDIF
794
795 PLUGIN_LDFLAGS = /NOLOGO /INCREMENTAL:no $(LOCAL_LDFLAGS) $(DLL_LDFLAGS)
796
797 #
798 # According to http://bugs.wireshark.org/bugzilla/show_bug.cgi?id=403
799 # XCOPY under Windows NT doesn't support the "/Y" flag.  This works
800 # around that bug.
801 # XXX - This apparently doesn't work for some versions of nmake:
802 # http://support.microsoft.com/default.aspx?scid=kb;en-us;86814
803 # It looks like we'll have to call "set copycmd=/y" before we run xcopy.
804 COPYCMD=/y
805
806 #
807 # If you don't want to build libwireshark.dll, you should comment out the
808 # following line. (Note: for plugin support this option must stay activated)
809 ENABLE_LIBWIRESHARK=USE
810
811 #
812 # install (debug) directory for Wireshark (relative to your source dir)
813 INSTALL_DIR=wireshark-gtk2
814
815
816
817 ##### C-Runtime Redistributable #####
818 #
819 # The C-Runtime since Version 7 must be shipped together with
820 # the program installer, to avoid missing msvcr*.dll files on
821 # the target machine.
822 #
823 # The location of these files differ on the various compiler
824 # packages, the following will use the default paths depending
825 # on the package version.
826 #
827 !IF "$(MSVC_VARIANT)" == "MSVC6"
828 # msvcrt.dll will already be available on target machines - nothing additional to install
829
830 !ELSEIF "$(WIRESHARK_TARGET_PLATFORM)" == "win64"
831 # We're not creating portable packages and therefore don't have to worry about
832 # "deploying using xcopy"
833 VCREDIST_EXE=$(WIRESHARK_LIBS)\vcredist_$(TARGET_MACHINE).exe
834
835 !ELSEIF "$(MSVC_VARIANT)" == "MSVC2002"
836 # you probably need to tweak this directory if you don't use the professional edition!
837 MSVCR_DLL=$(PROGRAM_FILES)\Microsoft Visual Studio .NET\Visual Studio .NET Professional - English\msvcr70.dll
838
839 !ELSEIF "$(MSVC_VARIANT)" == "DOTNET10"
840 # no redistributable available for this package!
841
842 !ELSEIF "$(MSVC_VARIANT)" == "MSVC2003"
843 # you probably need to tweak this directory if you don't use the professional edition!
844 MSVCR_DLL=$(PROGRAM_FILES)\Microsoft Visual Studio .NET 2003\Visual Studio .NET Professional 2003 - English\msvcr71.dll
845
846 !ELSEIF "$(MSVC_VARIANT)" == "DOTNET11"
847 # no redistributable available for this package!
848
849 !ELSEIF "$(MSVC_VARIANT)" == "MSVC2005"
850 MSVCR_DLL=$(PROGRAM_FILES)\Microsoft Visual Studio 8\VC\redist\$(VCREDIST_DLL)\Microsoft.VC80.CRT\*.*
851
852 !ELSEIF "$(MSVC_VARIANT)" == "MSVC2005EE" || "$(MSVC_VARIANT)" == "DOTNET20" || "$(MSVC_VARIANT)" == "MSVC2008EE"
853 # you need to download the redistributable package vcredist_x86.exe from Microsoft first,
854 # and copy it to the lib folder!!!
855 VCREDIST_EXE=$(WIRESHARK_LIBS)\vcredist_$(TARGET_MACHINE).exe
856
857 !ELSEIF "$(MSVC_VARIANT)" == "MSVC2008"
858 MSVCR_DLL=$(PROGRAM_FILES)\Microsoft Visual Studio 9.0\VC\redist\$(VCREDIST_DLL)\Microsoft.VC90.CRT\*.*
859
860 !ELSEIF "$(MSVC_VARIANT)" == "MSVC2010EE"
861 # NOT TESTED
862 # you need to download the redistributable package vcredist_x86.exe from Microsoft first,
863 # and copy it to the lib folder!!!
864 VCREDIST_EXE=$(WIRESHARK_LIBS)\vcredist_$(TARGET_MACHINE).exe
865 !ELSEIF "$(MSVC_VARIANT)" == "MSVC2010"
866 MSVCR_DLL=$(PROGRAM_FILES)\Microsoft Visual Studio 10.0\VC\redist\$(TARGET_MACHINE)\Microsoft.VC100.CRT*.*
867
868 !ELSE
869 !ERROR MSVC_VARIANT unknown
870 !ENDIF
871
872 !IF DEFINED(VCREDIST_EXE) && ! EXIST("$(VCREDIST_EXE)")
873 !ERROR Can't find $(VCREDIST_EXE). Have you downloaded it from Microsoft? \
874 See the developer's guide section "C-Runtime "Redistributable" files" for details how to get it
875 !ENDIF
876
877 ##### Advanced: Docbook/XML documentation generation #####
878 # If you want to generate the Docbook/XML based docs (User's and Developer's
879 # Guide, ...), you'll need some additional tools / libraries compared to the
880 # rest of the build process.
881 #
882 # FOR DETAILED INSTRUCTIONS TO GENERATE THE DOCS, SEE: docbook\README.txt.
883 #
884 # If you don't call the Makefile.nmake in the docbook dir to generate the
885 # docs, the following settings in this section will have no effect.
886
887 # formatting objects processor executable
888 # Comment this out if you don't have fop installed or you don't want the docs
889 # in PDF format.
890 #
891 # You may want to install the FOP hyphenation patterns from
892 # http://offo.sourceforge.net/hyphenation/
893 !IFNDEF FOP
894 FOP=fop-0.95\fop.bat
895 !ENDIF
896
897 # Additional options to fop.
898 FOP_OPTS=-Xmx256m
899
900 # html help compiler
901 # Comment this out if you don't have hhc.exe or you don't want the docs in
902 # .chm format.
903 #
904 # Beware: hhc.exe is NOT part of the MSVC packages in HHC_DIR mentioned above,
905 # so you'll need to install the HTML Help Workshop for this.
906 HHC_EXE="$(HHC_DIR)\hhc.exe"
907
908 # html to text converter for text version of release notes, e.g. elinks.
909 # This could also be "lynx", or "true" if neither elinks nor lynx is installed
910 # (cygwin: lynx works, elinks not available, links and true doesn't produce output)
911 #HTML2TXT=elinks -dump -dump-width 72
912 ##HTML2TXT=links -dump -width 72 ## XXX: Fails: For links -dump requires 'url' (filename) arg.
913 #HTML2TXT=lynx -dump -width=72 -nolist -stdin
914
915 !IFNDEF HTML2TXT
916 HTML2TXT=$(PYTHON) $(TOOLS_DIR)\html2text.py --width=72 --no-links
917 !ENDIF
918
919 # the XSL processor (part of cygwin's libxslt package)
920 XSLTPROC="xsltproc"
921
922 # the XML validator (part of cygwin's libxml2 package)
923 XMLLINT="xmllint"
924
925
926
927 ##############################################################################
928 #
929 # You should not have to change anything below this comment.
930 # If you do, it's a deficiency in the Makefile.nmake files;
931 # either tell wireshark-dev@wireshark.org about it, including
932 # details of why you had to change it, or fix config.nmake
933 # and any Makefile.nmake files that need to be changed, and
934 # send us the patches, along with details of why the change
935 # was necessary.
936 #
937 ##############################################################################
938
939 #
940 # The RC_VERSION should be comma-separated, not dot-separated,
941 # as per Graham Bloice's message in
942 #
943 #       http://www.ethereal.com/lists/ethereal-dev/200303/msg00283.html
944 #
945 # "The RC_VERSION variable in config.nmake should be comma separated.
946 # This allows the resources to be built correctly and the version
947 # number to be correctly displayed in the explorer properties dialog
948 # for the executables, and XP's tooltip, rather than 0.0.0.0."
949 #
950
951 VERSION=$(VERSION_MAJOR).$(VERSION_MINOR).$(VERSION_MICRO)$(VERSION_EXTRA)
952 RC_VERSION=$(VERSION_MAJOR),$(VERSION_MINOR),$(VERSION_MICRO),$(VERSION_BUILD)
953
954 WTAP_VERSION=$(WTAP_VERSION_MAJOR).$(WTAP_VERSION_MINOR).$(WTAP_VERSION_MICRO)
955 RC_WTAP_VERSION=$(WTAP_VERSION_MAJOR),$(WTAP_VERSION_MINOR),$(WTAP_VERSION_MICRO)
956
957 # GLib
958 GLIB_CFLAGS=/I$(GTK_DIR)\include\glib-$(GLIB_VERSION) \
959         /I$(GTK_DIR)\lib\glib-$(GLIB_VERSION)\include
960 GLIB_LIBS=$(GTK_DIR)\lib\glib-$(GLIB_VERSION).lib \
961         $(GTK_DIR)\lib\gmodule-$(GLIB_VERSION).lib \
962         $(GTK_DIR)\lib\gobject-$(GLIB_VERSION).lib
963 GTHREAD_LIBS=$(GTK_DIR)\lib\gthread-$(GLIB_VERSION).lib
964
965 # GTK+
966 GTK_CFLAGS=$(GLIB_CFLAGS) /I$(GTK_DIR)\include\gtk-2.0 \
967         /I$(GTK_DIR)\lib\gtk-2.0\include \
968         /I$(GTK_DIR)\include\atk-1.0 \
969         /I$(GTK_DIR)\include\cairo \
970         /I$(GTK_DIR)\include\pango-1.0
971 GTK_LIBS=$(GTK_DIR)\lib\gtk-win32-2.0.lib \
972         $(GTK_DIR)\lib\gdk-win32-2.0.lib \
973         $(GTK_DIR)\lib\gdk_pixbuf-2.0.lib \
974         $(GTK_DIR)\lib\pango-1.0.lib \
975         $(GLIB_LIBS)
976
977
978 !IF "$(GTK_INST_VERSION)" == "2.18" || "$(GTK_INST_VERSION)" == "2.16" || "$(GTK_INST_VERSION)" == "2.14"
979 GTK_LIB_DIR=2.10.0
980
981 !IFDEF PNG_DLL
982 NEED_LIBPNG_DLL=USE
983 !ENDIF
984 !IFDEF JPEG_DLL
985 NEED_LIBJPEG_DLL=USE
986 !ENDIF
987 !IFDEF TIFF_DLL
988 NEED_LIBTIFF_DLL=USE
989 !ENDIF
990 NEED_CAIRO_DLL=USE
991 # Pango >=1.24.5 Needs these:
992 NEED_FREETYPE_DLL=USE
993 NEED_FONTCONFIG_DLL=USE
994 NEED_EXPAT_DLL=USE
995
996 GTK_WIMP_DLLSRC_DIR=$(GTK_DIR)\lib\gtk-2.0\2.10.0\engines
997 GTK_WIMP_DLLDST_DIR=lib\gtk-2.0\2.10.0\engines
998 GTK_WIMP_RCSRC_DIR=$(GTK_DIR)\share\themes\MS-Windows\gtk-2.0
999 GTK_WIMP_RCDST_DIR=etc\gtk-2.0
1000 !ELSE
1001 !ERROR ? Unknown or invalid GTK_INST_VERSION
1002 !ENDIF
1003
1004
1005 !IFDEF AIRPCAP_DIR
1006 AIRPCAP_CONFIG=^#define HAVE_AIRPCAP 1
1007 AIRPDCAP_CONFIG=^#define HAVE_AIRPDCAP 1
1008 #AIRPCAP_CFLAGS=/I$(AIRPCAP_DIR)\include
1009 !ELSE
1010 AIRPCAP_CONFIG=
1011 AIRPDCAP_CONFIG=
1012 !ENDIF
1013
1014 !IFDEF PCAP_DIR
1015 # Nmake uses carets to escape special characters
1016 WINPCAP_CONFIG=^#define HAVE_LIBPCAP 1
1017 #
1018 # This requires that, if you're *building* Wireshark, you have
1019 # the most recent WinPcap's development package.  If, at *run*
1020 # time, an older version of WinPcap, missing some routines,
1021 # is found, we work around that.
1022 #
1023 PCAP_FINDALLDEVS_CONFIG=^#define HAVE_PCAP_FINDALLDEVS 1
1024 PCAP_DATALINK_NAME_TO_VAL_CONFIG=^#define HAVE_PCAP_DATALINK_NAME_TO_VAL 1
1025 PCAP_DATALINK_VAL_TO_NAME_CONFIG=^#define HAVE_PCAP_DATALINK_VAL_TO_NAME 1
1026 PCAP_DATALINK_VAL_TO_DESCRIPTION_CONFIG=^#define HAVE_PCAP_DATALINK_VAL_TO_DESCRIPTION 1
1027 # PCAP_BREAKLOOP won't have any benefit on Win32, but breaks compatibility with 3.0
1028 PCAP_BREAKLOOP_CONFIG=
1029 PCAP_LIST_DATALINKS_CONFIG=^#define HAVE_PCAP_LIST_DATALINKS 1
1030 PCAP_FREE_DATALINKS_CONFIG=^#define HAVE_PCAP_FREE_DATALINKS 1
1031 PCAP_SET_DATALINK_CONFIG=^#define HAVE_PCAP_SET_DATALINK 1
1032 !ELSE
1033 # no WpdPack installed
1034 WINPCAP_CONFIG=
1035 PCAP_FINDALLDEVS_CONFIG=
1036 PCAP_DATALINK_NAME_TO_VAL_CONFIG=
1037 PCAP_DATALINK_VAL_TO_NAME_CONFIG=
1038 PCAP_DATALINK_VAL_TO_DESCRIPTION_CONFIG=
1039 PCAP_BREAKLOOP_CONFIG=
1040 PCAP_LIST_DATALINKS_CONFIG=
1041 PCAP_FREE_DATALINKS_CONFIG=
1042 PCAP_SET_DATALINK_CONFIG=
1043 !ENDIF
1044
1045 !IF DEFINED(PCAP_DIR) && DEFINED(PCAP_REMOTE)
1046 PCAP_HAVE_REMOTE_CONFIG=^#define HAVE_REMOTE 1
1047 PCAP_REMOTE_CONFIG=^#define HAVE_PCAP_REMOTE 1
1048 PCAP_OPEN_CONFIG=^#define HAVE_PCAP_OPEN 1
1049 PCAP_SETSAMPLING_CONFIG=^#define HAVE_PCAP_SETSAMPLING 1
1050 !ELSE
1051 PCAP_HAVE_REMOTE_CONFIG=
1052 PCAP_REMOTE_CONFIG=
1053 PCAP_OPEN_CONFIG=
1054 PCAP_SETSAMPLING_CONFIG=
1055 !ENDIF
1056
1057 !IFDEF ZLIB_DIR
1058 ZLIB_PATH=$(ZLIB_DIR)
1059 ZLIB_CFLAGS=/I$(ZLIB_DIR)\include
1060 ZLIB_LIBS=$(ZLIB_DIR)\lib\zdll.lib
1061 ZLIB_DLL=$(ZLIB_DIR)\zlib1.dll
1062 # Nmake uses carets to escape special characters
1063 ZLIB_CONFIG=^#define HAVE_LIBZ 1
1064 !else
1065 ZLIB_CFLAGS=
1066 ZLIB_LIBS=
1067 ZLIB_DLL=
1068 ZLIB_CONFIG=
1069 !ENDIF
1070
1071 !IFDEF C_ARES_PKG
1072 !UNDEF ADNS_DIR
1073 C_ARES_DIR=$(WIRESHARK_LIBS)\c-ares-$(C_ARES_PKG)-$(WIRESHARK_TARGET_PLATFORM)ws
1074 C_ARES_CFLAGS=/I$(C_ARES_DIR)/include
1075 C_ARES_LIBS=$(C_ARES_DIR)\lib\libcares-2.lib
1076 C_ARES_DLL=$(C_ARES_DIR)\bin\libcares-2.dll
1077 # Nmake uses carets to escape special characters
1078 C_ARES_CONFIG=^#define HAVE_C_ARES 1
1079 !else
1080 C_ARES_CFLAGS=
1081 C_ARES_LIBS=
1082 C_ARES_CONFIG=
1083 !IFDEF ADNS_DIR
1084 ADNS_PATH=$(ADNS_DIR)\adns_win32\lib
1085 ADNS_CFLAGS=/I$(ADNS_DIR)\src /I$(ADNS_DIR)\adns_win32
1086 ADNS_LIBS=$(WIRESHARK_LIBS)\$(MSVC_VARIANT)\adns\adns_dll.lib
1087 ADNS_DLL=$(WIRESHARK_LIBS)\$(MSVC_VARIANT)\adns\adns_dll.dll
1088 # Nmake uses carets to escape special characters
1089 ADNS_CONFIG=^#define HAVE_GNU_ADNS 1
1090 !else
1091 ADNS_CFLAGS=
1092 ADNS_LIBS=
1093 ADNS_CONFIG=
1094 !ENDIF # ADNS
1095 !ENDIF # C_ARES
1096
1097 !IFDEF KFW_DIR
1098 KFW_PATH=$(KFW_DIR)\bin
1099 KFW_CFLAGS=/I$(KFW_DIR)\include
1100 KFW_LIBS=$(KFW_DIR)\lib\krb5_32.lib
1101 # Nmake uses carets to escape special characters
1102 KFW_CONFIG=^#define HAVE_MIT_KERBEROS 1
1103 !else
1104 KFW_CFLAGS=
1105 KFW_LIBS=
1106 KFW_CONFIG=
1107 !ENDIF
1108
1109 !IFDEF PCRE_DIR
1110 PCRE_PATH=$(PCRE_DIR)\bin
1111 PCRE_CFLAGS=/I$(PCRE_DIR)\include
1112 PCRE_LIBS=$(PCRE_DIR)\lib\pcre.lib
1113 # Nmake uses carets to escape special characters
1114 PCRE_CONFIG=^#define HAVE_LIBPCRE 1
1115 !else
1116 PCRE_CFLAGS=
1117 PCRE_LIBS=
1118 PCRE_CONFIG=
1119 !ENDIF
1120
1121 !IFDEF NETTLE_DIR
1122 NETTLE_CFLAGS=/I$(NETTLE_DIR)
1123 NETTLE_LIBS=$(NETTLE_DIR)\libnettle.lib
1124 # Nmake uses carets to escape special characters
1125 NETTLE_CONFIG=^#define HAVE_LIBNETTLE 1
1126 !else
1127 NETTLE_CFLAGS=
1128 NETTLE_LIBS=
1129 NETTLE_CONFIG=
1130 !ENDIF
1131
1132 !IFDEF GNUTLS_PKG
1133 GNUTLS_DIR=$(WIRESHARK_LIBS)\gnutls-$(GNUTLS_PKG)-$(WIRESHARK_TARGET_PLATFORM)ws
1134 GNUTLS_PATH=$(GNUTLS_DIR)
1135 # /DNOCRYPT avoids inclusion of Wincrypt.h, avoiding a X509_NAME define clash
1136 GNUTLS_CFLAGS=/I$(GNUTLS_DIR)\include /DNOCRYPT /DIMPORT_LIGNUTLSDLL
1137 GCRYPT_LIBS = $(GNUTLS_DIR)\bin\libgcrypt-11.lib
1138 GNUTLS_LIBS=\
1139         $(GNUTLS_DIR)\bin\libtasn1-3.lib        \
1140         $(GNUTLS_DIR)\bin\libgpg-error-0.lib    \
1141         $(GCRYPT_LIBS) \
1142         $(GNUTLS_DIR)\bin\libgnutls-26.lib
1143 # Nmake uses carets to escape special characters
1144 GNUTLS_CONFIG=^#define HAVE_LIBGNUTLS 1
1145 LIBGCRYPT_CONFIG=^#define HAVE_LIBGCRYPT 1
1146 !else
1147 GNUTLS_CFLAGS=
1148 GNUTLS_LIBS=
1149 GNUTLS_CONFIG=
1150 LIBGCRYPT_CONFIG=
1151 !ENDIF
1152
1153 !IFDEF LUA_DIR
1154 LUA_CFLAGS=/I$(LUA_DIR)\include
1155 LUA_LIBS=$(LUA_DIR)\lua5.1.lib
1156 # Nmake uses carets to escape special characters
1157 LUA_CONFIG=^#define HAVE_LUA 1
1158 LUA_VERSION=^#define HAVE_LUA_5_1 1
1159 !else
1160 LUA_CFLAGS=
1161 LUA_LIBS=
1162 LUA_CONFIG=
1163 !ENDIF
1164
1165 !IF DEFINED(PYTHON_EMBED)
1166 PYTHON_CFLAGS=/I$(PYTHON_DIR)\include
1167 PYTHON_LIBS=$(PYTHON_DIR)\libs\python$(PYTHON_VER).lib
1168 # Nmake uses carets to escape special characters
1169 PYTHON_CONFIG=^#define HAVE_PYTHON 1
1170 !else
1171 PYTHON_CFLAGS=
1172 PYTHON_LIBS=
1173 PYTHON_CONFIG=
1174 !ENDIF
1175
1176 !IFDEF PORTAUDIO_DIR
1177 # Nmake uses carets to escape special characters
1178 PORTAUDIO_CONFIG=^#define HAVE_LIBPORTAUDIO 1
1179 !IF "$(PORTAUDIO_VERSION)" == "18"
1180 # V18 uses API version 1 and v19 API version 2
1181 PORTAUDIO_CFLAGS=/I$(PORTAUDIO_DIR)\pa_common
1182 PORTAUDIO_API_CONFIG=^#define PORTAUDIO_API_1 1
1183 !ELSE
1184 PORTAUDIO_CFLAGS=/I$(PORTAUDIO_DIR)\include /I$(PORTAUDIO_DIR)\src\common /I$(PORTAUDIO_DIR)\src\os\win /DPA_NO_DS /DPA_NO_ASIO
1185 !ENDIF
1186 !ELSE
1187 PORTAUDIO_CFLAGS=
1188 PORTAUDIO_CONFIG=
1189 !ENDIF
1190
1191 !IFDEF HHC_DIR
1192 !IF "$(MSVC_VARIANT)" == "MSVC6"
1193 HHC_CFLAGS=/I"$(HHC_DIR)\include" -DHHC_DIR
1194 HHC_LIBS="$(HHC_DIR)\lib\htmlhelp.lib"
1195 !ELSE
1196 HHC_CFLAGS=-DHHC_DIR
1197 HHC_LIBS=htmlhelp.lib
1198 !ENDIF
1199 !ELSE
1200 HHC_CFLAGS=
1201 HHC_LIBS=
1202 !ENDIF
1203
1204 !IFDEF SMI_DIR
1205 SMI_CONFIG=^#define HAVE_LIBSMI 1
1206 SMI_CFLAGS=/I$(SMI_DIR)\include
1207 SMI_LIBS=$(SMI_DIR)\lib\smi.lib
1208 !ELSE
1209 SMI_LIBS=
1210 SMI_CFLAGS=
1211 SMI_CONFIG=
1212 !ENDIF
1213
1214 !IFDEF GEOIP_DIR
1215 GEOIP_CONFIG=^#define HAVE_GEOIP 1
1216 GEOIP_CFLAGS=/I$(GEOIP_DIR)
1217 GEOIP_LIBS=$(GEOIP_DIR)\GeoIP.lib
1218 !ELSE
1219 GeoIP_LIBS=
1220 GeoIP_CFLAGS=
1221 GeoIP_CONFIG=
1222 !ENDIF
1223
1224 !IFDEF ENABLE_LIBWIRESHARK
1225 LIBWIRESHARK_CONFIG=^#define HAVE_LIBWIRESHARKDLL 1
1226 # Link plugins with the import library of libwireshark.dll
1227 LINK_PLUGINS_WITH_LIBWIRESHARK=USE
1228 !ELSE
1229 LIBWIRESHARK_CONFIG=
1230 !ENDIF
1231
1232 # Construct the path
1233 PATH=$(PATH);$(CYGWIN_PATH);$(GTK_DIR)\bin;$(GETTEXT_DIR)\bin;$(ZLIB_PATH);$(ADNS_PATH)
1234
1235 # We can't use a lot of IPv6 code with plain Visual C++ 6.0
1236 !IF "$(MSVC_VARIANT)" == "MSVC6" && !DEFINED(MSSDK)
1237 INET6_CONFIG=
1238 !ELSE
1239 INET6_CONFIG=^#define INET6 1
1240 !ENDIF
1241
1242 !IF "$(MSVC_VARIANT)" == "MSVC6" && !DEFINED(MSSDK)
1243 NTDDNDIS_CONFIG=
1244 !ELSE
1245 NTDDNDIS_CONFIG=^#define HAVE_NTDDNDIS_H 1
1246 !ENDIF