Fix a couple (value) mistakes in value_strings. Found by Martin's patch on the ...
[obnox/wireshark/wip.git] / config.nmake
1 # $Id$
2
3 # Some more information about the settings in this file can be found in
4 # the file README.windows and the Developer's Guide (available online).
5
6 ##### Target platform #####
7 # Only "win32" and "win64" are valid (for now).
8 # This can be defined in the system environment.
9 !IFNDEF WIRESHARK_TARGET_PLATFORM
10 WIRESHARK_TARGET_PLATFORM=win32
11 !ENDIF
12
13 ##### Versions #####
14
15 # The current Wireshark version
16 # It's highly recommended to leave MAJOR/MINOR/MICRO unchanged
17 VERSION_MAJOR=1
18 VERSION_MINOR=7
19 VERSION_MICRO=0
20 VERSION_BUILD=0
21 # It's recommended to change VERSION_EXTRA for your own custom builds
22 # e.g. "-SVN-12345"
23 VERSION_EXTRA=
24
25 # The version of the wiretap library (recommended: leave unchanged)
26 WTAP_VERSION_MAJOR=0
27 WTAP_VERSION_MINOR=3
28 WTAP_VERSION_MICRO=1
29
30
31
32 ##### Directories #####
33
34 #
35 # Base directory, where your libraries reside, which are needed to
36 # compile the sources. This setting is used only inside this file.
37 #
38 WIRESHARK_LIBS=C:\wireshark-$(WIRESHARK_TARGET_PLATFORM)-libs
39
40 #
41 # Base directory, where your programs reside.
42 # This setting is used only inside this file.
43 #
44 PROGRAM_FILES=$(PROGRAMFILES)
45
46 #
47 # Location of the "tools" directory. This affects HTML2TXT below and should
48 # be overridden by makefiles in any subdirectories that use HTML2TXT.
49 !IFNDEF TOOLS_DIR
50 TOOLS_DIR=tools
51 !ENDIF
52
53 #
54 # Machine type for the compiler and linker
55 # TARGET_MACHINE (Used for link /MACHINE) should be one of "X86" or "X64"
56 # (sorry ARM, Alpha, MIPS, and Itanium fans).
57 # CPU (Used by win32.mak) should be one of "i386" or "AMD64".
58 # PROCESSOR_ARCHITECTURE (Used for redistributable packages and
59 # manifests) should be one of "x86" or "amd64".
60 !if "$(WIRESHARK_TARGET_PLATFORM)" == "win32"
61 TARGET_MACHINE=x86
62 CPU=i386
63 PROCESSOR_ARCHITECTURE=x86
64 !else if "$(WIRESHARK_TARGET_PLATFORM)" == "win64"
65 TARGET_MACHINE=x64
66 CPU=AMD64
67 PROCESSOR_ARCHITECTURE=amd64
68 !else
69 !error Your mysterious moon-man architecture "$(WIRESHARK_TARGET_PLATFORM)" frightens and confuses us.
70 !endif
71
72
73 ##### Microsoft Visual C / Studio Variant #####
74 # For the different Studios, see: http://en.wikipedia.org/wiki/Microsoft_Visual_Studio
75 # only one of the following MSVC_VARIANT settings should be used
76 # BTW: The "Microsoft Visual C++ Toolkit 2003" DOESN'T WORK for WS!
77
78 # "Microsoft Visual Studio 6.0"
79 # Visual C++ 6.0, _MSC_VER 1200, msvcrt.dll (version 6)
80 #MSVC_VARIANT=MSVC6
81
82 # "Microsoft Visual Studio .NET (2002)"
83 # Visual C++ 7.0, _MSC_VER 1300, msvcr70.dll
84 #MSVC_VARIANT=MSVC2002
85
86 # "Microsoft .Net Framework SDK Version 1.0"
87 # needs additional Platform SDK installation
88 # Visual C++ 7.0, _MSC_VER 1300, msvcr70.dll
89 #MSVC_VARIANT=DOTNET10
90
91 # "Microsoft Visual Studio .NET 2003"
92 # Visual C++ 7.1, _MSC_VER 1310, msvcr71.dll
93 #MSVC_VARIANT=MSVC2003
94
95 # "Microsoft .Net Framework SDK Version 1.1"
96 # needs additional Platform SDK installation
97 # Visual C++ 7.1, _MSC_VER 1310, msvcr71.dll
98 #MSVC_VARIANT=DOTNET11
99
100 # "Microsoft Visual Studio 2005"
101 # Visual C++ 8.0, _MSC_VER 1400, msvcr80.dll
102 #MSVC_VARIANT=MSVC2005
103
104 # "Microsoft Visual C++ 2005 Express Edition"
105 # needs additional Platform SDK installation
106 # Visual C++ 8.0, _MSC_VER 1400, msvcr80.dll
107 #MSVC_VARIANT=MSVC2005EE
108
109 # "Microsoft .Net Framework 2.0 SDK"
110 # needs additional Platform SDK installation
111 # Visual C++ 8.0, _MSC_VER 1400, msvcr80.dll
112 #MSVC_VARIANT=DOTNET20
113
114 # "Microsoft Visual Studio 2008"
115 # Visual C++ 9.0, _MSC_VER 1500, msvcr90.dll
116 #MSVC_VARIANT=MSVC2008
117
118 # "Microsoft Visual C++ 2008 Express Edition"
119 # Visual C++ 9.0, _MSC_VER 1500, msvcr90.dll
120 #MSVC_VARIANT=MSVC2008EE
121
122 # "Microsoft Visual Studio 2010"
123 # Visual C++ 10.0, _MSC_VER 1600, msvcr100.dll
124 #MSVC_VARIANT=MSVC2010
125
126 # "Microsoft Visual C++ 2010 Express Edition"
127 # Visual C++ 10.0, _MSC_VER 1600, msvcr100.dll
128 #MSVC_VARIANT=MSVC2010EE
129
130 # The default if we haven't set a system environment variable or
131 # uncommented an entry above.
132 !IFNDEF MSVC_VARIANT
133 MSVC_VARIANT=MSVC2008
134 !ENDIF
135
136 #
137 # Optional: To compile some time critical code from assembler instead of C
138 #
139 # If you have the NASM compiler, set this to the NASM executable.
140 # http://nasm.sourceforge.net/
141 #
142 # If you don't have NASM, comment this line out, so that NASM
143 # isn't defined.
144 #
145 NASM=$(WIRESHARK_LIBS)\nasm-2.09.08\nasm.exe
146
147 #
148 # Optional: the Python library enables scripting support.
149 #
150 # If you don't have the Python library, comment this line out, so that
151 # PYTHON_EMBED isn't defined.
152 #
153 # NOTE: The Python library must have been compiled with the same
154 # compiler (MSVC_VARIANT) as Wireshark. Known python.org Python
155 # CRT versions:
156 #
157 # Python version    CRT (32-bit)    CRT (64-bit)
158 # 2.4.4             7.1             ?
159 # 2.6.1             9.0             ?
160 # 2.6.2                             9.0
161 #
162 # If you versions of Python and Visual C++ use different CRTs
163 # comment this out.
164 #
165 # XXX The DLL path in epan/wspython/wspy_libws.py likely needs to
166 # be fixed before this is enabled by default.
167 #PYTHON_EMBED=1
168
169 #
170 # Optional: the Python interpreter is used as part of the buildsystem
171 #
172 # This will override the automatic detection below.
173 #PYTHON_VER=27
174 #PYTHON_DIR=C:\Python$(PYTHON_VER)
175
176 #
177 # If you don't have the native Python package installed, you can use
178 # the Cygwin version (not recommended)
179 #
180 #PYTHON=env python
181
182 # Santity check: native vs Cygwin Python options
183 !IF DEFINED(PYTHON) && DEFINED(PYTHON_DIR)
184 !ERROR PYTHON and PYTHON_DIR cannot be specified at the same time
185 !ENDIF
186
187 # Find native Python automatically if PYTHON(_DIR) wasn't defined
188 !IF !DEFINED(PYTHON) && !DEFINED(PYTHON_DIR)
189 !IF EXIST(c:\Python27\python.exe)
190 PYTHON_VER=27
191 !ELSE IF EXIST(c:\Python26\python.exe)
192 PYTHON_VER=26
193 !ELSE IF EXIST(c:\Python25\python.exe)
194 PYTHON_VER=25
195 !ELSE IF EXIST(c:\Python24\python.exe)
196 PYTHON_VER=24
197 !ENDIF
198
199 !IF DEFINED(PYTHON_VER)
200 PYTHON_DIR=C:\Python$(PYTHON_VER)
201 !ENDIF
202 !ENDIF
203
204 !IF DEFINED(PYTHON_DIR)
205 PYTHON="$(PYTHON_DIR)\python.exe"
206 PATH=$(PYTHON_DIR);$(PATH)
207 !ENDIF
208
209 ##### To Use packet editor uncomment this line ####
210 ### Warning Experimental - work in progress
211 #WANT_PACKET_EDITOR=^#define WANT_PACKET_EDITOR 1
212
213 ##### To use UIManager insted of GtkItemFactory comment out this line NOTE not completly implemented yet some menus will be missing####
214 #MAIN_MENU_USE_UIMANAGER=^#define MAIN_MENU_USE_UIMANAGER 1
215
216 !if "$(WIRESHARK_TARGET_PLATFORM)" == "win32"
217 ##### Win32 Libraries #####
218 #
219 # Mandatory: GLib settings
220 #
221 # Please note: Since Wireshark release 1.0.0, we no longer support GLib1.x
222 #
223 GLIB_VERSION=2.0
224
225 #
226 # Mandatory: GLib, GTK & related library settings
227 #
228 # Please note: Since Wireshark release 1.0.0, we no longer support GTK1.x
229 #
230 # If you want building with GTK+, set GTK_DIR to the pathname of the
231 # directory in which the "include" and "lib" directories reside.
232 #
233 GTK_DIR=$(WIRESHARK_LIBS)\gtk2
234 # These macros are used by the nsis installer script and by the install target.
235 PNG_DLL=libpng14-14.dll
236 FREETYPE_DLL=freetype6.dll
237 FONTCONFIG_DLL=libfontconfig-1.dll
238 EXPAT_DLL=libexpat-1.dll
239 INTL_DLL=intl.dll
240 # This macro is used by the setup target.
241 #GTK_PKG=2.16.6-20100912
242 GTK_PKG=2.22.1-20101227
243
244 #
245 # Mandatory: Version numbers of GTK and pango.
246 #
247 # (MAJOR + MINOR Version number but without MICRO version number)
248 # These macros are used by the nsis installer script and by the setup target.
249 #
250 #GTK_INST_VERSION=2.16
251 GTK_INST_VERSION=2.22
252
253 #
254 # Optional: WinPcap developer's pack to capture network traffic.
255 #
256 # If you have the WinPcap developer's pack (at least version 3.0),
257 # set this to the directory in which the WinPcap developer's pack resides.
258 #
259 # If you don't have the WPdpack, comment this line out, so that
260 # PCAP_DIR isn't defined.
261 #
262 PCAP_DIR=$(WIRESHARK_LIBS)\WPdpack
263 # This macro is used by the nsis installer script, by the u3/portable apps and by the setup target.
264 PCAP_VERSION=4_1_2
265
266 #
267 # Optional: WinPcap remote capture support and new API
268 # (pcap_open(), pcap_findalldevs_ex(), etc.)
269 #
270 PCAP_REMOTE=1
271
272 #
273 # Optional: The ZLib enables unzipping of gzip compressed capture files
274 # "on the fly".
275 #
276 # If you have Zlib, set this to directory in which the Zlib headers
277 # and .lib file are stored.
278 #
279 # If you don't have Zlib, comment this line out, so that ZLIB_DIR isn't
280 # defined.
281 # EXperimental only use zlib 1.2.5 on win32 for now
282 ZLIB_DIR=$(WIRESHARK_LIBS)\zlib125
283
284 #
285 # Optional: the ADNS library enables asynchronous (nonblocking) DNS
286 # name resolvings.
287 #
288 # If you have GNU ADNS, set this to the directory in which the GNU ADNS
289 # .lib file is stored.
290 #
291 # If you don't have GNU ADNS, comment this line out, so that ADNS_DIR
292 # isn't defined.
293 #
294 # If C_ARES_DIR is defined below, it will override this setting.
295 #
296 #ADNS_DIR=$(WIRESHARK_LIBS)\adns-1.0-win32-05ws
297
298 #
299 # Optional: the c-ares library enables asynchronous (nonblocking) DNS
300 # name resolvings.
301 #
302 # If you have c-ares, set this to the directory in which the c-ares
303 # .lib file is stored. Setting this will override ADNS_DIR above. You
304 # can't have both.
305 #
306 # If you're using Visual C++ 6.0, you'll have to use a platform SDK that
307 # defines socklen_t, such as Windows Server 2003 PSDK.
308 #
309 # If you don't have c-ares, comment this line out, so that C_ARES_DIR
310 # isn't defined.
311 #
312 C_ARES_PKG=1.7.1
313
314 #
315 # Optional: the PCRE (Perl Compatible Regular Expressions) library
316 # enables regular expressions for display filters.
317 #
318 # If you have the PCRE library, set this to the directory in which
319 # the GNUWIN32 pcre-lib package is stored.
320 #
321 # If you don't have PCRE, comment this line out, so that PCRE_DIR
322 # isn't defined.
323 #
324 #PCRE_DIR=$(WIRESHARK_LIBS)\pcre-7.0
325
326 #
327 # Optional: the GNUTLS library enables ssl decryption.
328 #
329 # If you have the GNUTLS library, set this to the package version.
330 #
331 # If you don't have GNUTLS, comment this line out, so that GNUTLS_PKG
332 # isn't defined.
333 #
334 # Platform SDK conflicts with openssl.h header
335 GNUTLS_PKG=2.10.3-1.11
336
337 #
338 # Optional: the KFW library enables kerberos/sasl/dcerpc decryption.
339 #
340 # If you have the kerberos for windows (mit) library, set this to the
341 # directory where the kfw package is stored.
342 #
343 # If you don't have KFW, comment this line out, so that KFW_DIR
344 # isn't defined.
345 #
346 KFW_DIR=$(WIRESHARK_LIBS)\kfw-3-2-2-i386-ws-vc6
347
348 #
349 # Optional: the Nettle library enables ??? decryption.
350 #
351 # If you have the Nettle encryption library, set this to the
352 # directory in which the nettle package is stored.
353 #
354 # If you don't have Nettle, comment this line out, so that NETTLE_DIR
355 # isn't defined.
356 #
357 # NETTLE_DIR=$(WIRESHARK_LIBS)\nettle-1.10
358
359 #
360 # Optional: the LUA library enables scripting support.
361 #
362 # If you have the LUA library, set this to the directory in which
363 # the LUA package is stored.
364 #
365 # If you don't have LUA, comment this line out, so that LUA_DIR
366 # isn't defined.
367 #
368 LUA_DIST=5_1_4_Win32_dll6
369 LUA_DIR=$(WIRESHARK_LIBS)\lua5.1.4
370
371 #
372 # Optional: the PORTAUDIO library enables audio output for RTP streams.
373 #
374 # If you have the PORTAUDIO library (used for rtp_player), set this to
375 # the directory in which the PORTAUDIO library is stored.
376 #
377 # If you don't have PORTAUDIO, comment this line out, so that
378 # PORTAUDIO_DIR isn't defined.
379 #
380 #PORTAUDIO_DIR=$(WIRESHARK_LIBS)\portaudio_v18_1
381 PORTAUDIO_DIR=$(WIRESHARK_LIBS)\portaudio_v19_2
382
383 #
384 # Version number of PortAudio
385 #
386 #PORTAUDIO_VERSION=18
387 PORTAUDIO_VERSION=19
388
389 #
390 # Optional: AirPcap developer's pack to capture wireless network traffic
391 # incl. 802.11 management frames.
392 #
393 # If you have the AirPcap developer's pack, set this to the directory
394 # in which the AirPcap developer's pack resides.
395 #
396 # If you don't have the AirPcap developer's pack, comment this line out,
397 # so that AIRPCAP_DIR isn't defined.
398 #
399 AIRPCAP_DIR=$(WIRESHARK_LIBS)\AirPcap_Devpack_4_1_0_1622\AirPcap_Devpack
400
401 #
402 # Optional: LIBSMI, System Management Interface
403 #
404 # Used for oid-name resolution for SNMP and other protocols
405 #
406 SMI_DIR=$(WIRESHARK_LIBS)\libsmi-0.4.8
407
408 #
409 # Optional: GeoIP, IP address database lookups
410 #
411 # Used to map IP addresses to MaxMind GeoIP database entries
412 #
413 # GeoIP requires IPv6 definitions that don't ship with Visual C++ 6.0.
414 # However, the Microsoft Platform SDK for Windows Server 2003 R2 provides
415 # these definitions. The SDK's SetEnv.bat script defines INETSDK.
416 !IF "$(MSVC_VARIANT)" != "MSVC6" || DEFINED(INETSDK)
417 GEOIP_DIR=$(WIRESHARK_LIBS)\GeoIP-1.4.6-win32ws\libGeoIP
418 !ENDIF
419
420 !else
421 ##### Win64 Libraries #####
422 #
423 # Mandatory: GLib settings
424 #
425 # Please note: Since Wireshark release 1.0.0, we no longer support GLib1.x
426 #
427 GLIB_VERSION=2.0
428
429 #
430 # Mandatory: GLib, GTK & related library settings
431 #
432 # Please note: Since Wireshark release 1.0.0, we no longer support GTK1.x
433 #
434 # If you want building with GTK+, set GTK_DIR to the pathname of the
435 # directory in which the "include" and "lib" directories reside.
436 #
437 GTK_DIR=$(WIRESHARK_LIBS)\gtk2
438 # These macros are used by the nsis installer script and by the install target.
439 PNG_DLL=libpng14-14.dll
440 #TIFF_DLL=libtiff-3.dll
441 #JPEG_DLL=libjpeg-7.dll
442 FREETYPE_DLL=libfreetype-6.dll
443 FONTCONFIG_DLL=libfontconfig-1.dll
444 EXPAT_DLL=libexpat-1.dll
445 INTL_DLL=libintl-8.dll
446
447 # These macros are used by the setup target.
448 #GTK_PKG=2.16.6-20100912
449 GTK_PKG=2.22.1-20101229
450
451 #
452 # Mandatory: Version numbers of GTK and pango.
453 #
454 # (MAJOR + MINOR Version number but without MICRO version number)
455 # These macros are used by the nsis installer script and by the setup target.
456 #
457 #GTK_INST_VERSION=2.16
458 GTK_INST_VERSION=2.22
459
460 #
461 # Optional: WinPcap developer's pack to capture network traffic.
462 #
463 # If you have the WinPcap developer's pack (at least version 3.0),
464 # set this to the directory in which the WinPcap developer's pack resides.
465 #
466 # If you don't have the WPdpack, comment this line out, so that
467 # PCAP_DIR isn't defined.
468 #
469 PCAP_DIR=$(WIRESHARK_LIBS)\WPdpack
470 # This macro is used by the nsis installer script, by the u3/portable apps and by the setup target.
471 PCAP_VERSION=4_1_2
472
473 #
474 # Optional: WinPcap remote capture support and new API
475 # (pcap_open(), pcap_findalldevs_ex(), etc.)
476 #
477 PCAP_REMOTE=1
478
479 #
480 # Optional: The ZLib enables unzipping of gzip compressed capture files
481 # "on the fly".
482 #
483 # If you have Zlib, set this to directory in which the Zlib headers
484 # and .lib file are stored.
485 #
486 # If you don't have Zlib, comment this line out, so that ZLIB_DIR isn't
487 # defined.
488 #
489 ZLIB_DIR=$(WIRESHARK_LIBS)\zlib125
490
491 #
492 # Optional: the ADNS library enables asynchronous (nonblocking) DNS
493 # name resolvings.
494 #
495 # If you have GNU ADNS, set this to the directory in which the GNU ADNS
496 # .lib file is stored.
497 #
498 # If you don't have GNU ADNS, comment this line out, so that ADNS_DIR
499 # isn't defined.
500 #
501 # If C_ARES_DIR is defined below, it will override this setting.
502 #
503 #ADNS_DIR=$(WIRESHARK_LIBS)\adns-1.0-win32-05ws
504
505 #
506 # Optional: the c-ares library enables asynchronous (nonblocking) DNS
507 # name resolvings.
508 #
509 # If you have c-ares, set this to the directory in which the c-ares
510 # .lib file is stored. Setting this will override ADNS_DIR above. You
511 # can't have both.
512 #
513 # If you're using Visual C++ 6.0, you'll have to use a platform SDK that
514 # defines socklen_t, such as Windows Server 2003 PSDK.
515 #
516 # If you don't have c-ares, comment this line out, so that C_ARES_DIR
517 # isn't defined.
518 #
519 C_ARES_PKG=1.7.1
520
521 #
522 # Optional: the PCRE (Perl Compatible Regular Expressions) library
523 # enables regular expressions for display filters.
524 #
525 # If you have the PCRE library, set this to the directory in which
526 # the GNUWIN32 pcre-lib package is stored.
527 #
528 # If you don't have PCRE, comment this line out, so that PCRE_DIR
529 # isn't defined.
530 #
531 #PCRE_DIR=$(WIRESHARK_LIBS)\pcre-7.0
532
533 #
534 # Optional: the GNUTLS library enables ssl decryption.
535 #
536 # If you have the GNUTLS library, set this to the package version.
537 #
538 # If you don't have GNUTLS, comment this line out, so that GNUTLS_PKG
539 # isn't defined.
540 #
541 # Platform SDK conflicts with openssl.h header
542 GNUTLS_PKG=2.10.3-1.7
543
544 #
545 # Optional: the KFW library enables kerberos/sasl/dcerpc decryption.
546 #
547 # If you have the kerberos for windows (mit) library, set this to the
548 # directory where the kfw package is stored.
549 #
550 # If you don't have KFW, comment this line out, so that KFW_DIR
551 # isn't defined.
552 #
553 #KFW_DIR=$(WIRESHARK_LIBS)\kfw-3.2.2-ws1
554
555 #
556 # Optional: the Nettle library enables ??? decryption.
557 #
558 # If you have the Nettle encryption library, set this to the
559 # directory in which the nettle package is stored.
560 #
561 # If you don't have Nettle, comment this line out, so that NETTLE_DIR
562 # isn't defined.
563 #
564 # NETTLE_DIR=$(WIRESHARK_LIBS)\nettle-1.10
565
566 #
567 # Optional: the LUA library enables scripting support.
568 #
569 # If you have the LUA library, set this to the directory in which
570 # the LUA package is stored.
571 #
572 # If you don't have LUA, comment this line out, so that LUA_DIR
573 # isn't defined.
574 #
575 LUA_DIST=5_1_4_Win64_dll9
576 LUA_DIR=$(WIRESHARK_LIBS)\lua5.1.4
577
578 #
579 # Optional: the PORTAUDIO library enables audio output for RTP streams.
580 #
581 # If you have the PORTAUDIO library (used for rtp_player), set this to
582 # the directory in which the PORTAUDIO library is stored.
583 #
584 # If you don't have PORTAUDIO, comment this line out, so that
585 # PORTAUDIO_DIR isn't defined.
586 #
587 #PORTAUDIO_DIR=$(WIRESHARK_LIBS)\portaudio_v18_1
588 PORTAUDIO_DIR=$(WIRESHARK_LIBS)\portaudio_v19_2
589
590 #
591 # Version number of PortAudio
592 #
593 #PORTAUDIO_VERSION=18
594 PORTAUDIO_VERSION=19
595
596 #
597 # Optional: AirPcap developer's pack to capture wireless network traffic
598 # incl. 802.11 management frames.
599 #
600 # If you have the AirPcap developer's pack, set this to the directory
601 # in which the AirPcap developer's pack resides.
602 #
603 # If you don't have the AirPcap developer's pack, comment this line out,
604 # so that AIRPCAP_DIR isn't defined.
605 #
606 AIRPCAP_DIR=$(WIRESHARK_LIBS)\AirPcap_Devpack_4_1_0_1622\AirPcap_Devpack
607
608 #
609 # Optional: LIBSMI, System Management Interface
610 #
611 # Used for oid-name resolution for SNMP and other protocols
612 #
613 #SMI_DIR=$(WIRESHARK_LIBS)\libsmi-0.4.8
614
615 #
616 # Optional: GeoIP, IP address database lookups
617 #
618 # Used to map IP addresses to MaxMind GeoIP database entries
619 #
620 GEOIP_DIR=$(WIRESHARK_LIBS)\GeoIP-1.4.6-win64ws\libGeoIP
621
622 !endif
623
624 ##### Tools #####
625
626 # Set the following mandatory commands to find the tools.
627 # The easiest way is to use the corresponding packages from cygwin.
628
629 # Set up the path to the cygwin binaries
630 CYGWIN_PATH=c:\cygwin\bin
631
632 # command for a shell (cygwin's bash package recommended)
633 SH_PROG=bash
634
635 # bash versions after 3.1.6 need the 'igncr' shell option to be able to
636 #  process scripts in windows 'native format' (dos crlf format).
637 # The following !IF results in the option being used only if it is available
638 #  since using it on bash version 3.1.6 (or earlier) is not required and
639 #  will cause an error message.
640 !if "$(SH_PROG)"=="bash" && [$(CYGWIN_PATH)\bash -c "set -o igncr" 2>nul: ] == 0
641 SH_FLAGS=-o igncr
642 !endif
643
644 SH=$(SH_PROG) $(SH_FLAGS)
645
646
647 # command for perl (cygwin's perl package recommended)
648 PERL=perl
649
650 # command for pod2man and pod2html
651 # (part of the perl package, usually leave these unchanged)
652 POD2MAN=$(SH) pod2man
653 POD2HTML=$(SH) pod2html
654
655 # command for lex/flexx (cygwin's flex recommended)
656 LEX=flex
657
658 # command for yacc/bison (cygwin's bison recommended)
659 YACC=bison
660
661 # Commands to convert UNIX line endings to DOS/Windows
662 UNIX2DOS=u2d
663 TEXTIFY=$(SH) $(TOOLS_DIR)/textify.sh
664
665 #
666 # Optional: To build the NSIS installer.
667 #
668 # If you have the NSIS package, set this to the NSIS executable.
669 #
670 # If you don't have NSIS, comment this line out, so that MAKENSIS
671 # isn't defined.
672 #
673 MAKENSIS="$(PROGRAM_FILES)\NSIS\makensis.exe"
674
675 #
676 # Optional: To build the NSIS PortableApps installer.
677 #
678 # If you have the NSIS Unicode package, set this to the NSIS Unicode executable.
679 #
680 # If you don't have NSIS Unicode, comment this line out, so that
681 # MAKENSIS_UNICODE isn't defined.
682 #
683 MAKENSIS_UNICODE="$(PROGRAM_FILES)\NSIS\Unicode\makensis.exe"
684
685 #
686 # Optional: To build the developers API documentation with doxygen and dot.
687 # Currently experimental, outdated and incomplete.
688 #
689 # You will have to download and install:
690 # Doxygen from: http://www.doxygen.org
691 # Graphviz from: http://www.research.att.com/sw/tools/graphviz/
692 #
693 # If you have doxygen, set this to the doxygen executable.
694 #
695 # If you don't want the developers documentation (or don't have the tools),
696 # comment this line out, so that DOXYGEN isn't defined.
697 #
698 #DOXYGEN="$(PROGRAM_FILES)/doxygen/bin/doxygen.exe"
699
700 #
701 # Recommended: Use the compressed html help format .chm as the Wireshark integrated help.
702 #
703 # The required htmlhelp.h and htmlhelp.lib should be included in MSVC_VARIANT > MSVC6.
704 #
705 # For MSVC_VARIANT == MSVC6 you will have to download and install the html help workshop from:
706 #
707 # http://msdn.microsoft.com/library/default.asp?url=/library/en-us/htmlhelp/html
708 # /hwMicrosoftHTMLHelpDownloads.asp
709 #
710 # Then point HHC_DIR to the html help dir (where hhc.exe resides).
711 #
712 # If you don't want the online help (or don't have the tools),
713 # comment this line out, so that HHC_DIR isn't defined.
714 #
715 HHC_DIR=$(PROGRAM_FILES)/HTML Help Workshop
716
717 #
718 # Optional: To reduce the size of dlls and exes, which is especially useful for USB device distributions (U3, PortableApps)
719 #
720 # If you have the UPX package, set this to the upx.exe executable.
721 #
722 # UPX can be downloaded from:
723 #   http://upx.sourceforge.net/
724 #
725 # If you don't have UPX, or don't want to pack exes and dlls,
726 # comment this line out, so that UPX isn't defined.
727 #
728
729 UPX=$(WIRESHARK_LIBS)\upx303w\upx.exe
730
731 ##### Flags, PATHs and Miscellaneous #####
732
733 # Santity check: Python embedding requires a valid PYTHON_DIR
734 !IF DEFINED(PYTHON_EMBED) && !DEFINED(PYTHON_DIR)
735 !ERROR PYTHON_EMBED requires that PYTHON_DIR is defined
736 !ENDIF
737
738 # "convert" the MSVC variant into the required MSC compiler version
739 !IF "$(MSVC_VARIANT)" == "MSVC6"
740 MSC_VER_REQUIRED=1200
741 !ELSEIF "$(MSVC_VARIANT)" == "MSVC2002" || "$(MSVC_VARIANT)" == "DOTNET10"
742 MSC_VER_REQUIRED=1300
743 !ELSEIF "$(MSVC_VARIANT)" == "MSVC2003" || "$(MSVC_VARIANT)" == "DOTNET11"
744 MSC_VER_REQUIRED=1310
745 !ELSEIF "$(MSVC_VARIANT)" == "MSVC2005" || "$(MSVC_VARIANT)" == "MSVC2005EE" || "$(MSVC_VARIANT)" == "DOTNET20"
746 MSC_VER_REQUIRED=1400
747 !ELSEIF "$(MSVC_VARIANT)" == "MSVC2008" ||  "$(MSVC_VARIANT)" == "MSVC2008EE"
748 MSC_VER_REQUIRED=1500
749 !ELSEIF "$(MSVC_VARIANT)" == "MSVC2010" ||  "$(MSVC_VARIANT)" == "MSVC2010EE"
750 MSC_VER_REQUIRED=1600
751 !ELSE
752 !ERROR MSVC_VARIANT unknown
753 !ENDIF
754
755 ## Manifest processing is not needed for VC10 (Visual Studio 2010 C)
756 ## See: http://msdn.microsoft.com/en-us/library/dd293574.aspx
757 !IF ($(MSC_VER_REQUIRED) >= 1400) && ($(MSC_VER_REQUIRED) < 1600)
758 MANIFEST_INFO_REQUIRED=1
759 !ENDIF
760
761 # Compiler flags:
762 # /W3                               Warning level 3 (0 less - 4 most, 1 default)
763 # /Zi                               Create .pdb file for debugging
764 # /MD                               Use "multithread- and DLL-specific version" of run-time libraries
765 #                                    msvc documentation states that /MD causes _MT and _DLL to be defined
766 #                                    See: http://msdn.microsoft.com/en-us/library/2kzt1wy3%28v=VS.90%29.aspx
767 # /D_CRT_SECURE_NO_DEPRECATE        Don't warn for "insecure" calls,
768 #                                     see MSDN "Security Enhancements in the CRT"
769 # /D_CRT_NONSTDC_NO_DEPRECATE       Don't warn for "Deprecated CRT Functions" as MSDN calls this
770 # /D_BIND_TO_CURRENT_CRT_VERSION=1  Make sure our CRT and manifest versions match
771 #                                    (http://msdn.microsoft.com/en-us/library/cc664727.aspx)
772 # /DWIN32_LEAN_AND_MEAN             Don't include unnecessary Windows include files (see windows.h)
773 # /MANIFEST:no                      Don't create a SxS manifest. Makes sure our plugins don't load
774 #                                     a second copy of the CRT.
775 #
776 ##Note: LOCAL_CFLAGS are flags used for *all* compilations
777 ##      STANDARD_CFLAGS (see below) are flags used just for *Wireshark* compilations
778 !IF     "$(MSVC_VARIANT)" == "MSVC6"      || \
779         "$(MSVC_VARIANT)" == "MSVC2002"   || \
780         "$(MSVC_VARIANT)" == "DOTNET10"   || \
781         "$(MSVC_VARIANT)" == "MSVC2003"   || \
782         "$(MSVC_VARIANT)" == "DOTNET11"
783 LOCAL_CFLAGS=/Zi /W3 /MD /DWIN32_LEAN_AND_MEAN /DMSC_VER_REQUIRED=$(MSC_VER_REQUIRED)
784
785 !ELSEIF "$(MSVC_VARIANT)" == "MSVC2005"   || \
786         "$(MSVC_VARIANT)" == "MSVC2005EE" || \
787         "$(MSVC_VARIANT)" == "DOTNET20"   || \
788         "$(MSVC_VARIANT)" == "MSVC2008"   || \
789         "$(MSVC_VARIANT)" == "MSVC2008EE" || \
790         "$(MSVC_VARIANT)" == "MSVC2010"   || \
791         "$(MSVC_VARIANT)" == "MSVC2010EE"
792 LOCAL_CFLAGS=/Zi /W3 /MD /DWIN32_LEAN_AND_MEAN /DMSC_VER_REQUIRED=$(MSC_VER_REQUIRED) \
793              /D_CRT_SECURE_NO_DEPRECATE /D_CRT_NONSTDC_NO_DEPRECATE
794
795 !IF "$(WIRESHARK_TARGET_PLATFORM)" != "win64"
796 LOCAL_CFLAGS=$(LOCAL_CFLAGS) /D_BIND_TO_CURRENT_CRT_VERSION=1
797 !ENDIF
798
799 # Additional compiler warnings to be treated as "Level 3"
800 #  when compiling Wireshark sources. (Selected from "level 4" warnings).
801 ## 4295: array is too small to include a terminating null character
802 WARNINGS_CFLAGS=/w34295
803
804 !ELSE
805 !ERROR MSVC_VARIANT unknown
806 !ENDIF
807
808 # http://msdn.microsoft.com/en-us/library/bb385193.aspx
809 # /MP               Compiles multiple source files by using multiple processes
810 # /MP[processMax]   If you omit the processMax argument, the compiler retrieves the number of effective processors
811 #                   on your computer from the operating system, and creates a process for each processor.
812 #
813 # The following compiler options and language features that are incompatible with the /MP option:
814 #
815 # * #import preprocessor directive
816 # * /E, /EP
817 # * /Gm
818 # * /showIncludes
819 # * /Yc
820 #
821 !IF     "$(MSVC_VARIANT)" == "MSVC2008"   || \
822         "$(MSVC_VARIANT)" == "MSVC2008EE" || \
823         "$(MSVC_VARIANT)" == "MSVC2010"   || \
824         "$(MSVC_VARIANT)" == "MSVC2010EE"
825 LOCAL_CFLAGS= $(LOCAL_CFLAGS) /MP
826 !ENDIF
827
828 # Optional: Static analysis. Only supported in the full-frontal MSVC editions.
829 # http://msdn.microsoft.com/en-us/library/ms182025.aspx
830
831 !IFDEF ENABLE_CODE_ANALYSIS
832 LOCAL_CFLAGS= $(LOCAL_CFLAGS) /analyze:WX-
833 !ENDIF
834
835 #STANDARD_CFLAGS are flags used for *Wireshark* compiles (not stuff like lemon, etc)
836 STANDARD_CFLAGS=-DHAVE_CONFIG_H -D_U_="" $(LOCAL_CFLAGS) $(WARNINGS_CFLAGS)
837
838 #Comment out the following if warnings are not to be treated as errors
839 WARNINGS_ARE_ERRORS=-WX
840
841 ## XXX: _MT and _DLL are defined when /MD is used so CVARSDLL is apparently unneeded
842 ##CVARSDLL=-D_MT -D_DLL
843
844 # Linker flags:
845 # /DEBUG  generate debug info
846 # /PROFILE generate map file(s) for profiling
847 # /DEFAULTLIB:xxx use xxx as the standard C library
848 # /NODEFAULTLIB:xxx don't use xxx as the standard C library
849 #
850 LOCAL_LDFLAGS=/DEBUG /MACHINE:$(TARGET_MACHINE)
851 DLL_LDFLAGS =
852 !IFDEF MANIFEST_INFO_REQUIRED
853 DLL_LDFLAGS = /MANIFEST:no
854 !ENDIF
855
856 # Enable Safe Exception Handler.
857 # http://msdn.microsoft.com/en-us/magazine/cc337897.aspx
858 !IF $(MSC_VER_REQUIRED) >= 1300
859 LOCAL_CFLAGS= $(LOCAL_CFLAGS) /GS
860 !IF "$(WIRESHARK_TARGET_PLATFORM)" != "win64"
861 LOCAL_LDFLAGS= $(LOCAL_LDFLAGS) /SafeSEH
862 !ENDIF
863 !ENDIF
864
865 # Enable ASLR. Requires VS2008 or later.
866 # http://blogs.msdn.com/b/vcblog/archive/2009/05/21/dynamicbase-and-nxcompat.aspx
867 # DEP (/NXCompat) is handled in init_process_policies() via SetProcessDEPPolicy.
868
869 # ASLR http://msdn.microsoft.com/en-us/library/bb384887.aspx
870 !IF $(MSC_VER_REQUIRED) >= 1500
871 LOCAL_LDFLAGS= $(LOCAL_LDFLAGS) /DYNAMICBASE /FIXED:no
872 !ENDIF
873
874 PLUGIN_LDFLAGS = /NOLOGO /INCREMENTAL:no $(LOCAL_LDFLAGS) $(DLL_LDFLAGS)
875
876 #
877 # According to http://bugs.wireshark.org/bugzilla/show_bug.cgi?id=403
878 # XCOPY under Windows NT doesn't support the "/Y" flag.  This works
879 # around that bug.
880 # XXX - This apparently doesn't work for some versions of nmake:
881 # http://support.microsoft.com/default.aspx?scid=kb;en-us;86814
882 # It looks like we'll have to call "set copycmd=/y" before we run xcopy.
883 COPYCMD=/y
884
885 #
886 # If you don't want to build libwireshark.dll, you should comment out the
887 # following line. (Note: for plugin support this option must stay activated)
888 ENABLE_LIBWIRESHARK=USE
889
890 #
891 # install (debug) directory for Wireshark (relative to your source dir)
892 INSTALL_DIR=wireshark-gtk2
893
894
895
896 ##### C-Runtime Redistributable #####
897 #
898 # The C-Runtime since Version 7 must be shipped together with
899 # the program installer, to avoid missing msvcr*.dll files on
900 # the target machine.
901 #
902 # The location of these files differ on the various compiler
903 # packages, the following will use the default paths depending
904 # on the package version.
905 #
906 !IF "$(MSVC_VARIANT)" == "MSVC6"
907 # msvcrt.dll will already be available on target machines - nothing additional to install
908
909 !ELSEIF "$(WIRESHARK_TARGET_PLATFORM)" == "win64"
910 # We're not creating portable packages and therefore don't have to worry about
911 # "deploying using xcopy"
912 VCREDIST_EXE=$(WIRESHARK_LIBS)\vcredist_$(TARGET_MACHINE).exe
913
914 !ELSEIF "$(MSVC_VARIANT)" == "MSVC2002"
915 # you probably need to tweak this directory if you don't use the professional edition!
916 MSVCR_DLL=$(PROGRAM_FILES)\Microsoft Visual Studio .NET\Visual Studio .NET Professional - English\msvcr70.dll
917
918 !ELSEIF "$(MSVC_VARIANT)" == "DOTNET10"
919 # no redistributable available for this package!
920
921 !ELSEIF "$(MSVC_VARIANT)" == "MSVC2003"
922 # you probably need to tweak this directory if you don't use the professional edition!
923 MSVCR_DLL=$(PROGRAM_FILES)\Microsoft Visual Studio .NET 2003\Visual Studio .NET Professional 2003 - English\msvcr71.dll
924
925 !ELSEIF "$(MSVC_VARIANT)" == "DOTNET11"
926 # no redistributable available for this package!
927
928 !ELSEIF "$(MSVC_VARIANT)" == "MSVC2005"
929 MSVCR_DLL=$(PROGRAM_FILES)\Microsoft Visual Studio 8\VC\redist\$(PROCESSOR_ARCHITECTURE)\Microsoft.VC80.CRT\*.*
930
931 !ELSEIF "$(MSVC_VARIANT)" == "MSVC2005EE" || "$(MSVC_VARIANT)" == "DOTNET20" || "$(MSVC_VARIANT)" == "MSVC2008EE"
932 # you need to download the redistributable package vcredist_x86.exe from Microsoft first,
933 # and copy it to the lib folder!!!
934 VCREDIST_EXE=$(WIRESHARK_LIBS)\vcredist_$(TARGET_MACHINE).exe
935
936 !ELSEIF "$(MSVC_VARIANT)" == "MSVC2008"
937 MSVCR_DLL=$(PROGRAM_FILES)\Microsoft Visual Studio 9.0\VC\redist\$(PROCESSOR_ARCHITECTURE)\Microsoft.VC90.CRT\*.*
938
939 !ELSEIF "$(MSVC_VARIANT)" == "MSVC2010EE"
940 # you need to download the redistributable package vcredist_x86.exe from Microsoft first,
941 # and copy it to the lib folder!!!
942 VCREDIST_EXE=$(WIRESHARK_LIBS)\vcredist_$(TARGET_MACHINE).exe
943 !ELSEIF "$(MSVC_VARIANT)" == "MSVC2010"
944 MSVCR_DLL=$(PROGRAM_FILES)\Microsoft Visual Studio 10.0\VC\redist\$(TARGET_MACHINE)\Microsoft.VC100.CRT\*.*
945
946 !ELSE
947 !ERROR MSVC_VARIANT unknown
948 !ENDIF
949
950 !IF DEFINED(VCREDIST_EXE) && ! EXIST("$(VCREDIST_EXE)")
951 !ERROR Can't find $(VCREDIST_EXE). Have you downloaded it from Microsoft? \
952 See the developer's guide section "C-Runtime "Redistributable" files" for details how to get it
953 !ENDIF
954
955 ##### Advanced: Docbook/XML documentation generation #####
956 # If you want to generate the Docbook/XML based docs (User's and Developer's
957 # Guide, ...), you'll need some additional tools / libraries compared to the
958 # rest of the build process.
959 #
960 # FOR DETAILED INSTRUCTIONS TO GENERATE THE DOCS, SEE: docbook\README.txt.
961 #
962 # If you don't call the Makefile.nmake in the docbook dir to generate the
963 # docs, the following settings in this section will have no effect.
964
965 # formatting objects processor executable
966 # Comment this out if you don't have fop installed or you don't want the docs
967 # in PDF format.
968 #
969 # You may want to install the FOP hyphenation patterns from
970 # http://offo.sourceforge.net/hyphenation/
971 !IFNDEF FOP
972 FOP=fop-0.95\fop.bat
973 !ENDIF
974
975 # Additional options to fop.
976 FOP_OPTS=-Xmx256m
977
978 # html help compiler
979 # Comment this out if you don't have hhc.exe or you don't want the docs in
980 # .chm format.
981 #
982 # Beware: hhc.exe is NOT part of the MSVC packages in HHC_DIR mentioned above,
983 # so you'll need to install the HTML Help Workshop for this.
984 HHC_EXE="$(HHC_DIR)\hhc.exe"
985
986 # html to text converter for text version of release notes, e.g. elinks.
987 # This could also be "lynx", or "true" if neither elinks nor lynx is installed
988 # (cygwin: lynx works, elinks not available, links and true doesn't produce output)
989 #HTML2TXT=elinks -dump -dump-width 72
990 ##HTML2TXT=links -dump -width 72 ## XXX: Fails: For links -dump requires 'url' (filename) arg.
991 #HTML2TXT=lynx -dump -width=72 -nolist -stdin
992
993 !IFNDEF HTML2TXT
994 HTML2TXT=$(PYTHON) $(TOOLS_DIR)\html2text.py --width=72 --no-links
995 !ENDIF
996
997 # the XSL processor (part of cygwin's libxslt package)
998 XSLTPROC="xsltproc"
999
1000 # the XML validator (part of cygwin's libxml2 package)
1001 XMLLINT="xmllint"
1002
1003
1004
1005 ##############################################################################
1006 #
1007 # You should not have to change anything below this comment.
1008 # If you do, it's a deficiency in the Makefile.nmake files;
1009 # either tell wireshark-dev@wireshark.org about it, including
1010 # details of why you had to change it, or fix config.nmake
1011 # and any Makefile.nmake files that need to be changed, and
1012 # send us the patches, along with details of why the change
1013 # was necessary.
1014 #
1015 ##############################################################################
1016
1017 #
1018 # The RC_VERSION should be comma-separated, not dot-separated,
1019 # as per Graham Bloice's message in
1020 #
1021 #       http://www.ethereal.com/lists/ethereal-dev/200303/msg00283.html
1022 #
1023 # "The RC_VERSION variable in config.nmake should be comma separated.
1024 # This allows the resources to be built correctly and the version
1025 # number to be correctly displayed in the explorer properties dialog
1026 # for the executables, and XP's tooltip, rather than 0.0.0.0."
1027 #
1028
1029 VERSION=$(VERSION_MAJOR).$(VERSION_MINOR).$(VERSION_MICRO)$(VERSION_EXTRA)
1030 RC_VERSION=$(VERSION_MAJOR),$(VERSION_MINOR),$(VERSION_MICRO),$(VERSION_BUILD)
1031 PRODUCT_VERSION=$(VERSION_MAJOR).$(VERSION_MINOR).$(VERSION_MICRO).$(VERSION_BUILD)
1032
1033 WTAP_VERSION=$(WTAP_VERSION_MAJOR).$(WTAP_VERSION_MINOR).$(WTAP_VERSION_MICRO)
1034 RC_WTAP_VERSION=$(WTAP_VERSION_MAJOR),$(WTAP_VERSION_MINOR),$(WTAP_VERSION_MICRO)
1035
1036 # GLib
1037 GLIB_CFLAGS=/I$(GTK_DIR)\include\glib-$(GLIB_VERSION) \
1038         /I$(GTK_DIR)\lib\glib-$(GLIB_VERSION)\include
1039 GLIB_LIBS=$(GTK_DIR)\lib\glib-$(GLIB_VERSION).lib \
1040         $(GTK_DIR)\lib\gmodule-$(GLIB_VERSION).lib \
1041         $(GTK_DIR)\lib\gobject-$(GLIB_VERSION).lib
1042 GTHREAD_LIBS=$(GTK_DIR)\lib\gthread-$(GLIB_VERSION).lib
1043
1044 # GTK+
1045 GTK_CFLAGS=$(GLIB_CFLAGS) /I$(GTK_DIR)\include\gtk-2.0 \
1046         /I$(GTK_DIR)\include\gdk-pixbuf-2.0 \
1047         /I$(GTK_DIR)\lib\gtk-2.0\include \
1048         /I$(GTK_DIR)\include\atk-1.0 \
1049         /I$(GTK_DIR)\include\cairo \
1050         /I$(GTK_DIR)\include\pango-1.0
1051 GTK_LIBS=$(GTK_DIR)\lib\gtk-win32-2.0.lib \
1052         $(GTK_DIR)\lib\gdk-win32-2.0.lib \
1053         $(GTK_DIR)\lib\gdk_pixbuf-2.0.lib \
1054         $(GTK_DIR)\lib\pango-1.0.lib \
1055         $(GLIB_LIBS)
1056
1057 # 2.18 was no good(Theming problem)
1058 !IF "$(GTK_INST_VERSION)" == "2.22" || "$(GTK_INST_VERSION)" == "2.16" || "$(GTK_INST_VERSION)" == "2.14"
1059 GTK_LIB_DIR=2.10.0
1060
1061 !IFDEF PNG_DLL
1062 NEED_LIBPNG_DLL=USE
1063 !ENDIF
1064 !IFDEF JPEG_DLL
1065 NEED_LIBJPEG_DLL=USE
1066 !ENDIF
1067 !IFDEF TIFF_DLL
1068 NEED_LIBTIFF_DLL=USE
1069 !ENDIF
1070 NEED_CAIRO_DLL=USE
1071 # Pango >=1.24.5 Needs these:
1072 NEED_FREETYPE_DLL=USE
1073 NEED_FONTCONFIG_DLL=USE
1074 NEED_EXPAT_DLL=USE
1075
1076 GTK_WIMP_DLLSRC_DIR=$(GTK_DIR)\lib\gtk-2.0\2.10.0\engines
1077 GTK_WIMP_DLLDST_DIR=lib\gtk-2.0\2.10.0\engines
1078 GTK_WIMP_RCSRC_DIR=$(GTK_DIR)\share\themes\MS-Windows\gtk-2.0
1079 GTK_WIMP_RCDST_DIR=etc\gtk-2.0
1080 !ELSE
1081 !ERROR ? Unknown or invalid GTK_INST_VERSION
1082 !ENDIF
1083
1084
1085 !IFDEF AIRPCAP_DIR
1086 AIRPCAP_CONFIG=^#define HAVE_AIRPCAP 1
1087 AIRPDCAP_CONFIG=^#define HAVE_AIRPDCAP 1
1088 #AIRPCAP_CFLAGS=/I$(AIRPCAP_DIR)\include
1089 !ELSE
1090 AIRPCAP_CONFIG=
1091 AIRPDCAP_CONFIG=
1092 !ENDIF
1093
1094 !IFDEF PCAP_DIR
1095 # Nmake uses carets to escape special characters
1096 WINPCAP_CONFIG=^#define HAVE_LIBPCAP 1
1097 #
1098 # This requires that, if you're *building* Wireshark, you have
1099 # the most recent WinPcap's development package.  If, at *run*
1100 # time, an older version of WinPcap, missing some routines,
1101 # is found, we work around that.
1102 #
1103 PCAP_FINDALLDEVS_CONFIG=^#define HAVE_PCAP_FINDALLDEVS 1
1104 PCAP_DATALINK_NAME_TO_VAL_CONFIG=^#define HAVE_PCAP_DATALINK_NAME_TO_VAL 1
1105 PCAP_DATALINK_VAL_TO_NAME_CONFIG=^#define HAVE_PCAP_DATALINK_VAL_TO_NAME 1
1106 PCAP_DATALINK_VAL_TO_DESCRIPTION_CONFIG=^#define HAVE_PCAP_DATALINK_VAL_TO_DESCRIPTION 1
1107 # PCAP_BREAKLOOP won't have any benefit on Win32, but breaks compatibility with 3.0
1108 PCAP_BREAKLOOP_CONFIG=
1109 PCAP_LIST_DATALINKS_CONFIG=^#define HAVE_PCAP_LIST_DATALINKS 1
1110 PCAP_FREE_DATALINKS_CONFIG=^#define HAVE_PCAP_FREE_DATALINKS 1
1111 PCAP_SET_DATALINK_CONFIG=^#define HAVE_PCAP_SET_DATALINK 1
1112 PCAP_OPEN_DEAD_CONFIG=^#define HAVE_PCAP_OPEN_DEAD 1
1113 BPF_IMAGE_CONFIG=^#define HAVE_BPF_IMAGE 1
1114 !ELSE
1115 # no WpdPack installed
1116 WINPCAP_CONFIG=
1117 PCAP_FINDALLDEVS_CONFIG=
1118 PCAP_DATALINK_NAME_TO_VAL_CONFIG=
1119 PCAP_DATALINK_VAL_TO_NAME_CONFIG=
1120 PCAP_DATALINK_VAL_TO_DESCRIPTION_CONFIG=
1121 PCAP_BREAKLOOP_CONFIG=
1122 PCAP_LIST_DATALINKS_CONFIG=
1123 PCAP_FREE_DATALINKS_CONFIG=
1124 PCAP_SET_DATALINK_CONFIG=
1125 PCAP_OPEN_DEAD_CONFIG=
1126 BPF_IMAGE_CONFIG=
1127 !ENDIF
1128
1129 !IF DEFINED(PCAP_DIR) && DEFINED(PCAP_REMOTE)
1130 PCAP_HAVE_REMOTE_CONFIG=^#define HAVE_REMOTE 1
1131 PCAP_REMOTE_CONFIG=^#define HAVE_PCAP_REMOTE 1
1132 PCAP_OPEN_CONFIG=^#define HAVE_PCAP_OPEN 1
1133 PCAP_SETSAMPLING_CONFIG=^#define HAVE_PCAP_SETSAMPLING 1
1134 !ELSE
1135 PCAP_HAVE_REMOTE_CONFIG=
1136 PCAP_REMOTE_CONFIG=
1137 PCAP_OPEN_CONFIG=
1138 PCAP_SETSAMPLING_CONFIG=
1139 !ENDIF
1140
1141 !IFDEF ZLIB_DIR
1142 ZLIB_PATH=$(ZLIB_DIR)
1143 ZLIB_CFLAGS=/I$(ZLIB_DIR)\include
1144 ZLIB_LIBS=$(ZLIB_DIR)\lib\zdll.lib
1145 ZLIB_DLL=$(ZLIB_DIR)\zlib1.dll
1146 # Nmake uses carets to escape special characters
1147 ZLIB_CONFIG=^#define HAVE_LIBZ 1
1148 !else
1149 ZLIB_CFLAGS=
1150 ZLIB_LIBS=
1151 ZLIB_DLL=
1152 ZLIB_CONFIG=
1153 !ENDIF
1154
1155 !IFDEF C_ARES_PKG
1156 !UNDEF ADNS_DIR
1157 C_ARES_DIR=$(WIRESHARK_LIBS)\c-ares-$(C_ARES_PKG)-$(WIRESHARK_TARGET_PLATFORM)ws
1158 C_ARES_CFLAGS=/I$(C_ARES_DIR)/include
1159 C_ARES_LIBS=$(C_ARES_DIR)\lib\libcares-2.lib
1160 C_ARES_DLL=$(C_ARES_DIR)\bin\libcares-2.dll
1161 # Nmake uses carets to escape special characters
1162 C_ARES_CONFIG=^#define HAVE_C_ARES 1
1163 !else
1164 C_ARES_CFLAGS=
1165 C_ARES_LIBS=
1166 C_ARES_CONFIG=
1167 !IFDEF ADNS_DIR
1168 ADNS_PATH=$(ADNS_DIR)\adns_win32\lib
1169 ADNS_CFLAGS=/I$(ADNS_DIR)\src /I$(ADNS_DIR)\adns_win32
1170 ADNS_LIBS=$(WIRESHARK_LIBS)\$(MSVC_VARIANT)\adns\adns_dll.lib
1171 ADNS_DLL=$(WIRESHARK_LIBS)\$(MSVC_VARIANT)\adns\adns_dll.dll
1172 # Nmake uses carets to escape special characters
1173 ADNS_CONFIG=^#define HAVE_GNU_ADNS 1
1174 !else
1175 ADNS_CFLAGS=
1176 ADNS_LIBS=
1177 ADNS_CONFIG=
1178 !ENDIF # ADNS
1179 !ENDIF # C_ARES
1180
1181 !IFDEF KFW_DIR
1182 KFW_PATH=$(KFW_DIR)\bin
1183 KFW_CFLAGS=/I$(KFW_DIR)\include
1184 KFW_LIBS=$(KFW_DIR)\lib\krb5_32.lib
1185 # Nmake uses carets to escape special characters
1186 KFW_CONFIG=^#define HAVE_MIT_KERBEROS 1
1187 !else
1188 KFW_CFLAGS=
1189 KFW_LIBS=
1190 KFW_CONFIG=
1191 !ENDIF
1192
1193 !IFDEF PCRE_DIR
1194 PCRE_PATH=$(PCRE_DIR)\bin
1195 PCRE_CFLAGS=/I$(PCRE_DIR)\include
1196 PCRE_LIBS=$(PCRE_DIR)\lib\pcre.lib
1197 # Nmake uses carets to escape special characters
1198 PCRE_CONFIG=^#define HAVE_LIBPCRE 1
1199 !else
1200 PCRE_CFLAGS=
1201 PCRE_LIBS=
1202 PCRE_CONFIG=
1203 !ENDIF
1204
1205 !IFDEF NETTLE_DIR
1206 NETTLE_CFLAGS=/I$(NETTLE_DIR)
1207 NETTLE_LIBS=$(NETTLE_DIR)\libnettle.lib
1208 # Nmake uses carets to escape special characters
1209 NETTLE_CONFIG=^#define HAVE_LIBNETTLE 1
1210 !else
1211 NETTLE_CFLAGS=
1212 NETTLE_LIBS=
1213 NETTLE_CONFIG=
1214 !ENDIF
1215
1216 !IFDEF GNUTLS_PKG
1217 GNUTLS_DIR=$(WIRESHARK_LIBS)\gnutls-$(GNUTLS_PKG)-$(WIRESHARK_TARGET_PLATFORM)ws
1218 GNUTLS_PATH=$(GNUTLS_DIR)
1219 # /DNOCRYPT avoids inclusion of Wincrypt.h, avoiding a X509_NAME define clash
1220 GNUTLS_CFLAGS=/I$(GNUTLS_DIR)\include /DNOCRYPT /DIMPORT_LIGNUTLSDLL
1221 GCRYPT_LIBS = $(GNUTLS_DIR)\bin\libgcrypt-11.lib
1222 GNUTLS_LIBS=\
1223         $(GNUTLS_DIR)\bin\libtasn1-3.lib        \
1224         $(GNUTLS_DIR)\bin\libgpg-error-0.lib    \
1225         $(GCRYPT_LIBS) \
1226         $(GNUTLS_DIR)\bin\libgnutls-26.lib
1227 # Nmake uses carets to escape special characters
1228 GNUTLS_CONFIG=^#define HAVE_LIBGNUTLS 1
1229 LIBGCRYPT_CONFIG=^#define HAVE_LIBGCRYPT 1
1230 !else
1231 GNUTLS_CFLAGS=
1232 GNUTLS_LIBS=
1233 GNUTLS_CONFIG=
1234 LIBGCRYPT_CONFIG=
1235 !ENDIF
1236
1237 !IFDEF LUA_DIR
1238 LUA_CFLAGS=/I$(LUA_DIR)\include
1239 LUA_LIBS=$(LUA_DIR)\lua5.1.lib
1240 # Nmake uses carets to escape special characters
1241 LUA_CONFIG=^#define HAVE_LUA 1
1242 LUA_VERSION=^#define HAVE_LUA_5_1 1
1243 !else
1244 LUA_CFLAGS=
1245 LUA_LIBS=
1246 LUA_CONFIG=
1247 !ENDIF
1248
1249 !IF DEFINED(PYTHON_EMBED)
1250 PYTHON_CFLAGS=/I$(PYTHON_DIR)\include
1251 PYTHON_LIBS=$(PYTHON_DIR)\libs\python$(PYTHON_VER).lib
1252 # Nmake uses carets to escape special characters
1253 PYTHON_CONFIG=^#define HAVE_PYTHON 1
1254 !else
1255 PYTHON_CFLAGS=
1256 PYTHON_LIBS=
1257 PYTHON_CONFIG=
1258 !ENDIF
1259
1260 !IFDEF PORTAUDIO_DIR
1261 # Nmake uses carets to escape special characters
1262 PORTAUDIO_CONFIG=^#define HAVE_LIBPORTAUDIO 1
1263 !IF "$(PORTAUDIO_VERSION)" == "18"
1264 # V18 uses API version 1 and v19 API version 2
1265 PORTAUDIO_CFLAGS=/I$(PORTAUDIO_DIR)\pa_common
1266 PORTAUDIO_API_CONFIG=^#define PORTAUDIO_API_1 1
1267 !ELSE
1268 PORTAUDIO_CFLAGS=/I$(PORTAUDIO_DIR)\include /I$(PORTAUDIO_DIR)\src\common /I$(PORTAUDIO_DIR)\src\os\win /DPA_NO_DS /DPA_NO_ASIO
1269 !ENDIF
1270 !ELSE
1271 PORTAUDIO_CFLAGS=
1272 PORTAUDIO_CONFIG=
1273 !ENDIF
1274
1275 !IFDEF HHC_DIR
1276 !IF "$(MSVC_VARIANT)" == "MSVC6"
1277 HHC_CFLAGS=/I"$(HHC_DIR)\include" -DHHC_DIR
1278 HHC_LIBS="$(HHC_DIR)\lib\htmlhelp.lib"
1279 !ELSE
1280 HHC_CFLAGS=-DHHC_DIR
1281 HHC_LIBS=htmlhelp.lib
1282 !ENDIF
1283 !ELSE
1284 HHC_CFLAGS=
1285 HHC_LIBS=
1286 !ENDIF
1287
1288 !IFDEF SMI_DIR
1289 SMI_CONFIG=^#define HAVE_LIBSMI 1
1290 SMI_CFLAGS=/I$(SMI_DIR)\include
1291 SMI_LIBS=$(SMI_DIR)\lib\smi.lib
1292 !ELSE
1293 SMI_LIBS=
1294 SMI_CFLAGS=
1295 SMI_CONFIG=
1296 !ENDIF
1297
1298 !IFDEF GEOIP_DIR
1299 GEOIP_CONFIG=^#define HAVE_GEOIP 1
1300 GEOIP_CFLAGS=/I$(GEOIP_DIR)
1301 GEOIP_LIBS=$(GEOIP_DIR)\GeoIP.lib
1302 !ELSE
1303 GeoIP_LIBS=
1304 GeoIP_CFLAGS=
1305 GeoIP_CONFIG=
1306 !ENDIF
1307
1308 !IFDEF ENABLE_LIBWIRESHARK
1309 LIBWIRESHARK_CONFIG=^#define HAVE_LIBWIRESHARKDLL 1
1310 # Link plugins with the import library of libwireshark.dll
1311 LINK_PLUGINS_WITH_LIBWIRESHARK=USE
1312 !ELSE
1313 LIBWIRESHARK_CONFIG=
1314 !ENDIF
1315
1316 # Construct the path
1317 PATH=$(PATH);$(CYGWIN_PATH);$(GTK_DIR)\bin;$(GETTEXT_DIR)\bin;$(ZLIB_PATH);$(ADNS_PATH)
1318
1319 # We can't use a lot of IPv6 code with plain Visual C++ 6.0
1320 !IF "$(MSVC_VARIANT)" == "MSVC6" && !DEFINED(MSSDK)
1321 INET6_CONFIG=
1322 !ELSE
1323 INET6_CONFIG=^#define INET6 1
1324 !ENDIF
1325
1326 !IF "$(MSVC_VARIANT)" == "MSVC6" && !DEFINED(MSSDK)
1327 NTDDNDIS_CONFIG=
1328 !ELSE
1329 NTDDNDIS_CONFIG=^#define HAVE_NTDDNDIS_H 1
1330 !ENDIF