waf: disable-python - don't build samba-policy
authorIan Stakenvicius <axs@gentoo.org>
Sat, 28 Jan 2017 02:32:22 +0000 (21:32 -0500)
committerAndrew Bartlett <abartlet@samba.org>
Fri, 10 Mar 2017 06:31:13 +0000 (07:31 +0100)
samba-policy requires samba-net which requires PROVISION, which
is disabled when python isn't available.

Signed-off-by: Ian Stakenvicius <axs@gentoo.org>
Reviewed-by: Andrew Bartlett <abartlet@samba.org>
Reviewed-by: Douglas Bagnall <douglas.bagnall@catalyst.net.nz>
source4/lib/policy/wscript_build

index b8ba6384e43b1d0f5d971a07556415815e1c3c18..f7c59090b846c45d4051cc4315c82b6aa626d25c 100644 (file)
@@ -6,7 +6,8 @@ bld.SAMBA_LIBRARY('samba-policy',
        public_deps='ldb samba-net',
        vnum='0.0.1',
        pyembed=True,
-       public_headers='policy.h'
+       public_headers='policy.h',
+       enabled=bld.PYTHON_BUILD_IS_ENABLED()
        )
 
 bld.SAMBA_PYTHON('py_policy',