s4-dsdb: enable initial replication of partitions via DsReplicaSync
[nivanova/samba-autobuild/.git] / upgrading-samba4.txt
1 Upgrading from an older samba4 installation.
2
3 * Compile the new version of samba4 by following the HOWTO, but do
4   not install it yet, and do not run provision.
5 * Stop any samba process
6 * Backup your samba4 provision:
7   go into the directory where your samba4 provision is stored (/usr/local/samba by default)
8   do tar cf $HOME/backup.tar private etc var sysvol
9 * Go into the source4 dir
10 * do make install
11 * run 'samba-tool dbcheck'
12
13 This will do a consistency check of the data, and is all most existing
14 installations will require.
15
16 If you are upgrading from a quite old provision (Samba 4.0 alpha 13 or
17 earlier) then running upgradeprovision will do an upgrade of security
18 descriptors, and upgradeprovision --full will perform a more
19 comprehensive upgrade of the data (including schema and display
20 specifiers).  This attempts to do a new provision, and to then copy
21 existing data into that database.