The author of the upstream code asked for this code to be GPLv2+ not GPLv3