Update talloc version so we don't fail on system talloc 1.2.0
authorAndrew Bartlett <abartlet@samba.org>
Wed, 4 Mar 2009 23:46:46 +0000 (10:46 +1100)
committerAndrew Bartlett <abartlet@samba.org>
Wed, 4 Mar 2009 23:46:46 +0000 (10:46 +1100)
The problem is that talloc in the Samba tree now includes
talloc_get_type_abort(), which is not present on Fedora 10 or ubuntu's
talloc 1.2.0.

Andrew Bartlett

lib/talloc/configure.ac
source4/configure.ac

index d2538f92221cf7a5452c3970c7174fbcf52b276c..39cea393cef78af85aea9beb34c2ae07ccc9abd6 100644 (file)
@@ -1,5 +1,5 @@
 AC_PREREQ(2.50)
-AC_INIT(talloc, 1.2.0)
+AC_INIT(talloc, 1.2.1)
 AC_CONFIG_SRCDIR([talloc.c])
 AC_SUBST(datarootdir)
 AC_CONFIG_HEADER(config.h)
index 54ca9108b14d0d7857d34c06e772781f93a72188..d33df08406856f0f1bce223b94fd55391af1ca90 100644 (file)
@@ -42,7 +42,7 @@ AC_CONFIG_FILES(param/samba-hostconfig.pc)
 AC_CONFIG_FILES(librpc/dcerpc_samr.pc)
 AC_CONFIG_FILES(librpc/dcerpc_atsvc.pc)
 
-SMB_INCLUDED_LIB_PKGCONFIG(LIBTALLOC, talloc >= 1.2.0, [],
+SMB_INCLUDED_LIB_PKGCONFIG(LIBTALLOC, talloc >= 1.2.1, [],
        [
                m4_include(../lib/talloc/libtalloc.m4)
                SMB_INCLUDE_MK(../lib/talloc/config.mk)