s4-smbtorture: add spoolss_OpenPrinterEx ndr test with full devmode.
[kai/samba.git] / wscript
diff --git a/wscript b/wscript
index 6961eb84af72a66ecb1cd6758ee7af836b7fbf19..5ccb74d91dbae36666176f414fd372ff476261b5 100755 (executable)
--- a/wscript
+++ b/wscript
@@ -13,27 +13,15 @@ import wafsamba, Options, samba_dist, Scripting, Utils, samba_version
 
 samba_dist.DIST_DIRS('.')
 
-#This is a list of files that we don't want in the package, for
-#whatever reason.  Directories should be listed with a trailing / to
-#avoid over-exclusion.
-
-#This list includes files that would confuse the recipient of a
-#samba-4.0.0 branded tarball (until the merge is complete) and the
-#core elements of the autotools build system (which is known to
-#produce buggy binaries).
-samba_dist.DIST_BLACKLIST('README Manifest Read-Manifest-Now Roadmap ' +
-                          'packaging/ docs-xml/ examples/ swat/ WHATSNEW.txt MAINTAINERS ')
 # install in /usr/local/samba by default
 Options.default_prefix = '/usr/local/samba'
 
-os.environ['TOPLEVEL_BUILD'] = '1'
-
 def set_options(opt):
     opt.BUILTIN_DEFAULT('NONE')
     opt.PRIVATE_EXTENSION_DEFAULT('samba4')
     opt.RECURSE('lib/replace')
-    opt.RECURSE('source4/dynconfig')
-    opt.RECURSE('source4/lib/ldb')
+    opt.RECURSE('dynconfig')
+    opt.RECURSE('lib/ldb')
     opt.RECURSE('selftest')
     opt.RECURSE('source4/lib/tls')
     opt.RECURSE('lib/nss_wrapper')
@@ -47,16 +35,11 @@ def set_options(opt):
                    help='enable special build farm options',
                    action='store_true', dest='BUILD_FARM')
 
-    gr.add_option('--enable-s3build',
-                   help='enable build of s3 binaries',
-                   action='store_true', dest='S3BUILD')
-
     opt.tool_options('python') # options for disabling pyc or pyo compilation
     # enable options related to building python extensions
 
 
 def configure(conf):
-    conf.env.toplevel_build = True
     version = samba_version.load_version(env=conf.env)
 
     conf.DEFINE('CONFIG_H_IS_FROM_SAMBA', 1)
@@ -65,14 +48,12 @@ def configure(conf):
 
     if Options.options.developer:
         conf.ADD_CFLAGS('-DDEVELOPER -DDEBUG_PASSWORD')
-
-    if Options.options.S3BUILD:
-        conf.env.enable_s3build = True
+        conf.env.DEVELOPER = True
 
     # this enables smbtorture.static for s3 in the build farm
     conf.env.BUILD_FARM = Options.options.BUILD_FARM or os.environ.get('RUN_FROM_BUILD_FARM')
 
-    conf.ADD_EXTRA_INCLUDES('#include/public #source4 #lib #source4/lib #source4/include #include')
+    conf.ADD_EXTRA_INCLUDES('#include/public #source4 #lib #source4/lib #source4/include #include #lib/replace')
 
     conf.RECURSE('lib/replace')
 
@@ -92,15 +73,20 @@ def configure(conf):
             conf.ADD_CFLAGS('-fno-common')
         if not conf.CHECK_SHLIB_W_PYTHON("Checking if -undefined dynamic_lookup is not need"):
             conf.env.append_value('shlib_LINKFLAGS', ['-undefined', 'dynamic_lookup'])
+
+    if sys.platform == 'darwin':
+        conf.ADD_LDFLAGS('-framework CoreFoundation')
+
     if int(conf.env['PYTHON_VERSION'][0]) >= 3:
         raise Utils.WafError('Python version 3.x is not supported by Samba yet')
 
-    conf.RECURSE('source4/dynconfig')
-    conf.RECURSE('source4/lib/ldb')
+    conf.RECURSE('dynconfig')
+    conf.RECURSE('lib/ldb')
     conf.RECURSE('source4/heimdal_build')
     conf.RECURSE('source4/lib/tls')
     conf.RECURSE('source4/ntvfs/sysdep')
     conf.RECURSE('lib/util')
+    conf.RECURSE('lib/ccan')
     conf.RECURSE('lib/zlib')
     conf.RECURSE('lib/util/charset')
     conf.RECURSE('source4/auth')
@@ -113,18 +99,15 @@ def configure(conf):
     conf.RECURSE('libcli/smbreadline')
     conf.RECURSE('pidl')
     conf.RECURSE('selftest')
-    if conf.env.enable_s3build:
-        conf.RECURSE('source3')
+    conf.RECURSE('source3')
 
-    # we don't want any libraries or modules to rely on runtime
-    # resolution of symbols
-    if sys.platform != "openbsd4":
-        conf.env.undefined_ldflags = conf.ADD_LDFLAGS('-Wl,-no-undefined', testflags=True)
+    conf.SAMBA_CHECK_UNDEFINED_SYMBOL_FLAGS()
 
     # gentoo always adds this. We want our normal build to be as
     # strict as the strictest OS we support, so adding this here
     # allows us to find problems on our development hosts faster.
     # It also results in faster load time.
+
     if sys.platform != "openbsd4":
         conf.env.asneeded_ldflags = conf.ADD_LDFLAGS('-Wl,--as-needed', testflags=True)
 
@@ -151,7 +134,7 @@ def ctags(ctx):
     "build 'tags' file using ctags"
     import Utils
     source_root = os.path.dirname(Utils.g_module.root_path)
-    cmd = 'ctags $(find %s -name "*.[ch]" | grep -v "*_proto\.h" | egrep -v \.inst\.)' % source_root
+    cmd = 'ctags --python-kinds=-i $(find %s -name "*.[ch]" | grep -v "*_proto\.h" | egrep -v \.inst\.) $(find %s -name "*.py")' % (source_root, source_root)
     print("Running: %s" % cmd)
     os.system(cmd)
 
@@ -159,7 +142,7 @@ def ctags(ctx):
 # of commands in --help
 def build(bld):
     '''build all targets'''
-    samba_version.load_version(env=bld.env)
+    samba_version.load_version(env=bld.env, is_install=bld.is_install)
     pass