libgpo: fix the build of gpext plugins.
[kai/samba.git] / source3 / libgpo / gpext / scripts.c
index 4ced3abda581dc30af15e47f653e0914b72b339d..43f9b3afb59200d4b226032a07ba361840017169 100644 (file)
@@ -130,9 +130,9 @@ static NTSTATUS scripts_parse_ini_section(struct gp_inifile_context *ini_ctx,
        while (1) {
 
                const char *key = NULL;
-               const char *script = NULL;
+               char *script = NULL;
                const char *count = NULL;
-               const char *parameters = NULL;
+               char *parameters = NULL;
 
                count = talloc_asprintf(ini_ctx->mem_ctx, "%d", i);
                NT_STATUS_HAVE_NO_MEMORY(count);
@@ -354,7 +354,7 @@ static NTSTATUS scripts_process_group_policy(ADS_STRUCT *ads,
        debug_gpext_header(0, "scripts_process_group_policy", flags, gpo,
                           extension_guid, snapin_guid);
 
-       status = gpo_get_unix_path(mem_ctx, gpo, &unix_path);
+       status = gpo_get_unix_path(mem_ctx, cache_path(GPO_CACHE_DIR), gpo, &unix_path);
        NT_STATUS_NOT_OK_RETURN(status);
 
        status = gp_inifile_init_context(mem_ctx, flags, unix_path,