r6760: Update debian packages
[kai/samba.git] / packaging / debian / rules
index 69749888c2e7c17b451070e0297972473cb5c2bc..113347e4e5b36cabc328e8654bb6e858d1d5dd8c 100755 (executable)
@@ -4,8 +4,7 @@
 # based on the sample debian/rules file for GNU hello by Ian Jackson.
 
 
 # based on the sample debian/rules file for GNU hello by Ian Jackson.
 
 
-SOURCEPATH=../source
-DOCSPATH=../docs
+SOURCEPATH=../../source
 
 package=samba4
 
 
 package=samba4
 
@@ -25,21 +24,17 @@ configure:
                --with-syslog \
                --with-readline \
                --with-ldap 
                --with-syslog \
                --with-readline \
                --with-ldap 
-       cd $(DOCSPATH) && autoreconf
-       cd $(DOCSPATH) && ./configure
        touch configure
 
 build: configure
        $(checkdir)
        cd $(SOURCEPATH) && $(MAKE) proto all
        touch configure
 
 build: configure
        $(checkdir)
        cd $(SOURCEPATH) && $(MAKE) proto all
-       cd $(DOCSPATH) && $(MAKE) htmlman manpages
        touch build
 
 clean:
        $(checkdir)
        rm -f build
        -cd $(SOURCEPATH) && $(MAKE) clean
        touch build
 
 clean:
        $(checkdir)
        rm -f build
        -cd $(SOURCEPATH) && $(MAKE) clean
-       -cd $(DOCSPATH) && $(MAKE) clean
        rm -f `find . -name "*~"`
        rm -rf debian/tmp `find debian/* -type d ! -name CVS` debian/files* core
        rm -f debian/*substvars
        rm -f `find . -name "*~"`
        rm -rf debian/tmp `find debian/* -type d ! -name CVS` debian/files* core
        rm -f debian/*substvars
@@ -58,8 +53,6 @@ binary-arch: checkroot build
        cd $(SOURCEPATH) && $(MAKE) install DESTDIR=`pwd`/../packaging/debian/tmp
        mkdir -p debian/tmp/usr/share/man/man1 
        mkdir -p debian/tmp/usr/share/man/man7 
        cd $(SOURCEPATH) && $(MAKE) install DESTDIR=`pwd`/../packaging/debian/tmp
        mkdir -p debian/tmp/usr/share/man/man1 
        mkdir -p debian/tmp/usr/share/man/man7 
-       cp $(DOCSPATH)/output/manpages/*.1 debian/tmp/usr/share/man/man1
-       cp $(DOCSPATH)/output/manpages/*.7 debian/tmp/usr/share/man/man7
        cp $(SOURCEPATH)/build/pidl/pidl.pl debian/tmp/usr/bin/pidl
        debstd 
        dpkg-gencontrol -isp -psamba4
        cp $(SOURCEPATH)/build/pidl/pidl.pl debian/tmp/usr/bin/pidl
        debstd 
        dpkg-gencontrol -isp -psamba4