JHT ==> Updated files in preparation for release of Samba-1.9.16p10
[kai/samba.git] / examples / redhat / samba-1.9.16p10.spec
1 Summary: SMB client and server
2 Name: samba
3 Version: 1.9.16p10
4 Release: 1
5 Copyright: GPL
6 Group: Networking
7 Source: ftp://samba.anu.edu.au/pub/samba/samba-1.9.16p10.tar.gz
8 Patch: samba-make.patch
9 Packager: John H Terpstra [Samba-Team] <jht@aquasoft.com.au>
10 Requires: pamconfig
11
12 %description
13 Samba provides an SMB server which can be used to provide network
14 services to SMB (sometimes called "Lan Manager") clients, including
15 various versions of MS Windows, OS/2, and other Linux machines.
16 Samba also provides some SMB clients, which complement the built-in
17 SMB filesystem in Linux.
18
19 Samba uses NetBIOS over TCP/IP (NetBT) protocols and does NOT need
20 NetBEUI (Microsoft Raw NetBIOS frame) protocol.
21
22 %prep
23 %setup
24 %patch -p1
25
26 %ifarch axp
27 %patch2 -p1
28 %endif
29
30 %build
31 cd source
32 make RPM_OPT_FLAGS="$RPM_OPT_FLAGS"
33
34 %install
35 cd source
36 make install
37 cd ..
38 install -m644 examples/simple/smb.conf /etc/smb.conf.sampl
39 install -m644 examples/redhat/smb.conf /etc/smb.conf
40 install -m755 examples/redhat/smb.init /etc/rc.d/init.d/smb
41 ln -sf ../init.d/smb /etc/rc.d/rc3.d/S91smb
42 ln -sf ../init.d/smb /etc/rc.d/rc0.d/K35smb
43 ln -sf ../init.d/smb /etc/rc.d/rc6.d/K35smb
44 ln -sf ../init.d/smb /etc/rc.d/rc1.d/K35smb
45 mkdir -p /home/samba
46 mkdir -p /var/log/samba
47 chown root.nobody /home/samba
48 chmod 775 /home/samba
49
50 strip /usr/sbin/smbd /usr/bin/smbclient /usr/sbin/nmbd /usr/bin/testparm \
51         /usr/bin/testprns /usr/bin/smbrun /usr/bin/smbstatus \
52         /usr/bin/nmblookup /usr/bin/smbpasswd
53
54 %post
55 /sbin/pamconfig --add --service=samba --password=none --sesslist=none
56
57 %postun
58 if [ "$1" = 0 ] ; then
59   /sbin/pamconfig --remove --service=samba --password=none --sesslist=none
60 fi
61
62 %files
63 %doc docs/*.txt docs/INSTALL.sambatar docs/MIRRORS docs/PROJECTS 
64 %doc docs/README.DCEDFS docs/README.jis docs/README.sambatar 
65 %doc docs/SMBTAR.notes docs/THANKS docs/announce docs/history
66 %doc docs/samba.faq docs/samba.lsm docs/wfw_slip.htm 
67 %doc examples
68 /usr/sbin/smbd
69 /usr/bin/smbclient
70 /usr/sbin/nmbd
71 /usr/bin/testparm
72 /usr/bin/testprns
73 /usr/bin/smbrun
74 /usr/bin/smbstatus
75 /usr/bin/nmblookup
76 /usr/bin/smbpasswd
77 %config /etc/smb.conf
78 /etc/smb.conf.sampl
79 /etc/rc.d/init.d/smb
80 /etc/rc.d/rc3.d/S91smb
81 /etc/rc.d/rc0.d/K35smb
82 /etc/rc.d/rc1.d/K35smb
83 /etc/rc.d/rc6.d/K35smb
84 /usr/man/man1/smbstatus.1
85 /usr/man/man1/smbclient.1
86 /usr/man/man1/smbrun.1
87 /usr/man/man1/testparm.1
88 /usr/man/man1/testprns.1
89 /usr/man/man5/smb.conf.5
90 /usr/man/man7/samba.7
91 /usr/man/man8/smbd.8
92 /usr/man/man8/nmbd.8
93 %dir /home/samba
94 %dir /var/lock/samba