edc581cf057698c2f6ee36d6c84b76cde897ada5
[kai/samba.git] / docs / docbook / devdoc / packagers.sgml
1 <chapter id="Packaging">
2 <chapterinfo>
3         &author.jelmer;
4 </chapterinfo>
5
6 <title>Notes to packagers</title>
7
8 <sect1>
9 <title>Versioning</title>
10
11 <para>Please, please update the version number in 
12 <filename>source/include/version.h</filename> to include the versioning of your package. This makes it easier to distinguish standard samba builds
13 from custom-build samba builds (distributions often patch packages). For 
14 example, a good version would be: </para>
15
16 <para><programlisting>
17 Version 2.999+3.0.alpha21-5 for Debian
18 </programlisting></para>
19
20 </sect1>
21
22 <sect1>
23 <title>Modules</title>
24
25 <para>Samba now has support for building parts of samba as plugins. This 
26 makes it possible to, for example, put ldap or mysql support in a seperate 
27 package, thus making it possible to have a normal samba package not 
28 depending on ldap or mysql. To build as much parts of samba 
29 as a plugin, run: </para>
30
31 <para><programlisting>
32 ./configure --with-shared-modules=rpc,vfs,auth,pdb,charset
33 </programlisting></para>
34
35 </sect1>
36
37
38 </chapter>