In gcc version 4.3.2 we get warnings for functions declared with