Fix detection of elements in in-memory keytab code.
[jra/samba/.git] / source3 / configure.in
index 15defbe8f1235a1d7be4711de68325daecdeeecf..edb6576db1f4a290b90eca1b552a06de8c5ca83c 100644 (file)
@@ -28,7 +28,6 @@ AC_ARG_WITH(fhs,
     logfilebase="\${VARDIR}"
     lockdir="\${VARDIR}/locks"
     piddir="\${VARDIR}/locks"
-    mandir="\${prefix}/man"
     privatedir="\${prefix}/private"
     swatdir="\${prefix}/swat")
 
@@ -80,23 +79,6 @@ AC_ARG_WITH(piddir,
     ;;
   esac])
 
-#################################################
-# set pid directory location
-AC_ARG_WITH(piddir,
-[  --with-mandir=DIR       Where to put man pages ($ac_default_prefix/man)],
-[ case "$withval" in
-  yes|no)
-  #
-  # Just in case anybody calls it without argument
-  #
-    AC_MSG_WARN([--with-mandir called without argument - will use default])
-  ;;
-  * )
-    piddir="$withval"
-    ;;
-  esac])
-
-
 #################################################
 # set SWAT directory location
 AC_ARG_WITH(swatdir,
@@ -167,7 +149,6 @@ done
 AC_SUBST(configdir)
 AC_SUBST(lockdir)
 AC_SUBST(piddir)
-AC_SUBST(mandir)
 AC_SUBST(logfilebase)
 AC_SUBST(privatedir)
 AC_SUBST(swatdir)
@@ -2721,8 +2702,8 @@ if test x"$with_ads_support" != x"no"; then
       exit(0);
     exit(1);
   }], 
-  samba_cv_HAVE_MEMORY_KEYTAB=no,
-  samba_cv_HAVE_MEMORY_KEYTAB=yes)])
+  samba_cv_HAVE_MEMORY_KEYTAB=yes,
+  samba_cv_HAVE_MEMORY_KEYTAB=no)])
 
   if test x"$samba_cv_HAVE_MEMORY_KEYTAB" = x"yes"; then
       AC_DEFINE(HAVE_MEMORY_KEYTAB,1,
@@ -2732,7 +2713,7 @@ if test x"$with_ads_support" != x"no"; then
   AC_CACHE_CHECK([for key in krb5_keytab_entry],
                  samba_cv_HAVE_KRB5_KEYTAB_ENTRY_KEY,[
     AC_TRY_COMPILE([#include <krb5.h>],
-      [krb5_keytab_entry entry; entry.key = NULL;],
+      [krb5_keytab_entry entry; krb5_keyblock e; entry.key = e;],
       samba_cv_HAVE_KRB5_KEYTAB_ENTRY_KEY=yes,
       samba_cv_HAVE_KRB5_KEYTAB_ENTRY_KEY=no)])