(merge from 3.0)
authorAndrew Bartlett <abartlet@samba.org>
Thu, 22 Jan 2004 10:22:03 +0000 (10:22 +0000)
committerAndrew Bartlett <abartlet@samba.org>
Thu, 22 Jan 2004 10:22:03 +0000 (10:22 +0000)
Fix for debian Bug#225328 by LaMont Jones <lamont@debian.org>, where
the failure of our LFS test on ia64 caused the _GNU_SOURCE define not to be
added, causeing strndup() not to be defined...

This was due to strdup() bein implicitly declared, and casting
pointer->int->pointer.

I'll into when we really should define _GNU_SOURCE shortly, but the
fix is correct anyway.

Andrew Bartlett

source/configure.in

index 78cc87096371c8dbb0c2a5979e5a9110d08aee88..746fb9eb8916c6a60f618c0fa267631232bb4e00 100644 (file)
@@ -394,6 +394,8 @@ exit(1);
        AC_TRY_RUN([
 #include <unistd.h>
 #include <sys/utsname.h>
+#include <string.h>
+#include <stdlib.h>
 main() {
 #if _LFS64_LARGEFILE == 1
        struct utsname uts;