Move pidl bits to a separate file.
authorJelmer Vernooij <jelmer@samba.org>
Mon, 11 Feb 2008 13:48:39 +0000 (14:48 +0100)
committerJelmer Vernooij <jelmer@samba.org>
Mon, 11 Feb 2008 14:19:24 +0000 (15:19 +0100)
source/Makefile
source/pidl/config.mk [new file with mode: 0644]

index 3aebc831af981718e993b8591bc8d1026b01a130..e734b01834efa85945a0c818372056f5e0cd7334 100644 (file)
@@ -1,4 +1,6 @@
 #!gmake
+# The Samba 4 Makefile.
+# This file is *NOT* autogenerated.
 
 include mkconfig.mk
 
@@ -68,8 +70,8 @@ showflags::
 # The permissions to give the executables
 INSTALLPERMS = 0755
 
-install:: showlayout everything installbin installdat installswat installmisc installlib \
-       installheader installpc installplugins
+install:: showlayout everything installbin installdat installswat installmisc \
+             installlib installheader installpc installplugins
 
 # DESTDIR is used here to prevent packagers wasting their time
 # duplicating the Makefile. Remove it and you will have the privilege
@@ -165,41 +167,9 @@ uninstallman::
 data.mk: config.status $(MK_FILES)
        ./config.status
 
-pidl/Makefile: pidl/Makefile.PL
-       cd pidl && $(PERL) Makefile.PL 
-
-testcov-html:: pidl-testcov
-
-pidl-testcov: pidl/Makefile
-       cd pidl && cover -test
-
-installpidl:: pidl/Makefile
-       $(MAKE) -C pidl install
-
-uninstallpidl:: pidl/Makefile
-       $(MAKE) -C pidl uninstall
-
-$(IDL_HEADER_FILES) \
-       $(IDL_NDR_PARSE_H_FILES) $(IDL_NDR_PARSE_C_FILES) \
-       $(IDL_NDR_CLIENT_C_FILES) $(IDL_NDR_CLIENT_H_FILES) \
-       $(IDL_NDR_SERVER_C_FILES) $(IDL_SWIG_FILES) \
-       $(IDL_NDR_EJS_C_FILES) $(IDL_NDR_EJS_H_FILES) \
-       $(IDL_NDR_PY_C_FILES) $(IDL_NDR_PY_H_FILES): idl
-
-idl_full:: pidl/lib/Parse/Pidl/IDL.pm pidl/lib/Parse/Pidl/Expr.pm 
-       @CPP="$(CPP)" PERL="$(PERL)" srcdir=$(srcdir) $(srcdir)/script/build_idl.sh FULL
-
-idl:: pidl/lib/Parse/Pidl/IDL.pm pidl/lib/Parse/Pidl/Expr.pm 
-       @CPP="$(CPP)" PERL="$(PERL)" srcdir=$(srcdir) $(srcdir)/script/build_idl.sh PARTIAL 
-
-pidl/lib/Parse/Pidl/IDL.pm: pidl/idl.yp
-       -$(YAPP) -m 'Parse::Pidl::IDL' -o pidl/lib/Parse/Pidl/IDL.pm pidl/idl.yp ||\
-               touch pidl/lib/Parse/Pidl/IDL.pm 
-
-pidl/lib/Parse/Pidl/Expr.pm: pidl/idl.yp
-       -$(YAPP) -m 'Parse::Pidl::Expr' -o pidl/lib/Parse/Pidl/Expr.pm pidl/expr.yp ||\
-               touch pidl/lib/Parse/Pidl/Expr.pm 
+testcov-html:: 
 
+include pidl/config.mk
 include selftest/config.mk
 include rules.mk
 
diff --git a/source/pidl/config.mk b/source/pidl/config.mk
new file mode 100644 (file)
index 0000000..3793008
--- /dev/null
@@ -0,0 +1,36 @@
+pidl/Makefile: pidl/Makefile.PL
+       cd pidl && $(PERL) Makefile.PL 
+
+pidl-testcov: pidl/Makefile
+       cd pidl && cover -test
+
+installpidl:: pidl/Makefile
+       $(MAKE) -C pidl install
+
+uninstallpidl:: pidl/Makefile
+       $(MAKE) -C pidl uninstall
+
+idl_full:: pidl/lib/Parse/Pidl/IDL.pm pidl/lib/Parse/Pidl/Expr.pm 
+       @CPP="$(CPP)" PERL="$(PERL)" srcdir=$(srcdir) $(srcdir)/script/build_idl.sh FULL
+
+idl:: pidl/lib/Parse/Pidl/IDL.pm pidl/lib/Parse/Pidl/Expr.pm 
+       @CPP="$(CPP)" PERL="$(PERL)" srcdir=$(srcdir) $(srcdir)/script/build_idl.sh PARTIAL 
+
+pidl/lib/Parse/Pidl/IDL.pm: pidl/idl.yp
+       -$(YAPP) -m 'Parse::Pidl::IDL' -o pidl/lib/Parse/Pidl/IDL.pm pidl/idl.yp ||\
+               touch pidl/lib/Parse/Pidl/IDL.pm 
+
+pidl/lib/Parse/Pidl/Expr.pm: pidl/idl.yp
+       -$(YAPP) -m 'Parse::Pidl::Expr' -o pidl/lib/Parse/Pidl/Expr.pm pidl/expr.yp ||\
+               touch pidl/lib/Parse/Pidl/Expr.pm 
+
+testcov-html:: pidl-testcov
+
+$(IDL_HEADER_FILES) \
+       $(IDL_NDR_PARSE_H_FILES) $(IDL_NDR_PARSE_C_FILES) \
+       $(IDL_NDR_CLIENT_C_FILES) $(IDL_NDR_CLIENT_H_FILES) \
+       $(IDL_NDR_SERVER_C_FILES) $(IDL_SWIG_FILES) \
+       $(IDL_NDR_EJS_C_FILES) $(IDL_NDR_EJS_H_FILES) \
+       $(IDL_NDR_PY_C_FILES) $(IDL_NDR_PY_H_FILES): idl
+
+