r14569: Make more functions public.
authorJelmer Vernooij <jelmer@samba.org>
Sun, 19 Mar 2006 17:57:34 +0000 (17:57 +0000)
committerGerald (Jerry) Carter <jerry@samba.org>
Wed, 10 Oct 2007 18:58:48 +0000 (13:58 -0500)
source/build/smb_build/makefile.pm
source/ntptr/config.mk
source/ntvfs/config.mk
source/rpc_server/config.mk
source/rpc_server/dcerpc_server.c

index 6ed1c36d13ede04f2861b12ed4e2939cde04f8b2..b0c7ea3be1c13128223ac584c90e4db35af3baaf 100644 (file)
@@ -249,7 +249,7 @@ __EOD__
                defined($ctx->{LIBRARY_SONAME})) {
                $soarg = "$self->{config}->{SONAMEFLAG}$ctx->{LIBRARY_SONAME} ";
                if ($ctx->{LIBRARY_REALNAME} ne $ctx->{LIBRARY_SONAME}) {
-                       $soargdebug = "\tln -fs $ctx->{LIBRARY_REALNAME} $ctx->{DEBUGDIR}/$ctx->{LIBRARY_SONAME}\n";
+                       $soargdebug = "\t\@ln -fs $ctx->{LIBRARY_REALNAME} $ctx->{DEBUGDIR}/$ctx->{LIBRARY_SONAME}\n";
                }
        }
 
index c4bccd7a68a9122793bc1d81804c91bce53258a8..2aea27f76702be4819f29ec08ec66f09ff816d36 100644 (file)
@@ -19,6 +19,7 @@ PRIVATE_PROTO_HEADER = ntptr_proto.h
 OBJ_FILES = \
                ntptr_base.o \
                ntptr_interface.o
+REQUIRED_SUBSYSTEMS = DCERPC_COMMON
 #
 # End SUBSYSTEM ntptr
 ################################################
index 3f05bfa7be1966f9c70e3c3cf243c886fe725ef4..7a37641f91540c3251ec5ec77583fb29ccb40f43 100644 (file)
@@ -46,6 +46,7 @@ OBJ_FILES = \
                ipc/vfs_ipc.o \
                ipc/ipc_rap.o \
                ipc/rap_server.o
+REQUIRED_SUBSYSTEMS = DCERPC_COMMON dcerpc_server
 # End MODULE ntvfs_ipc
 ################################################
 
index 7ded61909553ada5741603e3924478509bd0ae4c..f7f0a81ea4386d95b5faf648d2a2f59a9ca262f6 100644 (file)
@@ -213,7 +213,8 @@ OBJ_FILES = \
 REQUIRED_SUBSYSTEMS = \
                LIBCLI_AUTH \
                LIBNDR \
-               dcerpc
+               dcerpc \
+               service
 #
 # End SUBSYSTEM DCERPC
 ################################################
index f4780eaf3824fd5ce142437cc046a92735ec3705..121474051e8024c37acfc9f2063a5f2cc376965e 100644 (file)
@@ -1115,7 +1115,7 @@ NTSTATUS dcesrv_input(struct dcesrv_connection *dce_conn, const DATA_BLOB *data)
 
   from the current fragment
 */
-NTSTATUS dcesrv_output(struct dcesrv_connection *dce_conn, 
+_PUBLIC_ NTSTATUS dcesrv_output(struct dcesrv_connection *dce_conn, 
                       void *private_data,
                       NTSTATUS (*write_fn)(void *private_data, DATA_BLOB *output, size_t *nwritten))
 {