r22234: merge test suite changes from bzr tree
authorAndrew Tridgell <tridge@samba.org>
Mon, 16 Apr 2007 04:47:11 +0000 (04:47 +0000)
committerGerald (Jerry) Carter <jerry@samba.org>
Wed, 10 Oct 2007 19:50:41 +0000 (14:50 -0500)
source/cluster/ctdb/Makefile.in
source/cluster/ctdb/config.mk
source/cluster/ctdb/ctdb_cluster.c
source/cluster/ctdb/ctdb_cluster.h
source/cluster/ctdb/tests/cmdline.c [new file with mode: 0644]
source/cluster/ctdb/tests/cmdline.h [new file with mode: 0644]
source/cluster/ctdb/tests/ctdb_bench.c
source/cluster/ctdb/tests/ctdb_fetch.c
source/cluster/ctdb/tests/ctdb_fetch1.c
source/cluster/ctdb/tests/ctdb_messaging.c
source/cluster/ctdb/tests/ctdb_test.c

index e0baf53045911758d0bf7393d4ec587af7b414e3..175418aa99dcc17310686b58ac9eb69d09a8a822 100644 (file)
@@ -49,9 +49,9 @@ showflags:
 dirs:
        @mkdir -p $(DIRS)
 
-bin/ctdb_test: $(OBJS) tests/ctdb_test.o
+bin/ctdb_test: $(OBJS) tests/ctdb_test.o tests/cmdline.o
        @echo Linking $@
-       @$(CC) $(CFLAGS) -o $@ tests/ctdb_test.o $(OBJS) $(LIB_FLAGS)
+       @$(CC) $(CFLAGS) -o $@ tests/ctdb_test.o tests/cmdline.o $(OBJS) $(LIB_FLAGS)
 
 bin/ctdbd: $(OBJS) direct/ctdbd.o
        @echo Linking $@
@@ -61,21 +61,21 @@ bin/ctdbd_test: $(OBJS) direct/ctdbd_test.o
        @echo Linking $@
        @$(CC) $(CFLAGS) -o $@ direct/ctdbd_test.o 
 
-bin/ctdb_bench: $(OBJS) tests/ctdb_bench.o
+bin/ctdb_bench: $(OBJS) tests/ctdb_bench.o tests/cmdline.o
        @echo Linking $@
-       @$(CC) $(CFLAGS) -o $@ tests/ctdb_bench.o $(OBJS) $(LIB_FLAGS)
+       @$(CC) $(CFLAGS) -o $@ tests/ctdb_bench.o tests/cmdline.o $(OBJS) $(LIB_FLAGS)
 
-bin/ctdb_fetch: $(OBJS) tests/ctdb_fetch.o
+bin/ctdb_fetch: $(OBJS) tests/ctdb_fetch.o tests/cmdline.o
        @echo Linking $@
-       @$(CC) $(CFLAGS) -o $@ tests/ctdb_fetch.o $(OBJS) $(LIB_FLAGS)
+       @$(CC) $(CFLAGS) -o $@ tests/ctdb_fetch.o tests/cmdline.o $(OBJS) $(LIB_FLAGS)
 
-bin/ctdb_fetch1: $(OBJS) tests/ctdb_fetch1.o
+bin/ctdb_fetch1: $(OBJS) tests/ctdb_fetch1.o tests/cmdline.o
        @echo Linking $@
-       @$(CC) $(CFLAGS) -o $@ tests/ctdb_fetch1.o $(OBJS) $(LIB_FLAGS)
+       @$(CC) $(CFLAGS) -o $@ tests/ctdb_fetch1.o tests/cmdline.o $(OBJS) $(LIB_FLAGS)
 
-bin/ctdb_messaging: $(OBJS) tests/ctdb_messaging.o
+bin/ctdb_messaging: $(OBJS) tests/ctdb_messaging.o tests/cmdline.o
        @echo Linking $@
-       @$(CC) $(CFLAGS) -o $@ tests/ctdb_messaging.o $(OBJS) $(LIB_FLAGS)
+       @$(CC) $(CFLAGS) -o $@ tests/ctdb_messaging.o tests/cmdline.o $(OBJS) $(LIB_FLAGS)
 
 bin/ibwrapper_test: $(OBJS) ib/ibwrapper_test.o
        @echo Linking $@
index 0e0629bfb1f16ada319d9f0c95c58bdb6ec8a186..a16b7b2991949bd9093fd0ae556c27b11cb44074 100644 (file)
@@ -15,6 +15,7 @@ OBJ_FILES = \
 
 ##################
 [SUBSYSTEM::ctdb]
+INIT_FUNCTION = server_service_ctdbd_init
 OBJ_FILES = \
                ctdb_cluster.o \
                common/ctdb.o \
index 82eea6a3d46c79ef9867399a7ce74ee67c3fc6a8..c9233696e8b7048793a70357c310811f13fcfb52 100644 (file)
@@ -110,25 +110,6 @@ static void *ctdb_backend_handle(struct cluster_ops *ops)
 static void ctdb_message_handler(struct ctdb_context *ctdb, uint32_t srvid, 
                                 TDB_DATA data, void *private)
 {
-       struct cluster_state *state = talloc_get_type(private, struct cluster_state);
-       struct cluster_messaging_list *m;
-       for (m=state->list;m;m=m->next) {
-               if (srvid == m->server.id) {
-                       DATA_BLOB bdata;
-                       bdata.data   = data.dptr;
-                       bdata.length = data.dsize;
-                       m->handler(m->msg, bdata);
-               }
-       }
-}
-
-/*
-  destroy a element of messaging list (when messaging context goes away)
-*/
-static int cluster_messaging_destructor(struct cluster_messaging_list *m)
-{
-       DLIST_REMOVE(m->state->list, m);
-       return 0;
 }
 
 /*
@@ -139,30 +120,7 @@ static NTSTATUS ctdb_message_init(struct cluster_ops *ops,
                                  struct server_id server,
                                  cluster_message_fn_t handler)
 {
-       struct cluster_state *state = ops->private;
-       struct cluster_messaging_list *m;
-       int ret;
-
-       /* setup messaging handler */
-       ret = ctdb_set_message_handler(state->ctdb, CTDB_SRVID_ALL, 
-                                      ctdb_message_handler, state);
-        if (ret == -1) {
-                DEBUG(0,("ctdb_set_message_handler failed - %s\n", 
-                        ctdb_errstr(state->ctdb)));
-               exit(1);
-        }
-
-       m = talloc(msg, struct cluster_messaging_list);
-       NT_STATUS_HAVE_NO_MEMORY(m);
-       
-       m->state   = state;
-       m->msg     = msg;
-       m->server  = server;
-       m->handler = handler;
-       DLIST_ADD(state->list, m);
-
-       talloc_set_destructor(m, cluster_messaging_destructor);
-
+       /* nothing to do - we're now using the wildcard message handler */
        return NT_STATUS_OK;
 }
 
@@ -198,7 +156,7 @@ static struct cluster_ops cluster_ctdb_ops = {
 };
 
 /* initialise ctdb */
-void cluster_ctdb_init(struct event_context *ev)
+void cluster_ctdb_init(struct event_context *ev, const char *model)
 {
        const char *nlist;
        const char *address;
@@ -240,6 +198,11 @@ void cluster_ctdb_init(struct event_context *ev)
                ctdb_set_flags(state->ctdb, CTDB_FLAG_SELF_CONNECT);
        }
 
+       if (strcmp(model, "single") != 0) {
+               DEBUG(0,("Enabling ctdb daemon mode\n"));
+               ctdb_set_flags(state->ctdb, CTDB_FLAG_DAEMON_MODE);
+       }
+
        lacount = lp_parm_int(-1, "ctdb", "maxlacount", -1);
        if (lacount != -1) {
                ctdb_set_max_lacount(state->ctdb, lacount);
@@ -267,6 +230,15 @@ void cluster_ctdb_init(struct event_context *ev)
                if (ctdb_db == NULL) goto failed;
        }
 
+       /* setup a global message handler */
+       ret = ctdb_set_message_handler(state->ctdb, CTDB_SRVID_ALL, 
+                                      ctdb_message_handler, state);
+        if (ret == -1) {
+                DEBUG(0,("ctdb_set_message_handler failed - %s\n", 
+                        ctdb_errstr(state->ctdb)));
+               exit(1);
+        }
+
        /* start the protocol running */
        ret = ctdb_start(state->ctdb);
         if (ret == -1) {
@@ -275,7 +247,7 @@ void cluster_ctdb_init(struct event_context *ev)
         }
 
        /* wait until all nodes are connected (should not be needed
-          outide of test code) */
+          outside of test code) */
        ctdb_connect_wait(state->ctdb);
 
        cluster_set_ops(&cluster_ctdb_ops);
@@ -286,3 +258,4 @@ failed:
        DEBUG(0,("cluster_ctdb_init failed\n"));
        talloc_free(state);
 }
+
index 5f93df960c79ae38983cbd5b003bb5344836239f..a602ee73f8e4ce39e263a2eefb3016a5cf6a1793 100644 (file)
@@ -20,4 +20,4 @@
    Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 */
 
-void cluster_ctdb_init(struct event_context *ev);
+void cluster_ctdb_init(struct event_context *ev, const char *model);
diff --git a/source/cluster/ctdb/tests/cmdline.c b/source/cluster/ctdb/tests/cmdline.c
new file mode 100644 (file)
index 0000000..57829b9
--- /dev/null
@@ -0,0 +1,102 @@
+/* 
+   common commandline code to ctdb test tools
+
+   Copyright (C) Andrew Tridgell  2007
+
+   This library is free software; you can redistribute it and/or
+   modify it under the terms of the GNU Lesser General Public
+   License as published by the Free Software Foundation; either
+   version 2 of the License, or (at your option) any later version.
+
+   This library is distributed in the hope that it will be useful,
+   but WITHOUT ANY WARRANTY; without even the implied warranty of
+   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+   Lesser General Public License for more details.
+
+   You should have received a copy of the GNU Lesser General Public
+   License along with this library; if not, write to the Free Software
+   Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
+*/
+
+#include "includes.h"
+#include "lib/events/events.h"
+#include "system/filesys.h"
+#include "popt.h"
+
+/* Handle common command line options for ctdb test progs
+ */
+
+static struct {
+       const char *nlist;
+       const char *transport;
+       const char *myaddress;
+       int self_connect;
+       int daemon_mode;
+} ctdb_cmdline = {
+       .nlist = NULL,
+       .transport = "tcp",
+       .myaddress = NULL,
+       .self_connect = 0,
+       .daemon_mode = 0
+};
+
+
+struct poptOption popt_ctdb_cmdline[] = {
+       { "nlist", 0, POPT_ARG_STRING, &ctdb_cmdline.nlist, 0, "node list file", "filename" },
+       { "listen", 0, POPT_ARG_STRING, &ctdb_cmdline.myaddress, 0, "address to listen on", "address" },
+       { "transport", 0, POPT_ARG_STRING, &ctdb_cmdline.transport, 0, "protocol transport", NULL },
+       { "self-connect", 0, POPT_ARG_NONE, &ctdb_cmdline.self_connect, 0, "enable self connect", "boolean" },
+       { "daemon", 0, POPT_ARG_NONE, &ctdb_cmdline.daemon_mode, 0, "spawn a ctdb daemon", "boolean" },
+       { NULL }
+};
+
+
+/*
+  startup daemon side of ctdb according to command line options
+ */
+struct ctdb_context *ctdb_cmdline_init(struct event_context *ev)
+{
+       struct ctdb_context *ctdb;
+       int ret;
+
+       if (ctdb_cmdline.nlist == NULL || ctdb_cmdline.myaddress == NULL) {
+               printf("You must provide a node list with --nlist and an address with --listen\n");
+               exit(1);
+       }
+
+       /* initialise ctdb */
+       ctdb = ctdb_init(ev);
+       if (ctdb == NULL) {
+               printf("Failed to init ctdb\n");
+               exit(1);
+       }
+
+       if (ctdb_cmdline.self_connect) {
+               ctdb_set_flags(ctdb, CTDB_FLAG_SELF_CONNECT);
+       }
+       if (ctdb_cmdline.daemon_mode) {
+               ctdb_set_flags(ctdb, CTDB_FLAG_DAEMON_MODE);
+       }
+
+       ret = ctdb_set_transport(ctdb, ctdb_cmdline.transport);
+       if (ret == -1) {
+               printf("ctdb_set_transport failed - %s\n", ctdb_errstr(ctdb));
+               exit(1);
+       }
+
+       /* tell ctdb what address to listen on */
+       ret = ctdb_set_address(ctdb, ctdb_cmdline.myaddress);
+       if (ret == -1) {
+               printf("ctdb_set_address failed - %s\n", ctdb_errstr(ctdb));
+               exit(1);
+       }
+
+       /* tell ctdb what nodes are available */
+       ret = ctdb_set_nlist(ctdb, ctdb_cmdline.nlist);
+       if (ret == -1) {
+               printf("ctdb_set_nlist failed - %s\n", ctdb_errstr(ctdb));
+               exit(1);
+       }
+
+       return ctdb;
+}
diff --git a/source/cluster/ctdb/tests/cmdline.h b/source/cluster/ctdb/tests/cmdline.h
new file mode 100644 (file)
index 0000000..785595e
--- /dev/null
@@ -0,0 +1,7 @@
+
+extern struct poptOption popt_ctdb_cmdline[];
+
+#define POPT_CTDB_CMDLINE { NULL, 0, POPT_ARG_INCLUDE_TABLE, popt_ctdb_cmdline, 0, "Common ctdb test options:", NULL },
+
+struct ctdb_context *ctdb_cmdline_init(struct event_context *ev);
+
index 78d66f6f2cc2af8a2e65c1479aa767ec42d9a792..37c095c0c0410a828c3f8cdb0ca6fc2abc5f94c7 100644 (file)
@@ -22,6 +22,7 @@
 #include "lib/events/events.h"
 #include "system/filesys.h"
 #include "popt.h"
+#include "tests/cmdline.h"
 
 #include <sys/time.h>
 #include <time.h>
@@ -196,19 +197,10 @@ int main(int argc, const char *argv[])
 {
        struct ctdb_context *ctdb;
        struct ctdb_db_context *ctdb_db;
-       const char *nlist = NULL;
-       const char *transport = "tcp";
-       const char *myaddress = NULL;
-       int self_connect=0;
-       int daemon_mode=0;
 
        struct poptOption popt_options[] = {
                POPT_AUTOHELP
-               { "nlist", 0, POPT_ARG_STRING, &nlist, 0, "node list file", "filename" },
-               { "listen", 0, POPT_ARG_STRING, &myaddress, 0, "address to listen on", "address" },
-               { "transport", 0, POPT_ARG_STRING, &transport, 0, "protocol transport", NULL },
-               { "self-connect", 0, POPT_ARG_NONE, &self_connect, 0, "enable self connect", "boolean" },
-               { "daemon", 0, POPT_ARG_NONE, &daemon_mode, 0, "spawn a ctdb daemon", "boolean" },
+               POPT_CTDB_CMDLINE
                { "timelimit", 't', POPT_ARG_INT, &timelimit, 0, "timelimit", "integer" },
                { "num-records", 'r', POPT_ARG_INT, &num_records, 0, "num_records", "integer" },
                { "num-msgs", 'n', POPT_ARG_INT, &num_msgs, 0, "num_msgs", "integer" },
@@ -239,46 +231,10 @@ int main(int argc, const char *argv[])
                while (extra_argv[extra_argc]) extra_argc++;
        }
 
-       if (nlist == NULL || myaddress == NULL) {
-               printf("You must provide a node list with --nlist and an address with --listen\n");
-               exit(1);
-       }
-
        ev = event_context_init(NULL);
 
        /* initialise ctdb */
-       ctdb = ctdb_init(ev);
-       if (ctdb == NULL) {
-               printf("Failed to init ctdb\n");
-               exit(1);
-       }
-
-       if (self_connect) {
-               ctdb_set_flags(ctdb, CTDB_FLAG_SELF_CONNECT);
-       }
-       if (daemon_mode) {
-               ctdb_set_flags(ctdb, CTDB_FLAG_DAEMON_MODE);
-       }
-
-       ret = ctdb_set_transport(ctdb, transport);
-       if (ret == -1) {
-               printf("ctdb_set_transport failed - %s\n", ctdb_errstr(ctdb));
-               exit(1);
-       }
-
-       /* tell ctdb what address to listen on */
-       ret = ctdb_set_address(ctdb, myaddress);
-       if (ret == -1) {
-               printf("ctdb_set_address failed - %s\n", ctdb_errstr(ctdb));
-               exit(1);
-       }
-
-       /* tell ctdb what nodes are available */
-       ret = ctdb_set_nlist(ctdb, nlist);
-       if (ret == -1) {
-               printf("ctdb_set_nlist failed - %s\n", ctdb_errstr(ctdb));
-               exit(1);
-       }
+       ctdb = ctdb_cmdline_init(ev);
 
        /* attach to a specific database */
        ctdb_db = ctdb_attach(ctdb, "test.tdb", TDB_DEFAULT, O_RDWR|O_CREAT|O_TRUNC, 0666);
index 45e5248980045aa9dec5e6a38cc09a350e3c6bf2..febaf13fe406fd17af0b54cfae87d7efcb044023 100644 (file)
@@ -22,6 +22,7 @@
 #include "lib/events/events.h"
 #include "system/filesys.h"
 #include "popt.h"
+#include "tests/cmdline.h"
 
 #include <sys/time.h>
 #include <time.h>
@@ -163,19 +164,10 @@ int main(int argc, const char *argv[])
 {
        struct ctdb_context *ctdb;
        struct ctdb_db_context *ctdb_db;
-       const char *nlist = NULL;
-       const char *transport = "tcp";
-       const char *myaddress = NULL;
-       int self_connect=0;
-       int daemon_mode=0;
 
        struct poptOption popt_options[] = {
                POPT_AUTOHELP
-               { "nlist", 0, POPT_ARG_STRING, &nlist, 0, "node list file", "filename" },
-               { "listen", 0, POPT_ARG_STRING, &myaddress, 0, "address to listen on", "address" },
-               { "transport", 0, POPT_ARG_STRING, &transport, 0, "protocol transport", NULL },
-               { "self-connect", 0, POPT_ARG_NONE, &self_connect, 0, "enable self connect", "boolean" },
-               { "daemon", 0, POPT_ARG_NONE, &daemon_mode, 0, "spawn a ctdb daemon", "boolean" },
+               POPT_CTDB_CMDLINE
                { "timelimit", 't', POPT_ARG_INT, &timelimit, 0, "timelimit", "integer" },
                { "num-records", 'r', POPT_ARG_INT, &num_records, 0, "num_records", "integer" },
                { "num-msgs", 'n', POPT_ARG_INT, &num_msgs, 0, "num_msgs", "integer" },
@@ -207,46 +199,9 @@ int main(int argc, const char *argv[])
                while (extra_argv[extra_argc]) extra_argc++;
        }
 
-       if (nlist == NULL || myaddress == NULL) {
-               printf("You must provide a node list with --nlist and an address with --listen\n");
-               exit(1);
-       }
-
        ev = event_context_init(NULL);
 
-       /* initialise ctdb */
-       ctdb = ctdb_init(ev);
-       if (ctdb == NULL) {
-               printf("Failed to init ctdb\n");
-               exit(1);
-       }
-
-       if (self_connect) {
-               ctdb_set_flags(ctdb, CTDB_FLAG_SELF_CONNECT);
-       }
-       if (daemon_mode) {
-               ctdb_set_flags(ctdb, CTDB_FLAG_DAEMON_MODE);
-       }
-
-       ret = ctdb_set_transport(ctdb, transport);
-       if (ret == -1) {
-               printf("ctdb_set_transport failed - %s\n", ctdb_errstr(ctdb));
-               exit(1);
-       }
-
-       /* tell ctdb what address to listen on */
-       ret = ctdb_set_address(ctdb, myaddress);
-       if (ret == -1) {
-               printf("ctdb_set_address failed - %s\n", ctdb_errstr(ctdb));
-               exit(1);
-       }
-
-       /* tell ctdb what nodes are available */
-       ret = ctdb_set_nlist(ctdb, nlist);
-       if (ret == -1) {
-               printf("ctdb_set_nlist failed - %s\n", ctdb_errstr(ctdb));
-               exit(1);
-       }
+       ctdb = ctdb_cmdline_init(ev);
 
        /* attach to a specific database */
        ctdb_db = ctdb_attach(ctdb, "test.tdb", TDB_DEFAULT, O_RDWR|O_CREAT|O_TRUNC, 0666);
index 8071256a43e5c0fe4f6d9f67aff12c9f93bae97f..ffe9c7c94696aa73ae1c6c5fa00f8d13a71b8bdd 100644 (file)
@@ -24,6 +24,7 @@
 #include "popt.h"
 #include "ctdb.h"
 #include "ctdb_private.h"
+#include "tests/cmdline.h"
 
 #define PARENT_SRVID   0
 #define CHILD1_SRVID   1
@@ -109,20 +110,11 @@ int main(int argc, const char *argv[])
 {
        struct ctdb_context *ctdb;
        struct ctdb_db_context *ctdb_db;
-       const char *nlist = NULL;
-       const char *transport = "tcp";
-       const char *myaddress = NULL;
-       int self_connect=0;
-       int daemon_mode=0;
        TDB_DATA data;
 
        struct poptOption popt_options[] = {
                POPT_AUTOHELP
-               { "nlist", 0, POPT_ARG_STRING, &nlist, 0, "node list file", "filename" },
-               { "listen", 0, POPT_ARG_STRING, &myaddress, 0, "address to listen on", "address" },
-               { "transport", 0, POPT_ARG_STRING, &transport, 0, "protocol transport", NULL },
-               { "self-connect", 0, POPT_ARG_NONE, &self_connect, 0, "enable self connect", "boolean" },
-               { "daemon", 0, POPT_ARG_NONE, &daemon_mode, 0, "spawn a ctdb daemon", "boolean" },
+               POPT_CTDB_CMDLINE
                POPT_TABLEEND
        };
        int opt;
@@ -150,47 +142,15 @@ int main(int argc, const char *argv[])
                while (extra_argv[extra_argc]) extra_argc++;
        }
 
-       if (nlist == NULL || myaddress == NULL) {
-               printf("You must provide a node list with --nlist and an address with --listen\n");
-               exit(1);
-       }
-
        ev = event_context_init(NULL);
 
        /* initialise ctdb */
-       ctdb = ctdb_init(ev);
+       ctdb = ctdb_cmdline_init(ev);
        if (ctdb == NULL) {
                printf("Failed to init ctdb\n");
                exit(1);
        }
 
-       if (self_connect) {
-               ctdb_set_flags(ctdb, CTDB_FLAG_SELF_CONNECT);
-       }
-       if (daemon_mode) {
-               ctdb_set_flags(ctdb, CTDB_FLAG_DAEMON_MODE);
-       }
-
-       ret = ctdb_set_transport(ctdb, transport);
-       if (ret == -1) {
-               printf("ctdb_set_transport failed - %s\n", ctdb_errstr(ctdb));
-               exit(1);
-       }
-
-       /* tell ctdb what address to listen on */
-       ret = ctdb_set_address(ctdb, myaddress);
-       if (ret == -1) {
-               printf("ctdb_set_address failed - %s\n", ctdb_errstr(ctdb));
-               exit(1);
-       }
-
-       /* tell ctdb what nodes are available */
-       ret = ctdb_set_nlist(ctdb, nlist);
-       if (ret == -1) {
-               printf("ctdb_set_nlist failed - %s\n", ctdb_errstr(ctdb));
-               exit(1);
-       }
-
        /* attach to a specific database */
        ctdb_db = ctdb_attach(ctdb, "test.tdb", TDB_DEFAULT, O_RDWR|O_CREAT|O_TRUNC, 0666);
        if (!ctdb_db) {
index 050f14de380e9cd187963027415da017c0ec4340..d02c2116e80c4e69220da1b0055aef2ec62d0afb 100644 (file)
 #include "lib/events/events.h"
 #include "system/filesys.h"
 #include "popt.h"
+#include "tests/cmdline.h"
 
 static int timelimit = 10;
 static int num_records = 10;
 static int num_msgs = 1;
-static int num_repeats = 100;
 static int num_clients = 2;
 
 
@@ -47,20 +47,11 @@ int main(int argc, const char *argv[])
 {
        struct ctdb_context *ctdb;
        struct ctdb_db_context *ctdb_db;
-       const char *nlist = NULL;
-       const char *transport = "tcp";
-       const char *myaddress = NULL;
-       int self_connect=0;
-       int daemon_mode=0;
        char buf[256];
 
        struct poptOption popt_options[] = {
                POPT_AUTOHELP
-               { "nlist", 0, POPT_ARG_STRING, &nlist, 0, "node list file", "filename" },
-               { "listen", 0, POPT_ARG_STRING, &myaddress, 0, "address to listen on", "address" },
-               { "transport", 0, POPT_ARG_STRING, &transport, 0, "protocol transport", NULL },
-               { "self-connect", 0, POPT_ARG_NONE, &self_connect, 0, "enable self connect", "boolean" },
-               { "daemon", 0, POPT_ARG_NONE, &daemon_mode, 0, "spawn a ctdb daemon", "boolean" },
+               POPT_CTDB_CMDLINE
                { "timelimit", 't', POPT_ARG_INT, &timelimit, 0, "timelimit", "integer" },
                { "num-records", 'r', POPT_ARG_INT, &num_records, 0, "num_records", "integer" },
                { "num-msgs", 'n', POPT_ARG_INT, &num_msgs, 0, "num_msgs", "integer" },
@@ -95,47 +86,15 @@ int main(int argc, const char *argv[])
                while (extra_argv[extra_argc]) extra_argc++;
        }
 
-       if (nlist == NULL || myaddress == NULL) {
-               printf("You must provide a node list with --nlist and an address with --listen\n");
-               exit(1);
-       }
-
        ev = event_context_init(NULL);
 
        /* initialise ctdb */
-       ctdb = ctdb_init(ev);
+       ctdb = ctdb_cmdline_init(ev);
        if (ctdb == NULL) {
                printf("Failed to init ctdb\n");
                exit(1);
        }
 
-       if (self_connect) {
-               ctdb_set_flags(ctdb, CTDB_FLAG_SELF_CONNECT);
-       }
-       if (daemon_mode) {
-               ctdb_set_flags(ctdb, CTDB_FLAG_DAEMON_MODE);
-       }
-
-       ret = ctdb_set_transport(ctdb, transport);
-       if (ret == -1) {
-               printf("ctdb_set_transport failed - %s\n", ctdb_errstr(ctdb));
-               exit(1);
-       }
-
-       /* tell ctdb what address to listen on */
-       ret = ctdb_set_address(ctdb, myaddress);
-       if (ret == -1) {
-               printf("ctdb_set_address failed - %s\n", ctdb_errstr(ctdb));
-               exit(1);
-       }
-
-       /* tell ctdb what nodes are available */
-       ret = ctdb_set_nlist(ctdb, nlist);
-       if (ret == -1) {
-               printf("ctdb_set_nlist failed - %s\n", ctdb_errstr(ctdb));
-               exit(1);
-       }
-
        /* attach to a specific database */
        ctdb_db = ctdb_attach(ctdb, "test.tdb", TDB_DEFAULT, O_RDWR|O_CREAT|O_TRUNC, 0666);
        if (!ctdb_db) {
index 62c7d1c5529e549d7efb12635a7efd5ed281b9b7..8125cc44904ca497c069e4e20b1e634fb9f1ce87 100644 (file)
@@ -22,6 +22,7 @@
 #include "lib/events/events.h"
 #include "system/filesys.h"
 #include "popt.h"
+#include "tests/cmdline.h"
 
 enum my_functions {FUNC_SORT=1, FUNC_FETCH=2};
 
@@ -77,19 +78,10 @@ int main(int argc, const char *argv[])
 {
        struct ctdb_context *ctdb;
        struct ctdb_db_context *ctdb_db;
-       const char *nlist = NULL;
-       const char *transport = "tcp";
-       const char *myaddress = NULL;
-       int self_connect=0;
-       int daemon_mode=0;
 
        struct poptOption popt_options[] = {
                POPT_AUTOHELP
-               { "nlist", 0, POPT_ARG_STRING, &nlist, 0, "node list file", "filename" },
-               { "listen", 0, POPT_ARG_STRING, &myaddress, 0, "address to listen on", "address" },
-               { "transport", 0, POPT_ARG_STRING, &transport, 0, "protocol transport", NULL },
-               { "self-connect", 0, POPT_ARG_NONE, &self_connect, 0, "enable self connect", "boolean" },
-               { "daemon", 0, POPT_ARG_NONE, &daemon_mode, 0, "spawn a ctdb daemon", "boolean" },
+               POPT_CTDB_CMDLINE
                POPT_TABLEEND
        };
        int opt;
@@ -118,55 +110,15 @@ int main(int argc, const char *argv[])
                while (extra_argv[extra_argc]) extra_argc++;
        }
 
-       if (nlist == NULL || myaddress == NULL) {
-               printf("You must provide a node list with --nlist and an address with --listen\n");
-               exit(1);
-       }
-
        ev = event_context_init(NULL);
 
        /* initialise ctdb */
-       ctdb = ctdb_init(ev);
+       ctdb = ctdb_cmdline_init(ev);
        if (ctdb == NULL) {
                printf("Failed to init ctdb\n");
                exit(1);
        }
 
-       if (self_connect) {
-               ctdb_set_flags(ctdb, CTDB_FLAG_SELF_CONNECT);
-       }
-
-       if (daemon_mode) {
-               ctdb_set_flags(ctdb, CTDB_FLAG_DAEMON_MODE);
-       }
-
-       /* this flag is only used by test code and it makes ctdb_start() block until all
-          nodes have connected.
-          until we do better recovery and cluster rebuild it is probably good to use this flag
-          in applications.
-        */
-       ctdb_set_flags(ctdb, CTDB_FLAG_CONNECT_WAIT);
-
-       ret = ctdb_set_transport(ctdb, transport);
-       if (ret == -1) {
-               printf("ctdb_set_transport failed - %s\n", ctdb_errstr(ctdb));
-               exit(1);
-       }
-
-       /* tell ctdb what address to listen on */
-       ret = ctdb_set_address(ctdb, myaddress);
-       if (ret == -1) {
-               printf("ctdb_set_address failed - %s\n", ctdb_errstr(ctdb));
-               exit(1);
-       }
-
-       /* tell ctdb what nodes are available */
-       ret = ctdb_set_nlist(ctdb, nlist);
-       if (ret == -1) {
-               printf("ctdb_set_nlist failed - %s\n", ctdb_errstr(ctdb));
-               exit(1);
-       }
-
        /* attach to a specific database */
        ctdb_db = ctdb_attach(ctdb, "test.tdb", TDB_DEFAULT, O_RDWR|O_CREAT|O_TRUNC, 0666);
        if (!ctdb_db) {