r12528: Add seperate proto headers for ntvfs, tdr, smb_server and nbt_server.
authorJelmer Vernooij <jelmer@samba.org>
Tue, 27 Dec 2005 22:51:30 +0000 (22:51 +0000)
committerGerald (Jerry) Carter <jerry@samba.org>
Wed, 10 Oct 2007 18:47:51 +0000 (13:47 -0500)
38 files changed:
source/build/smb_build/TODO
source/include/includes.h
source/include/structs.h
source/lib/basic.mk
source/lib/registry/common/reg_interface.c
source/lib/registry/patchfile.c
source/lib/tdr/tdr.c
source/lib/tdr/tdr.h
source/main.mk
source/nbt_server/config.mk
source/nbt_server/nbt_server.h
source/ntvfs/cifs/vfs_cifs.c
source/ntvfs/config.mk
source/ntvfs/ipc/vfs_ipc.c
source/ntvfs/nbench/vfs_nbench.c
source/ntvfs/ntvfs.h
source/ntvfs/ntvfs_base.c
source/ntvfs/ntvfs_generic.c
source/ntvfs/ntvfs_interface.c
source/ntvfs/ntvfs_util.c
source/ntvfs/posix/vfs_posix.h
source/ntvfs/print/vfs_print.c
source/ntvfs/simple/svfs_util.c
source/ntvfs/simple/vfs_simple.c
source/ntvfs/unixuid/vfs_unixuid.c
source/pidl/lib/Parse/Pidl/Samba4/TDR.pm
source/script/mkproto.pl
source/smb_server/config.mk
source/smb_server/smb/nttrans.c
source/smb_server/smb/receive.c
source/smb_server/smb/reply.c
source/smb_server/smb/request.c
source/smb_server/smb/search.c
source/smb_server/smb/service.c
source/smb_server/smb/trans2.c
source/smb_server/smb_server.h
source/smb_server/tcon.c
source/smbd/server.c

index 1c2e6c2f61a0eefcb93ddbd05a1337b9985729a5..6c45e6e6b24cbd37c2d2867c206377dfacf5b1c8 100644 (file)
@@ -11,3 +11,4 @@
  - utility function for 'init mutex'
 - install shared modules
 - improve (un)install scripts (rewrite in perl?)
+- proper #include dependencies
index 2222b4ff430ec3fa0065e10ab8ee264329927784..a8aecc36102d6907e56724f8c4c7d6bbe1b5681c 100644 (file)
@@ -101,7 +101,6 @@ struct ipv4_addr {
 #include "smb_macros.h"
 #include "smb.h"
 #include "byteorder.h"
-#include "lib/tdr/tdr.h"
 #include "librpc/ndr/libndr.h"
 #include "librpc/gen_ndr/misc.h"
 #include "librpc/gen_ndr/dcerpc.h"
@@ -109,13 +108,13 @@ struct ipv4_addr {
 #include "librpc/gen_ndr/orpc.h"
 #include "librpc/rpc/dcerpc.h"
 #include "smb_interfaces.h"
-#include "ntvfs/ntvfs.h"
 #include "cli_context.h"
 #include "auth/credentials/credentials.h"
 
 /***** automatically generated prototypes *****/
 #define _PRINTF_ATTRIBUTE(a1, a2) PRINTF_ATTRIBUTE(a1, a2)
 #include "include/proto.h"
+#include "basic.h"
 #undef _PRINTF_ATTRIBUTE
 #define _PRINTF_ATTRIBUTE(a1, a2)
 
index 153902d13a2e9d255d037a2a8b9db627c212edbb..2187fcd8ba860304c51f9f1ed8c5cc06b8de0106 100644 (file)
@@ -157,7 +157,6 @@ struct request_buffer;
 struct smb2srv_request;
 struct smb2_request_buffer;
 
-struct ntvfs_context;
 struct ntvfs_module_context;
 
 struct pvfs_dir;
@@ -267,14 +266,10 @@ struct task_server;
 struct model_ops;
 struct stream_server_ops;
 
-struct nbtd_server;
-struct nbtd_interface;
-struct nbtd_iface_name;
 struct wins_server;
 struct nbtd_proxy_wins_challenge;
 struct nbtd_proxy_wins_release_demand;
 
-struct nbt_iface_name;
 struct nbt_dc_name;
 struct wb_sid_object;
 struct wb_dom_info;
@@ -373,3 +368,6 @@ struct IUnknown_vtable;
 struct MprVar;
 
 struct registry_context;
+struct nbtd_interface;
+struct nbtd_iface_name;
+struct nbtd_server;
index 4d2d1b08fdd2379f3cc0cbcf489b8de8ab01b814..b4bde76d3f61cbff99fd2040714fcc00570c0d99 100644 (file)
@@ -32,6 +32,7 @@ MAJOR_VERSION = 0
 MINOR_VERSION = 0
 RELEASE_VERSION = 1
 DESCRIPTION = Simple marshall/unmarshall library
+PRIVATE_PROTO_HEADER = tdr/tdr_proto.h
 OBJ_FILES = tdr/tdr.o
 
 ##############################
@@ -62,6 +63,7 @@ OBJ_FILES = \
 ##############################
 # Start SUBSYSTEM LIBBASIC
 [SUBSYSTEM::LIBBASIC]
+PRIVATE_PROTO_HEADER = basic.h
 OBJ_FILES = version.o \
                xfile.o \
                debug.o \
index b0540c1ba424efe183d1e53e06f89277dbd94feb..00fa42d34277366df98af09da69c8950d9a809d3 100644 (file)
@@ -29,7 +29,7 @@ static struct reg_init_function_entry *backends = NULL;
 static struct reg_init_function_entry *reg_find_backend_entry(const char *name);
 
 /* Register new backend */
-NTSTATUS registry_register(const void *_hive_ops)  
+_PUBLIC_ NTSTATUS registry_register(const void *_hive_ops)  
 {
        const struct hive_operations *hive_ops = _hive_ops;
        struct reg_init_function_entry *entry = backends;
@@ -65,7 +65,7 @@ static struct reg_init_function_entry *reg_find_backend_entry(const char *name)
        return NULL;
 }
 
-NTSTATUS registry_init(void)
+_PUBLIC_ NTSTATUS registry_init(void)
 {
        init_module_fn static_init[] = STATIC_REGISTRY_MODULES;
        init_module_fn *shared_init = load_samba_modules(NULL, "registry");
@@ -101,7 +101,7 @@ static struct {
        { 0, NULL }
 };
 
-int reg_list_predefs(TALLOC_CTX *mem_ctx, char ***predefs, uint32_t **hkeys)
+_PUBLIC_ int reg_list_predefs(TALLOC_CTX *mem_ctx, char ***predefs, uint32_t **hkeys)
 {
        int i;
        *predefs = talloc_array(mem_ctx, char *, ARRAY_SIZE(predef_names));
@@ -151,7 +151,7 @@ WERROR reg_get_predefined_key(struct registry_context *ctx, uint32_t hkey, struc
 }
 
 /* Open a registry file/host/etc */
-WERROR reg_open_hive(TALLOC_CTX *parent_ctx, const char *backend, const char *location, const char *credentials, struct registry_key **root)
+_PUBLIC_ WERROR reg_open_hive(TALLOC_CTX *parent_ctx, const char *backend, const char *location, const char *credentials, struct registry_key **root)
 {
        struct registry_hive *rethive;
        struct registry_key *retkey = NULL;
@@ -200,7 +200,7 @@ WERROR reg_open_hive(TALLOC_CTX *parent_ctx, const char *backend, const char *lo
  * First tries to use the open_key function from the backend
  * then falls back to get_subkey_by_name and later get_subkey_by_index 
  */
-WERROR reg_open_key(TALLOC_CTX *mem_ctx, struct registry_key *parent, const char *name, struct registry_key **result)
+_PUBLIC_ WERROR reg_open_key(TALLOC_CTX *mem_ctx, struct registry_key *parent, const char *name, struct registry_key **result)
 {
        WERROR error;
 
@@ -251,7 +251,7 @@ WERROR reg_open_key(TALLOC_CTX *mem_ctx, struct registry_key *parent, const char
        return WERR_OK;
 }
 
-WERROR reg_key_get_value_by_index(TALLOC_CTX *mem_ctx, const struct registry_key *key, int idx, struct registry_value **val)
+_PUBLIC_ WERROR reg_key_get_value_by_index(TALLOC_CTX *mem_ctx, const struct registry_key *key, int idx, struct registry_value **val)
 {
        if(!key) return WERR_INVALID_PARAM;
 
@@ -434,7 +434,7 @@ WERROR reg_key_add_name(TALLOC_CTX *mem_ctx, const struct registry_key *parent,
        return WERR_OK;
 }
 
-WERROR reg_val_set(struct registry_key *key, const char *value, uint32_t type, DATA_BLOB data)
+_PUBLIC_ WERROR reg_val_set(struct registry_key *key, const char *value, uint32_t type, DATA_BLOB data)
 {
        /* A 'real' set function has preference */
        if (key->hive->functions->set_value) 
@@ -455,7 +455,7 @@ WERROR reg_get_sec_desc(TALLOC_CTX *ctx, const struct registry_key *key, struct
        return WERR_NOT_SUPPORTED;
 }
 
-WERROR reg_del_value(const struct registry_key *key, const char *valname)
+_PUBLIC_ WERROR reg_del_value(const struct registry_key *key, const char *valname)
 {
        WERROR ret = WERR_OK;
        if(!key->hive->functions->del_value)
index dd118c780f070dd7c41018227e281840250812a6..21c9c26b2162617a66f731e82a6de5543e61a3c5 100644 (file)
@@ -173,7 +173,7 @@ static WERROR reg_generate_diff_key(struct reg_diff *diff, struct registry_key *
 /* 
  * Generate diff between two registry contexts 
  */
-struct reg_diff *reg_generate_diff(TALLOC_CTX *mem_ctx, struct registry_context *ctx1, struct registry_context *ctx2)
+_PUBLIC_ struct reg_diff *reg_generate_diff(TALLOC_CTX *mem_ctx, struct registry_context *ctx1, struct registry_context *ctx2)
 {
        struct reg_diff *diff = talloc_zero(mem_ctx, struct reg_diff);
        int i;
@@ -202,7 +202,7 @@ struct reg_diff *reg_generate_diff(TALLOC_CTX *mem_ctx, struct registry_context
 /*
  * Save registry diff
  */
-WERROR reg_diff_save(const struct reg_diff *diff, const char *filename)
+_PUBLIC_ WERROR reg_diff_save(const struct reg_diff *diff, const char *filename)
 {
        int xf, i, j;
 
@@ -363,7 +363,7 @@ struct reg_diff *reg_diff_load(TALLOC_CTX *ctx, const char *fn)
 /* 
  * Apply diff to a registry context 
  */
-BOOL reg_diff_apply (const struct reg_diff *diff, struct registry_context *ctx)
+_PUBLIC_ BOOL reg_diff_apply (const struct reg_diff *diff, struct registry_context *ctx)
 {
        TALLOC_CTX *mem_ctx = talloc_init("apply_cmd_file");
        struct registry_key *tmp = NULL;
index 4a8d05a8abc94ac6b919dd3d2ddfd6a560c1ea0c..5ebe3f0852306c11ece285a0ca29ff921bab6ebd 100644 (file)
@@ -24,6 +24,7 @@
 #include "includes.h"
 #include "system/network.h"
 #include "system/filesys.h"
+#include "tdr/tdr.h"
 
 #define TDR_BASE_MARSHALL_SIZE 1024
 
index f882a632750516e583e71d083a218ea28203084b..8ca6717ceeae4784585d8e6545a85395b5a23d3b 100644 (file)
@@ -54,3 +54,5 @@ struct tdr_print {
 
 typedef NTSTATUS (*tdr_push_fn_t) (struct tdr_push *, const void *);
 typedef NTSTATUS (*tdr_pull_fn_t) (struct tdr_pull *, TALLOC_CTX *, void *);
+
+#include "tdr/tdr_proto.h"
index b185ec97e4c0c8e0f5b11b7b5f1fbdb7c9d94f11..d21d57b790c8323f79673c803473e0a4ede5a029 100644 (file)
@@ -215,9 +215,9 @@ clean_pch:
 
 basics: include/config.h \
        include/proto.h \
+       $(PROTO_HEADERS) \
        idl \
-       heimdal_basics \
-       $(PROTO_HEADERS)
+       heimdal_basics
 
 clean: heimdal_clean
        @echo Removing headers
index 24e69eb52e5615158bf43601e40d6e956cfde58f..61d2a7a3d60e723a591e5dd5c77f0c457424ec9b 100644 (file)
@@ -47,6 +47,7 @@ OBJ_FILES = \
                defense.o \
                packet.o \
                irpc.o
+PRIVATE_PROTO_HEADER = nbt_server_proto.h
 REQUIRED_SUBSYSTEMS = \
                LIBCLI_NBT NBTD_WINS NBTD_DGRAM
 # End SUBSYSTEM NBTD
index 71e384bd2cd8d8d875ce39e62a6498512f44f745..9203f20fd91512041ee4785990d5448fab660ed3 100644 (file)
@@ -86,3 +86,5 @@ struct nbtd_server {
                return; \
        } \
 } while (0)
+
+#include "nbt_server/nbt_server_proto.h"
index b0d0d0655227d007a39d9dbb019f3d6487a56846..16a472104b73abd226ce829a047356bc177cb9b7 100644 (file)
@@ -33,6 +33,7 @@
 #include "smb_server/smb_server.h"
 #include "smbd/service_stream.h"
 #include "auth/auth.h"
+#include "ntvfs/ntvfs.h"
 
 /* this is stored in ntvfs_private */
 struct cvfs_private {
index bc39d8215682e17a3492aeb276ef8802e09bdacd..74b62809f7e55bac6581d5bf4b63498c76fa9d59 100644 (file)
@@ -77,6 +77,7 @@ PUBLIC_HEADERS = ntvfs.h
 MAJOR_VERSION = 0
 MINOR_VERSION = 0
 DESCRIPTION = Virtual File System with NTFS semantics
+PRIVATE_PROTO_HEADER = ntvfs_proto.h
 RELEASE_VERSION = 1
 OBJ_FILES = \
                ntvfs_base.o \
index 3f91323fe512238c12acd051cc43a834dc5afce7..3a643d71458dab8c07a6d3f178bddbef3e411763 100644 (file)
@@ -29,6 +29,7 @@
 #include "system/filesys.h"
 #include "dlinklist.h"
 #include "smb_server/smb_server.h"
+#include "ntvfs/ntvfs.h"
 
 #define IPC_BASE_FNUM 0x400
 
index acfa6313d371a5334733f9196a68a479f0ed387c..3c95621694ba239943efca8eb45e7e6262a256bc 100644 (file)
@@ -27,6 +27,7 @@
 #include "includes.h"
 #include "system/filesys.h"
 #include "smb_server/smb_server.h"
+#include "ntvfs/ntvfs.h"
 
 /* this is stored in ntvfs_private */
 struct nbench_private {
index 3a6a78c032750b75c744016ee6b6a0d11d13b507..4ec8926ebcce1c1d2cd434f197db9d0c9832c845 100644 (file)
@@ -180,3 +180,5 @@ struct ntvfs_critical_sizes {
        int sizeof_smbsrv_tcon;
        int sizeof_smbsrv_request;
 };
+
+#include "ntvfs/ntvfs_proto.h"
index 1b021527de6f60abf5704e002c5e1f56196a6743..d20904737f4f9ada5d4be9694442b237d124a50f 100644 (file)
@@ -27,6 +27,7 @@
 #include "dlinklist.h"
 #include "smb_server/smb_server.h"
 #include "smb_build.h"
+#include "ntvfs/ntvfs.h"
 
 /* the list of currently registered NTVFS backends, note that there
  * can be more than one backend with the same name, as long as they
index 8d2809cf6bb52bf4a5d04e59260fb04f4e9becaf..dc638ade5fdb896c5bebb5de6a19a7a5bb24fe49 100644 (file)
@@ -34,6 +34,7 @@
 #include "includes.h"
 #include "smb_server/smb_server.h"
 #include "librpc/gen_ndr/ndr_security.h"
+#include "ntvfs/ntvfs.h"
 
 /* a second stage function converts from the out parameters of the generic
    call onto the out parameters of the specific call made */
index 6a711bc3bd03d0664a5e5ccca4f655068e358690..788dcafaca6f7c4ed52362037deaf5863c4ac253 100644 (file)
@@ -21,7 +21,7 @@
 
 #include "includes.h"
 #include "smb_server/smb_server.h"
-
+#include "ntvfs/ntvfs.h"
 
 /* connect/disconnect */
 NTSTATUS ntvfs_connect(struct smbsrv_request *req, const char *sharename)
index e360321882bf33306930608d5dbe68679052fa9f..ad31865425f37b74bdbc4b2a242b378776ca1d18 100644 (file)
@@ -24,6 +24,7 @@
 #include "includes.h"
 #include "dlinklist.h"
 #include "smb_server/smb_server.h"
+#include "ntvfs/ntvfs.h"
 
 
 NTSTATUS ntvfs_async_state_push(struct smbsrv_request *req,
index 9eec368157d7cf4f493cf88f780fe790c8b8918e..dd2bf74543a85f42a9148ead7c9d3692e5711615 100644 (file)
@@ -25,6 +25,7 @@
 
 #include "system/filesys.h"
 #include "smb_server/smb_server.h"
+#include "ntvfs/ntvfs.h"
 
 /* this is the private structure for the posix vfs backend. It is used
    to hold per-connection (per tree connect) state information */
index c04cf76f332c7afa8df47beb5a7ed0da44eebac2..e933f5502bba062fb7667741af3ffe3ba3a9d8b9 100644 (file)
@@ -25,6 +25,7 @@
 #include "includes.h"
 #include "ioctl.h"
 #include "smb_server/smb_server.h"
+#include "ntvfs/ntvfs.h"
 
 /*
   connect to a share - used when a tree_connect operation comes
index ac5cf69e9a6f60a51a3e07572330c05782f5d080..d332abb09107e52bce27f1cdf245231c4629867b 100644 (file)
@@ -28,6 +28,7 @@
 #include "svfs.h"
 #include "system/time.h"
 #include "system/dir.h"
+#include "ntvfs/ntvfs.h"
 
 /*
   convert a windows path to a unix path - don't do any manging or case sensitive handling
index e9063c38c51f2cccc2ce1eda5e6f6565815e78ab..1198cafbe915b4832064a52e686a9c56b0295b48 100644 (file)
@@ -33,6 +33,7 @@
 #include "system/time.h"
 #include "dlinklist.h"
 #include "smb_server/smb_server.h"
+#include "ntvfs/ntvfs.h"
 
 #ifndef O_DIRECTORY
 #define O_DIRECTORY 0
index 928ff8241b27eba7006d37a8b45159f7af76ba04..8bdf732735ca013c2195abb9b6bab57074615640 100644 (file)
@@ -27,6 +27,7 @@
 #include "auth/auth.h"
 #include "librpc/gen_ndr/ndr_security.h"
 #include "smb_server/smb_server.h"
+#include "ntvfs/ntvfs.h"
 
 struct unixuid_private {
        struct sidmap_context *sidmap;
index 789fb7adbe164b8ece5e7ec1be26269485b61962..3bdb7015260264cea33c1cdb8d1463732f53f325 100644 (file)
@@ -242,6 +242,7 @@ sub Parser($$$)
        pidl "";
        pidl_hdr "/* autogenerated by pidl */";
        pidl_hdr "#include \"$baseheader\"";
+       pidl_hdr "#include \"tdr/tdr.h\"";
        pidl_hdr "";
 
        foreach (@$idl) { ParserInterface($_) if ($_->{TYPE} eq "INTERFACE"); } 
index 479d53da32575aa1a05cf7db82f4066b8e57ed94..1b2a9d355abbf56e068087ed903721160cfd724c 100755 (executable)
@@ -56,14 +56,14 @@ if (not defined($private_define) and defined($private_file)) {
 }
 
 if (defined($public_file)) {
-       open PUBLIC, ">$public_file"; 
+       open PUBLIC, ">$public_file" or die("Can't open `$public_file': $!")
        $public_fd = \*PUBLIC;
 }
 
 if ($private_file eq $public_file) {
        $private_fd = $public_fd;
 } elsif (defined($private_file)) {
-       open PRIVATE, ">$private_file"; 
+       open PRIVATE, ">$private_file" or die("Can't open `$private_file': $!"); 
        $private_fd = \*PRIVATE;
 }
 
@@ -128,6 +128,10 @@ sub process_file($$$)
 
                next if ($line =~ /^\/|[;]/);
 
+               if ($line =~ s/^_PUBLIC_[\t ]//) {
+                       $target = $public_file;
+               }
+
                next unless ( $line =~ /
                              ^void|^BOOL|^int|^struct|^char|^const|^\w+_[tT]\s|^uint|^unsigned|^long|
                              ^NTSTATUS|^ADS_STATUS|^enum\s.*\(|^DATA_BLOB|^WERROR|^XFILE|^FILE|^DIR|
@@ -142,10 +146,6 @@ sub process_file($$$)
                        next;
                }
 
-               if ($line =~ s/_PUBLIC_//xo) {
-                       $target = $public_file;
-               }
-
                if ( $line =~ /\(.*\)\s*$/o ) {
                        chomp $line;
                        print $target "$line;\n";
index 0810c29998ecedca3bd4c5818550b0f0029ea8e9..d41ec24acaa148ed329be83d6aed9745a234d086 100644 (file)
@@ -8,6 +8,7 @@ OBJ_FILES = \
                tcon.o \
                session.o \
                management.o
+PRIVATE_PROTO_HEADER = smb_server_proto.h
 REQUIRED_SUBSYSTEMS = \
                LIBPACKET \
                SMB_PROTOCOL \
index 215b378283c6844887d919bc12375ab73f237a28..7d5398671dfca73d9c2985ebf152d1bdfa20872a 100644 (file)
@@ -25,6 +25,7 @@
 #include "includes.h"
 #include "smb_server/smb_server.h"
 #include "librpc/gen_ndr/ndr_security.h"
+#include "ntvfs/ntvfs.h"
 
 
 
index 806244ee12e46c7493ddbd36bb407dd503d6a4b3..a7dde2163fc3b6d8f20302f2dcb7f7320bd1b8d0 100644 (file)
@@ -25,6 +25,7 @@
 #include "smbd/service_stream.h"
 #include "smb_server/smb_server.h"
 #include "lib/stream/packet.h"
+#include "ntvfs/ntvfs.h"
 
 
 /*
index d780cb1a7534b82abfb1fcc73692201548994c0c..644a5dd1a4dc9f1994f54454420cd16fd604e604 100644 (file)
@@ -26,6 +26,7 @@
 #include "includes.h"
 #include "smb_server/smb_server.h"
 #include "libcli/nbt/libnbt.h"
+#include "ntvfs/ntvfs.h"
 
 
 /* useful way of catching wct errors with file and line number */
index 5491089c8e09cc6c0186aa47162b7552828ef010..08e3eb74a552c882070c6ff330c29a683a402a0a 100644 (file)
@@ -28,6 +28,7 @@
 #include "smb_server/smb_server.h"
 #include "smbd/service_stream.h"
 #include "lib/stream/packet.h"
+#include "ntvfs/ntvfs.h"
 
 
 /* we over allocate the data buffer to prevent too many realloc calls */
index 3ec66a0f334ce4079fcbc2457bdfbc47c9bc34d9..e214d23e1850a4f9e820969e7bb1151eee9b4ca6 100644 (file)
@@ -24,6 +24,7 @@
 
 #include "includes.h"
 #include "smb_server/smb_server.h"
+#include "ntvfs/ntvfs.h"
 
 
 /* check req->async.status and if not OK then send an error reply */
index 6032e5a20d2eb300c6bab60018548c9f8f2f277f..f5ba1254d8044e41394facbf2f461883f752fa67 100644 (file)
@@ -21,6 +21,7 @@
 #include "includes.h"
 #include "smb_server/smb_server.h"
 #include "smbd/service_stream.h"
+#include "ntvfs/ntvfs.h"
 
 
 /**
index 6e4322d7b3f50e49691a411e95c8c5c07fba4da5..ef7fa40b201d7294da3e3336d6373b5f664508e8 100644 (file)
@@ -25,6 +25,7 @@
 #include "dlinklist.h"
 #include "smb_server/smb_server.h"
 #include "librpc/gen_ndr/ndr_misc.h"
+#include "ntvfs/ntvfs.h"
 
 #define CHECK_MIN_BLOB_SIZE(blob, size) do { \
        if ((blob)->length < (size)) { \
index 7f38119f2baa6c67af2245252417e63f90da1e72..d0df15e022f057871adc7efba5e1ef439a0ab2dc 100644 (file)
@@ -301,3 +301,5 @@ struct smbsrv_connection {
                BOOL nt_status_support;
        } config;
 };
+
+#include "smb_server/smb_server_proto.h"
index 0cb6738d31f669c818d470fa0152cb7563aa266a..01194d1ea1015b63a67ac87462534617ad358ea4 100644 (file)
@@ -24,6 +24,7 @@
 #include "dlinklist.h"
 #include "smb_server/smb_server.h"
 #include "smbd/service_stream.h"
+#include "ntvfs/ntvfs.h"
 
 
 /****************************************************************************
index a753a1668bb09d8a074ff0c3bbc5da0ed148ff69..7174084f13d9ab83d0dde99eb9886773d880b93e 100644 (file)
@@ -32,6 +32,7 @@
 #include "system/kerberos.h"
 #include "smb_build.h"
 #include "registry/registry.h"
+#include "ntvfs/ntvfs.h"
 
 /*
   recursively delete a directory tree