r18329: print out special make variables when failing, to track down the
authorStefan Metzmacher <metze@samba.org>
Sun, 10 Sep 2006 11:23:29 +0000 (11:23 +0000)
committerGerald (Jerry) Carter <jerry@samba.org>
Wed, 10 Oct 2007 19:18:10 +0000 (14:18 -0500)
build failures on older BSD systems with broken make

metze

source/main.mk

index 314d3587c22febd4ec49474e0be187ea5d202a2a..270c9b3ff5f9aeb610500c6c885225906105ed5b 100644 (file)
@@ -339,6 +339,9 @@ include/includes.d: include/includes.h
        @$(CC) `$(PERL) $(srcdir)/script/cflags.pl $@` $(CFLAGS) $(PICFLAG) -c $< -o $@ && exit 0;\
                echo "The following command failed:" 1>&2;\
                echo "$(CC) `$(PERL) $(srcdir)/script/cflags.pl $@` $(CFLAGS) $(PICFLAG) -c $< -o $@" 1>&2;\
+               echo "@: $@";\
+               echo "<: $<";\
+               echo "*: $*";\
                $(CC) `$(PERL) $(srcdir)/script/cflags.pl $@` $(CFLAGS) $(PICFLAG) -c $< -o $@ >/dev/null 2>&1
 
 .c.ho: