Remove obsolete comment.
authorJelmer Vernooij <jelmer@samba.org>
Mon, 25 Feb 2008 19:39:16 +0000 (20:39 +0100)
committerJelmer Vernooij <jelmer@samba.org>
Fri, 29 Feb 2008 13:07:29 +0000 (14:07 +0100)
source/rules.mk

index 62600e8d001f6f2609a0daf7a88eda5f4e2e3ec7..b644a6a52aab51586720b162db2fd6f083af556c 100644 (file)
@@ -10,14 +10,6 @@ HDEPENDS = $(CC) -M -MG -MP -MT $(<:.c=.ho) -MT $@ \
 PCHDEPENDS = $(CC) -M -MG -MT include/includes.h.gch -MT $@ \
     $(CFLAGS) $(CPPFLAGS) $< -o $@
 
-# $< is broken in older BSD versions:
-# when $@ is foo/bar.o, $< could be torture/foo/bar.c
-# if it also exists. So better use $* which is foo/bar
-# and append .c manually to get foo/bar.c
-#
-# If we have GNU Make, it is safe to use $<, which also lets
-# building with $srcdir != $builddir work.
-
 # Run a static analysis checker
 CHECK = $(CC_CHECKER) $(CFLAGS) `$(PERL) $(srcdir)/script/cflags.pl $@` \
     $(PICFLAG) $(CPPLAGS) -c $< -o $@
@@ -134,9 +126,11 @@ include/includes.d: include/includes.h
        @-mkdir -p `dirname $@`
        @$(COMPILE) && exit 0 ; \
                echo "The following command failed:" 1>&2;\
-               echo "$(COMPILE)" 1>&2;\
                $(COMPILE) >/dev/null 2>&1
 
+
+#              echo "$(COMPILE)" 1>&2;\
+
 .c.ho:
        @echo "Compiling $< with host compiler"
        @-mkdir -p `dirname $@`